Xwindow XDMCP DISPLAY issues

Discussion in 'Linux Networking' started by wg, Nov 18, 2015.

  1. wg

    wg Guest

    Greetings,

    I'm encountering a strange issue with remote xwindow XDMCP sessions.

    /etc/hosts on server1 and server2:
    192.168.1.88 SERVER1.MAGRO SERVER1
    192.168.1.89 SERVER2.MAGRO SERVER2

    On server1 I want to start an Xserver at VT8 and I type

    server1@root:~ > /usr/bin/Xorg :8.0 vt8 -query server2

    The display switches to an all black vt8.
    Switching back to vt7 I see the following lines (after ~60sec):
    ....
    Fatal server error:
    (EE) XDMCP fatal error: Session failed Session 34272013 failed for displa
    (EE)
    ....
    Note: 'displa' apparently is truncated.

    Then on server2, I find the following lines with journalctl:

    ....
    Nov 18 12:00:33 SERVER2 kdm[27950]: localhost:8[27950]: Cannot connect
    to localhost:8, giving up
    Nov 18 12:00:33 SERVER2 kdm[1113]: Display localhost:8 cannot be opened
    ....

    /etc/hosts on server2 same as on server1.

    On server2 the display should be SERVER1.MAGRO:8.

    It works the other way round, that is I get an Xserver on vt8 with
    server2@root:~ > /usr/bin/Xorg :8.0 vt8 -query server1
    an can login to an Xsession.
    echo $DISPLAY shows
    SERVER2.MAGRO:8

    Where and when is the variable DISPLAY set?
    In /etc I did a 'grep -r DISPLAY= *' but did not recognize anything
    suitable.

    Thanks for reading and any hints.
    Wolf
     
    wg, Nov 18, 2015
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.