XP preference to go for my neighbours WLAN 1st !

Discussion in 'Wireless Networks' started by willoxs, Jan 5, 2005.

  1. willoxs

    willoxs Guest

    Hi,
    has anyone else seen this behaviour?

    boot up laptop and it connects to my neighbours network rather than my own
    which preferred.

    My access point is only a few metres from the laptop - so much closer and
    greater signal strength.
    I have to force the connection to my system

    Brief set-up details
    Running XP SP1
    I have a WEP key configured on my system but neighbours is open
    I have my system as preferred or 1st choice

    not a big issue but really annoying
    Thanks for any help
    F
     
    willoxs, Jan 5, 2005
    #1
    1. Advertisements

  2. willoxs

    Malke Guest

    There is an option (possibly in Advanced settings) in the Wireless
    settings for Windows to only connect to preferred networks. Put a check
    in that and you won't connect to your neighbor's network.

    Malke
     
    Malke, Jan 5, 2005
    #2
    1. Advertisements

  3. willoxs

    Tony Guest

    Also use a different channel to your neighbour, Channels 1, 7 or 11 are the
    best for not overlapping.
     
    Tony, Jan 5, 2005
    #3
  4. Tony,

    Unfortunately, the solutions provided above are not adequate.
    There is a check box that states "Automatically connect to non-preferred
    networks" (in the Advanced dialog box), which will make your machine connect
    to any network. However, by default this is off. Please make sure that
    this is the case, as is not a good idea to have it checked.

    Now the only reason that the Wireless service would connect to your
    neighbors network is because it has the same name. If they were both called
    "Default" then the problem is pretty clear- we can't tell one from the
    other. Changing the SSID of your network in the AP and on your client will
    definitively fix your problem, as then they will appear as different,
    non-confusable networks.


    --
    Brian Wehrle

    Software Test Engineer/Wireless Networking
    Microsoft Corp.




    P.S. Changing the channel is also a good idea, if your neighbor is using
    the default (1), go to 7 or 11. However, this is not directly related to
    your problem.
     
    Brian Wehrle [MSFT], Jan 6, 2005
    #4
  5. willoxs

    Malke Guest

    Great catch, Brian. Serves me right for trying to remember the wireless
    settings when the laptop isn't on. Thanks. I'm betting that you're
    right about the SSID name. Most home users just leav it as "Linksys" or
    "Default" or whatever.

    Malke
     
    Malke, Jan 6, 2005
    #5
  6. Malke,

    It seems that there should be some better way to remember a network, like
    the ethernet address of the AP.
    However, since these can change, or there can be multiple AP's in a network
    the SSID is defined as the network identifier.
    It was very short-sighted of the manufacturers to use their current naming
    scheme (among other things, like the channel settings).

    I see very few cases of the above problem, surprisingly! I assume it will
    become more and more of a problem as time goes on.
    Brian
     
    Brian Wehrle [MSFT], Jan 7, 2005
    #6
  7. willoxs

    Pavel A. Guest

    Some manufacturers have proprietary setting to force the WLAN
    adapter to connect only to APs with certain BSSID (sometimes called "ethernet address" ).
    But unlikely that it is meant as remedy for naive users who can't configure
    their AP and WZC.
    --PA
     
    Pavel A., Jan 9, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.