XP Network ... help!

Discussion in 'Home Networking' started by Nick H., Jun 4, 2005.

  1. Nick H.

    Nick H. Guest

    Hi all.
    I have two PC's running XP Pro, and a broadband connection.
    One machine is connected directly to the LiveBox modem/router by RJ45, and
    the second is connected wirelessly. Both access the Internet no problem, but
    I cannot get the two PC's to network with each other.
    I have done all the wizard stuff a hundred times, with no joy. This has to
    be easy ... what am I doing wrong (or not doing right)?

    All help greatly appreciated.

    Cheers.

    Nick H.
     
    Nick H., Jun 4, 2005
    #1
    1. Advertisements

  2. What error do you get? Are you trying to connect from one PC to a shared
    drive/printer on the other?

    Things to check are:

    - Can one PC ping the other?
    * on one PC: Start | Run | cmd
    * on one PC: ipconfig
    * on one PC: (note the IP address)
    * on other PC: Start | Run | cmd
    * on other PC: ping 192.168.0.2 (assuming that's the IP address noted
    above)


    - If the PCs have software firewalls such as Norton Internet Security, has
    it been configured to regard the 192.168.x.x subnet as "friendly" and not to
    apply normal firewall rules to it? In Norton, it's under the Configure
    option of Personal Firewall, on the Network tabsheet

    - Does the LiveBox have "wireless isolation" to prevent two different PCs
    that connect via wireless talking to each other (the can only talk to the
    internet)? This *may* also prevent wired-to-wireless communication - not
    sure quite how this feature normally works.

    - Assuming that the PCs are not part of a domain (which would typically
    require a server in addition to the PCs) then you'll need to create users
    with the same username and the same password on the two different PCs and
    you'll need to set the share and directory permissions to allow the users
    read (and maybe write) access, depending on whether you want the users to be
    able to modify as well as read the contents of the other PC's shared
    drive(s).
     
    Martin Underwood, Jun 4, 2005
    #2
    1. Advertisements

  3. Nick H.

    Nick H. Guest

    Hi Martin, and thanks for such a swift reply.

    However ... :(

    I don't get an error, per se ... I simply cannot see the other machine. Each
    PC can only see itself on the 'network'.
    The C drives are shared on each PC.
    All firewalls have been uninstalled/disabled.
    The username and password is identical on both machines (administrator).
    Both PC's can ping each other.

    FYI, the PC's were previously networked:
    PC1 by USB direct to the modem/router and PC2 wirelessly.
    Now PC1 is connected by ethernet to the router ... PC2 still wirelessly.
    At a loss...

    Cheers.

    Nick H.
     
    Nick H., Jun 4, 2005
    #3
  4. Nick H.

    Christo Guest

    you did map the drive/folder your sharing files on?

    if both machines can ping then they are obviously connected

    are you sure its pinging properly?

    check all IP addresses and subnet masks, make sure you have drives map

    try going to run on a machine by clicking start and type the following

    \\192.168.x.x (ip address of the other machine) and press enter

    do you get any error messages? if so then something is wrong at a very basic
    level, like i mentioned IPs and subnet masks

    post back how you get on trying \\192.168.x.x in run

    HTH

    Christo
     
    Christo, Jun 4, 2005
    #4
  5. Nick H.

    Conor Guest

    Go into Windows Firewall/whatever firewall you're using and enable File
    and Printer Sharing as its usually blocked by default.

    If that still doesn't work try:
    Start, Run and enter \\<ip address of other machine>

    Can take a good few minutes for the other computer to appear in My
    Network.
     
    Conor, Jun 4, 2005
    #5
  6. Nick H.

    F9 Guest

    I was told earlier by this group to make sure both had a guest account
    active and .................. Bother. Cant remember the other thing.

    Do a google groups on this group for about 2/3 weeks ago and it will come
    up.

    By the way, worked first time after i did what i was told - shame that isn't
    true for everything.
     
    F9, Jun 4, 2005
    #6
  7. Nick H.

    Dr Teeth Guest

    Not necessary at all.

    My network is working 100% and my guest accounts are off.

    --
    Cheers,

    Guy

    ** Stress - the condition brought about by having to
    ** resist the temptation to beat the living daylights
    ** out of someone who richly deserves it.
     
    Dr Teeth, Jun 4, 2005
    #7
  8. Nick H.

    F9 Guest

    You are probably right, I'm only a newbie, but this was the advice I was
    given (below) and it worked for me.

    "Look at the WINS tab of the Advanced button of TCP/IP properties of
    each conenction and ensure "Use NetBIOS over TCP/IP" is checked

    Ensure you have either a) guest access enabled on all machines or b)
    the same username and password combination existing on all machines
    including use of only CAPITALS if any Win98 / ME machines are
    involved. Blank passwords may not work. Option a) is simpler.


    Phil "
     
    F9, Jun 4, 2005
    #8
  9. Nick H.

    Dr Teeth Guest

    Did not change the Win XP default here.
    Same username/password is not necessary. You'll just get asked for
    them when you try to login.

    I'm newish to this too...it seems that things don't work when the
    settings say they should...I think some reboots may be needed along
    the way.


    --
    Cheers,

    Guy

    ** Stress - the condition brought about by having to
    ** resist the temptation to beat the living daylights
    ** out of someone who richly deserves it.
     
    Dr Teeth, Jun 4, 2005
    #9
  10. Nick H.

    John Steele Guest

    There is a strange quirk in Windows file sharing since SP2. It is connected
    to the Windows Firewall. the symptoms are that your Workgroup is not visible
    on one of the computers in the local network. It is in fact the first one to
    be powered up. This should not happen and the fix seems illogical but it
    works fro me. This only applies if the Windows Firewall is active. A third
    party firewall that disables the Windows Firewall changes the behaviour.

    The following is a copy of a post I made on 15 April under the heading
    "Workgroup not accessible - fixed"

    I have been getting the message "Workgroup not accessible. You may not have
    permission to access..." intermittently on one of my computers name WK02.
    The other two computer in the workgroup are fine, although they are unable
    to see WK02 as members of the workgroup. They can still access shares and
    printers on WK02 even though they cannot browse the computer. All Workgroup
    computers are XP (2 running Pro, one running Home) with full updates.

    I have fixed the problem and have generated this post in the hope it will
    help someone else. It would also be interesting if any experts could give an
    explanation as to what is actually going wrong.

    I discovered that if one of the other two computers were switched on first
    (i.e. they became the master browser) then WK02 was visible to them and WK02
    could browse the workgroup correctly. If WK02 was switched on first (the
    normal situation as it is a desktop, the other two are laptops) then the
    workgroup browsing fails.

    After eliminating all other factors, and some research with Ethereal, I
    discovered that it was the Windows firewall that was blocking the UDP ports
    137 and 138. The Advanced setting for file and printer sharing was Own
    Network as one would expect. The firewall log showed these were being
    blocked. See below for port 138:

    2005-04-15 09:36:44 DROP UDP 192.168.x.101 192.168.x.255 138 138
    211 - - - - - - - RECEIVE

    This is a broadcast message being sent out to the subnet from 192.168.x.101
    and the receiving of this message being blocked by the firewall.

    I changed the setting to custom using the network setting of
    192.168.x.0/255.255.255.0 (x is the local subnet number) for both these UDP
    ports and SUCCESS. The computer now behaves as expected.

    I did try changing my network to a static IP address.
    I did try disabling my other firewall (Kerio 2.5.1) to eliminate that from
    the equation - no different
    I did try enabling and disabling the Windows firewall several times and
    found the results consistent

    My other two computers have alterative firewall products and these have
    disabled the Windows firewall. Everything else works.

    The question remains - why is putting a custom scope, set to my network
    address/subnet mask, any different from the default? I notice that the log
    shows a mask of 192.168.x.255 rather than the 255.255.255.0 that one would
    normally expect.


    I hope this might help somebody

    John Steele
     
    John Steele, Jun 4, 2005
    #10
  11. so maybe your system sets the appropriate flags. Networking won't work
    without NetBIOS so it seems a simple step to force it on on systems
    that aren't working.
    really ? if you print or share a file / directory there is no "login"
    you just get "permission denied" when you try to do something if it
    isn't happy with your credentials.

    Looking at remote print jobs running on my system they are owned by
    "Guest" so using the Guest account is one way to fix non-working
    systems where security gets in the way. Identikit usename / password
    combos are the other way.

    'net user' from a command prompt shows active users on a system,
    chances are that Administrator is common to both.

    Like most things windows is probably broken in this area, I set up a
    new system and it wouldn't network until I had the same user/password
    on both. Once it was working I could remove the user of the new
    machine and it has kept working ever since. Bizarre.

    Phil
     
    Phil Thompson, Jun 4, 2005
    #11
  12. Nick H.

    Dr Teeth Guest

    I find swinging a black cat around my children's heads
    (anti-clockwise) at sunset helps <g>.

    --
    Cheers,

    Guy

    ** Stress - the condition brought about by having to
    ** resist the temptation to beat the living daylights
    ** out of someone who richly deserves it.
     
    Dr Teeth, Jun 4, 2005
    #12
  13. Nick H.

    Conor Guest

    Yeah...due to the fact it's turned on by default and you manually have
    to enable Exceptions and select File and Printer Sharing.
     
    Conor, Jun 4, 2005
    #13
  14. Nick H.

    John Fryatt Guest

    This area seems confusing for something that ought to be fairly well
    sorted by now.
    I have 2 XP machines and 1 on Win 98. All can share resources with each
    other. I don't have identical user names/passwords.
    The bit that confuses me is that 'Control Panel/User Accounts' says
    Guest account is off, while 'Admin Tools/Computer Management/Local USers
    and Groups' says Guest account is NOT disabled.
    Note - CP applet uses 'on/off' terminology whereas Admin Tools applet
    uses 'disabled' (or not).
    So, what does that mean? Is Guest active or not? One interpretation
    could be that Guest is off for purposes of directly logging in, but is
    enabled for file sharing purposes. Any ideas?

    I suppose I should experiment really... :-{

    Amazing how Windows seeks to simplify things with nice panels and
    applets etc. but often only succeeds in making the whole thing more
    confusing.
     
    John Fryatt, Jun 5, 2005
    #14
  15. Nick H.

    Nick H. Guest

    Hi all ... and thanks beaucoup for all the input ... your time and trouble
    is really, really, appreciated.
    Sheesh ... how did we resolve problems before we had the Internet?
    (Actually, it's the 'net that's creating them, I suppose :)

    Anyway ... the story so far:

    On both machines (XP Pro SP2):
    I disabled XP firewall.
    Set up identical username/passwords.
    Turned guest accounts on.
    Checked "Use NetBIOS over TCP/IP" in WINS tab of the Advanced button of
    TCP/IP properties.
    Borrowed a black cat and some kids and swung according to instructions.
    Successfully, finally, mapped drives to see each other. Hoorah. This had
    been impossible before, even though each machine could ping the other
    successfully.

    I then backed out of each step, reversing the process ... still connected,
    no problem - until I turn the firewalls back on.
    So, no identical username/passwords, guest accounts are off, Windows default
    NetBios settings ... but the firewalls stop all communication between the
    two.

    I am obviously missing something very basic here, but it seems as if all the
    correct boxes are checked in the Firewall settings.
    On a possibly naive note, neither computer appears in 'My Network Places ...
    Entire Network ... blah ... blah'. They each only see themselves.

    I understand if ya'll fed up with this by now, but I'm not really happy
    working without the firewalls.

    Once again, MTIA.

    Nick H.
     
    Nick H., Jun 5, 2005
    #15
  16. Nick H.

    Nick H. Guest

    Hi all.

    Sorted ...

    Referring to John Steele's contribution to the thread, I played around in
    the XP firewall settings.

    Under 'Exceptions ... File and Printer sharing ... Edit' I have four ports
    listed:
    TCP 139 and 445, and UDP 137 and 138.
    (Are these standard on all PC's?)

    I changed the scope on all of them (was that necessary, or would changing
    only certain ports do it?) as per the snip from John's mail below:

    "I changed the setting to custom using the network setting of
    192.168.x.0/255.255.255.0 (x is the local subnet number) for both these UDP
    ports and SUCCESS. The computer now behaves as expected."

    and frigging voila!

    Once again, many thanks to all involved. I wish I could buy you all a
    pint...

    Cheers.

    Nick H.
     
    Nick H., Jun 5, 2005
    #16
  17. Nick H.

    John Steele Guest

    Once I had traced the cause - thanks to Ethereal! I did not have time to
    conduct the experiment of trying each of the ports in turn. It took long
    enough to diagnose the issue as it was. Setting all four ports is "safe". It
    is only setting the firewall to what it should have been set to in the
    first place.

    I am pleased that it helped. The problem had been irritating me for months.

    John Steele
     
    John Steele, Jun 5, 2005
    #17
  18. Nick H.

    F9 Guest

    I had turned windows firewall off as its not very good. I use a commercial
    firewall so it shouldn't have affected my ability to see the other computer.
     
    F9, Jun 6, 2005
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.