WOL not working consistently

Discussion in 'Home Networking' started by Endulini, Sep 24, 2013.

  1. Endulini

    Endulini Guest

    Hi,

    I've been trying to set up WOL on a Windows 8 system and am confident that
    it's configured ok as I can confirm that the Magic Packets are getting
    through and are recognised both through the internal LAN and over the
    Internet (using a combination of Magic Packet software and TeamViewer). The
    problem comes when I shut the system down or set it to sleep or hibernate.
    Whilst I can wake it remotely for the first 20 minutes or so after this it
    doesn't respond at all. I've disabled hybrid shut-down and have read that
    WOL isn't supposedly supported in shut-down or sleep but even putting it in
    hibernate doesn't help. It's set up with dynamic DNS so I'm also confident
    that it's not due to the IP changing.

    Anyone have any suggestions or comments?

    Thanks.
     
    Endulini, Sep 24, 2013
    #1
    1. Advertisements

  2. Endulini

    Rob Morley Guest

    Is the PSU maintaining standby power for the network port?
    Have you checked the correct options in the network card's Power
    Management settings?
     
    Rob Morley, Sep 25, 2013
    #2
    1. Advertisements

  3. Endulini

    Endulini Guest

    "Rob Morley" wrote in message
    The green light is on when the computer is off so presumably yes it is
    ..
    Management settings?

    "Allow this device to wake the computer" is selected
    "Allow the computer to turn off this device to save power" is selected (is
    that right?)
    "Only allow a magic packet to wake the computer" is selected.

    Can't see a problem here - is there anything in Power Management might
    inhibit it?
     
    Endulini, Sep 25, 2013
    #3
  4. Endulini

    Dave Saville Guest

    Wouldn't think so. If it's been turned off to save power how is it
    going to wake up except by re-application of power? It ain't goning to
    see any signal on the wire.
     
    Dave Saville, Sep 25, 2013
    #4
  5. Endulini

    Rob Morley Guest

    If it's on even when the machine doesn't respond then that doesn't seem
    to be the problem.
    I'd be inclined to switch that one off, but I'm only guessing and I
    don't have a Windows 8 machine to play with.
     
    Rob Morley, Sep 25, 2013
    #5
  6. Endulini

    Adrian C Guest

    In the router's configuration, as well as the port forwarding you may
    have done, You might need to _statically_ assign the MAC address of the
    PC's network card to the IP address used for it. This normally has to be
    done in CLI, overturning the dynamic assign which is forgotton a time
    after the PC powers off.

    Which router?
     
    Adrian C, Sep 27, 2013
    #6
  7. Endulini

    Adrian C Guest

    Ah, see here.

    http://talktalkmembers.com/t5/Unlimited-Broadband/HG533-Wake-on-LAN-problems/td-p/852729
     
    Adrian C, Sep 28, 2013
    #7
  8. Endulini

    Endulini Guest

    It's a Thomson TG587n v2 i.e. an O2 router (I know I've also posted a
    question about a TalkTalk router but that's a different story.....)
     
    Endulini, Sep 28, 2013
    #8
  9. Endulini

    Adrian C Guest

    Here ya go.

    http://npr.me.uk/wol.html
     
    Adrian C, Sep 29, 2013
    #9
  10. Endulini

    Endulini Guest

    Cheers Adrian. I've seen this and used it to successfully set my router to
    forward on the packets and I can see that the packets are getting through
    even from the internet. What is happening though is that after the computer
    has been 'asleep', powered down or 'hibernating' for longer than around 20
    minutes it doesn't reboot when the magic packet is sent. It's like it's only
    dozing initially and then something further powers off after 20 minutes and
    stops it from rebooting.....
     
    Endulini, Oct 1, 2013
    #10
  11. Endulini

    Adrian C Guest

    So you've done the arpadd stuff?

    e.g. arpadd intf=LocalNetwork ip=192.168.1.66 hwaddr=00:00:48:8f:03:9a

    Hmmm... me confused.

    Look at network card properties, advanced tab - there may be other
    settings there. Wake from power off, hybernate, sleep are all a
    minefield of known compatibility snags existing between BIOS, APM/APCI
    and OS. On some plaforms (e.g. HP Microserver) only wake from power off
    is properly supported.

    I've even come across slightly different implementions of the magic
    packet and differing port numbers. In windows powercfg.exe reveals a lot
    on current settings, and so does wireshark if you do some sniffing.
     
    Adrian C, Oct 5, 2013
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.