WLAN apache serve without WAN

Discussion in 'Network Routers' started by siogdc, Jun 11, 2010.

  1. siogdc

    siogdc Guest

    Hi all -

    I am trying to set up a simple system for a small meeting. I have a Mac
    running apache that will be connected either wireless or cabled to a
    wireless router (currently a D-link dir-655) on local IP address
    192.168.0.100. I was hoping to allow access to the site to anyone
    connected via the wireless. There will not be a WAN so no assigned IP
    address. I have tested with a few computers connected to the wireless
    but no luck connecting to the mac server - either ping, port scan, ssh
    or http. My main question is - can this even be done considering my
    equipment and config and without a WAN ip address? and if so, what might
    be wrong with my setup.

    ps - I can access the website if I am on a WAN and use the WAN ip
    address so I dont think it is the Mac firewall. and I do see all
    connected computers via the D-link web config interface.
    ie 192.168.0.101, 192.168.0.102 etc.

    Thanks very much ahead of time.

    DC
     
    siogdc, Jun 11, 2010
    #1
    1. Advertisements

  2. siogdc

    Char Jackson Guest

    Use a wired connection for the web server, if possible. Save the
    precious wireless bandwidth for the visitors who need it.
    Completely irrelevant. WAN connectivity isn't needed since the web
    server will be on the LAN.
    Are those same computers able to access the web server over a wired
    connection? If so, look at your wireless settings. If not, look at
    your IP addressing. If the web server and the client computers are all
    connected to the LAN side of the router, (which I assume they are),
    they must all be in the same subnet. OTOH, if the web server is by
    itself on the WAN side of the router, then it must NOT be on the same
    subnet as the client computers.
     
    Char Jackson, Jun 11, 2010
    #2
    1. Advertisements

  3. siogdc

    siogdc Guest

    Char -

    Many thanks -
    I have it working now. Good advice on testing the system cabled to the
    router. This helped to establish the initial connection. Bottom line -
    firewall issue on the server machine. I had it open for ssh (22) and web
    (80) - had to open to all access - not sure why (?) but I will tighten
    this before the meeting.

    Great advice on running the system wired to preserve wireless bandwidth!
    Thanks again -
    dc
     
    siogdc, Jun 13, 2010
    #3
  4. siogdc

    Char Jackson Guest

    Very cool, glad you got it sorted out!
     
    Char Jackson, Jun 13, 2010
    #4
  5. siogdc

    Aileen

    Joined:
    Jul 16, 2010
    Messages:
    5
    Likes Received:
    0
    Make sure your firewall is accepting incoming connections on port 80 (default HTTP port). Check the windows firewall settings (and other firewalls you might have) for this.
     
    Aileen, Jul 17, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.