Wireless Woe - Please Help

Discussion in 'Linux Networking' started by EliveUser, Dec 29, 2007.

  1. EliveUser

    EliveUser Guest

    In principal, i'd be very willing to just spend some money on another
    card and be done with it. Problem is, with wireless there's no guarantee
    that any piece of hardware will work out of the box with linux. Just
    google Dlink WNA-2330 and madwifi and you'll see what i mean. The fact
    that it worked for you doesn't mean it would work for me.

    And there are people out there who have got that damn linksys wmp54g
    working... grrr.
     
    EliveUser, Jan 1, 2008
    #21
    1. Advertisements

  2. EliveUser

    thunder Guest

    Have you tried connecting to any other access points? It seems to me the
    card is working, it's just not connecting to that AP. Personally, I'd be
    looking more at the router, than the card.
     
    thunder, Jan 1, 2008
    #22
    1. Advertisements

  3. EliveUser

    Unruh Guest

    I do appologize. My news server for some reason resurrected old posts and
    reposted them. I had originally answered your post, and seeing it again
    assumed that you felt you had not gotten answers and were posting again.
    Looking at the time stamps I realise it was my news server's fault ( and
    mine for not seeing the old date) Sorry.

    ....
    Anonymity? There is nothing anonymous about my posts. I have done an
    obvious munge of my name in a futile attempt to decrease the 100 spams I
    get per day, but my return email address is obvious to anyone who looks at
    it.
     
    Unruh, Jan 1, 2008
    #23
  4. EliveUser

    Unruh Guest

    Well, the big problem is taht the manufacturers feel free to put totally
    different chipsets into the modem and call it by the same name. Thus you
    might get one chipset and he might get the other. That is the
    manufacturer's fault.


    Which version?
     
    Unruh, Jan 1, 2008
    #24
  5. EliveUser

    ray Guest

    I believe that problem is usually due to changes in chipset during
    manufacturing runs. Mine is H/W Ver:A1 F/W Ver:1.0.
     
    ray, Jan 1, 2008
    #25
  6. EliveUser

    EliveUser Guest

    There's nothing wrong with staying anonymous when posting to the usenet.
    There is a danger however, when you know that you don't have to care
    about who the people are you communicate with (or what they think about
    you) of lowering ones usual standards of politeness.
    Even in your first response to my posting you very quickly assumed that
    i was an idiot who didn't know what he was doing. Well i'm not.

    I had and have a good reason for not permanently switching off
    encryption while piddling with my wmp54g. I share my router as an
    internet gateway with a neighbor and switching off encryption for longer
    periods would be disruptive to him. I especially did not want to do this
    just for the purpose of demonstrating that iwlist scan actually produces
    an "Encryption key: off" output on my machine when encryption is off.
    You should assume that people are telling the truth, unless you really
    have a reason not to. Makes communication a lot easier.
     
    EliveUser, Jan 1, 2008
    #26
  7. EliveUser

    EliveUser Guest

    I don't have any other access points i could connect the card to, but i
    know that the router is ok, since it is connected to several other
    clients in my network. My conclusion from looking all over the internet
    is that the problem is probably the driver software in connection with
    my kernel / distribution environment..
     
    EliveUser, Jan 1, 2008
    #27
  8. EliveUser

    Syren Baran Guest

    If you can ping the router thats a good thing (TM).
    You can manually configure the connection then.
    Simply:
    route add default gw routeripaddress
    echo "nameserver routeripaddress" >>/etc/resolv.conf

    That should be sufficient to to access the internet.
    BTW, does dhcp work for other wireless cards or only cable connected boxes?
     
    Syren Baran, Jan 1, 2008
    #28
  9. EliveUser

    EliveUser Guest

    I have the WMP54G Version 4.1 which uses a Ralink RT61 chipset. There
    seem to be three different ways to get this running.

    1. Use the serialmonkey open source native linux driver
    2. Use the windows driver provided by Ralink in connection with ndiswrapper
    3. Use a closed source native linux driver from Ralink

    If you look across the internet you will find many reports of different
    problems people have trying to get any of these alternatives to work but
    also reports of people who have been successful.

    I have so far tried alternatives 1 and 2. This thread was generated
    while trying to get ndiswrapper to work. I have also started to look
    into alternative 3 following this:

    http://www-personal.umich.edu/~mejn/rt61.html

    Unfortunately so far, i have not even managed to compile the Ralink
    driver and i won't have any time to further pursue this over the next 10
    days. But i'll give a report eventually should i be successful :)
     
    EliveUser, Jan 1, 2008
    #29
  10. EliveUser

    Unruh Guest

    I certainly did not want to give the impression that you are an idiot. I
    was however annoyed that you would give us information which did not
    correspond to what you are actually doing. It is hard enough to try to
    guess what could be going wrong without the poster also posting misleading
    information.

    Yes, and the evidence was that you were not telling the truth. You stated
    that encryption was off, and that the iwlist output was from when you were
    trying to connect. The evidence thus was that it was on. Thus one or
    the other of those was not the truth.
    And the most common reason for exactly the symptoms you describe is that
    encryption is on and you are using the wrong encryption key.

    Check also that wpa_supplicant is not running when you are trying to
    connect (left over perhaps )
    ..
     
    Unruh, Jan 1, 2008
    #30
  11. EliveUser

    EliveUser Guest

    Thanks, i'll try that next weekend (perhaps early next morning central
    european time). Can't do it now since i'm about to leave for a couple of
    days and don't have access to the machine in question just now.

    Currently the router assigns ip addresses as a dhcp server to several
    clients that are connected to a wireless bridge by cabel. That wireless
    bridge has a static ip address and connects to the router through
    wireless. It did use to connect to a pinnacle music streaming client
    directly per wireless though. So dhcp has worked for at least one
    wireless card in the past.
     
    EliveUser, Jan 1, 2008
    #31
  12. EliveUser

    EliveUser Guest

    hmm, ok i at least understand your reaction. I seem to remember from
    previous attempts at configuring wireless cards that wrong encryption
    keys would produce "authentification errors" or similiar...

    i'm pretty sure wpa_supplicant was still running every time i tried to
    connect. Because of the situation described above, i initially tried to
    connect with encryption (this is what my system does currently every
    time i boot). I then turn off encryption on the router and try to
    connect manually, but i certainly never killed wpa_supplicant before
    trying that...
     
    EliveUser, Jan 1, 2008
    #32
  13. EliveUser

    Syren Baran Guest

    I used the rt2x00 driver in conjuction with a rt2500 card a while back.
    Worked a lot better that than using ndiswrapper with the windows driver.
    Dont know about the rt61 though.
     
    Syren Baran, Jan 1, 2008
    #33
  14. EliveUser

    Unruh Guest

    I would suggest that you try killing it first and then connecting when no
    key is needed. It might interfere.
     
    Unruh, Jan 2, 2008
    #34
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.