Wireless Woe - Please Help

Discussion in 'Linux Networking' started by EliveUser, Dec 29, 2007.

  1. EliveUser

    EliveUser Guest

    I'm trying to connect my pc to my router unsuccessfully for a couple of
    days now and have run out of ideas. Perhaps somebody can help me along.

    I'm using a linksys WMP54G PCI card; the router is a linksys WRT54G. My
    OS is debian based Elive 1.0 (GEM) which uses a 2.6.18 linux kernel.

    Here's what i've done so far:

    Initially i tried the out of the box native rt61 driver pre-installed by
    Elive, which did not work at all (the wmp54g couldn't see the router).
    Next i used ndiswrapper. This would seem to have been reasonably
    successful. The driver and PCI card seem to be working and can see my
    router. I've put the outputs of

    1. $ lshw -C network
    2. $ ifconfig
    3. $ iwlist wlan0 scan
    4. $ iwconfig

    at the end of this posting. However when i try to connect with

    $ dhclient wlan0

    all i get is:
    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/wlan0/00:1d:7e:05:92:05
    Sending on LPF/wlan0/00:1d:7e:05:92:05
    Sending on Socket/fallback/fallback-net
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
    No DHCPOFFERS received.
    No working leases in persistent database.

    Sleeping.
    This is while trying to connect to an unencrypted network! So the
    problem has nothing (yet) to do with wpa.

    Any help appreciated. Here are the outputs mentioned above:

    1. $lshw - C network
    *-network:0
    description: Wireless interface
    product: RT2561/RT61 802.11g PCI
    vendor: RaLink
    physical id: 9
    bus info: [email protected]:09.0
    logical name: wlan0
    version: 00
    serial: 00:1d:7e:05:92:05
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ndiswrapper
    driverversion=1.28 firmware=Linksys, A Division of Cisco Sy latency=64
    link=yes multicast=yes wireless=IEEE 802.11g
    resources: iomemory:fe1e8000-fe1effff irq:201
    *-network:1
    description: Ethernet interface
    product: RTL-8139/8139C/8139C+
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: a
    bus info: [email protected]:0a.0
    logical name: eth0
    version: 10
    serial: 00:08:54:40:14:26
    size: 100MB/s
    capacity: 100MB/s
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical tp mii 10bt
    10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=8139too
    driverversion=0.9.27 duplex=full ip=192.168.1.105 latency=64 link=yes
    maxlatency=64 mingnt=32 multicast=yes port=MII speed=100MB/s
    resources: ioport:e800-e8ff iomemory:fe1e7c00-fe1e7cff irq:169
    2. $ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:08:54:40:14:26
    inet addr:192.168.1.105 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::208:54ff:fe40:1426/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:49 errors:0 dropped:0 overruns:0 frame:0
    TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:4156 (4.0 KiB) TX bytes:2092 (2.0 KiB)
    Interrupt:169 Base address:0xe800

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    wlan0 Link encap:Ethernet HWaddr 00:1D:7E:05:92:05
    inet6 addr: fe80::21d:7eff:fe05:9205/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:117 errors:0 dropped:0 overruns:0 frame:0
    TX packets:117 errors:0 dropped:12 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:13221 (12.9 KiB) TX bytes:16029 (15.6 KiB)
    Interrupt:201 Memory:fe1e8000-fe1f0000
    3. $ iwlist wlan0 scan
    wlan0 Scan completed :
    Cell 01 - Address: 00:14:BF:37:2C:00
    ESSID:"Meinert"
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.462 GHz (Channel 11)
    Quality:54/100 Signal level:-61 dBm Noise
    level:-96 dBm
    Encryption key:eek:n
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
    24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
    12 Mb/s; 48 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    Cell 02 - Address: 00:04:0E:D8:DB:23
    ESSID:""
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.462 GHz (Channel 11)
    Quality:23/100 Signal level:-81 dBm Noise
    level:-96 dBm
    Encryption key:eek:n
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
    6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
    36 Mb/s; 48 Mb/s; 54 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK
    Cell 03 - Address: 00:12:BF:E8:AB:C5
    ESSID:"Michis Netzwerk"
    Protocol:IEEE 802.11g
    Mode:Managed
    Frequency:2.472 GHz (Channel 13)
    Quality:70/100 Signal level:-51 dBm Noise
    level:-96 dBm
    Encryption key:eek:n
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
    12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
    48 Mb/s; 54 Mb/s
    Extra:bcn_int=100
    Extra:atim=0
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (2) : TKIP CCMP
    Authentication Suites (1) : PSK
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (2) : TKIP CCMP
    Authentication Suites (1) : PSK
    4. $ iwconfig
    wlan0 IEEE 802.11g ESSID:"Meinert"
    Mode:Managed Frequency:2.462 GHz Access Point:
    00:14:BF:37:2C:00
    Bit Rate:54 Mb/s Tx-Power:20 dBm Sensitivity=-121 dBm
    RTS thr:2347 B Fragment thr:2346 B
    Encryption key:eek:ff
    Power Management:eek:ff
    Link Quality:54/100 Signal level:-61 dBm Noise level:-96 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
     
    EliveUser, Dec 29, 2007
    #1
    1. Advertisements

  2. EliveUser

    thunder Guest

    Are you sure? iwlist wlan0 scan results say the encryption key is on.
     
    thunder, Dec 29, 2007
    #2
    1. Advertisements

  3. EliveUser

    Zebedee Guest

    yes, i have a second pc connected to a wireless bridge and am therefore
    turning encryption off only for short times. When generating the output
    for my posting, i had encryption on again, but i can assure you that the
    dhclient command produced exactly the identical results as posted when
    trying to connect to an unencrypted network.
     
    Zebedee, Dec 29, 2007
    #3
  4. EliveUser

    EliveUser Guest

    hmm, sorry for the identity confusion - also a consequence of working
    from different pcs. I'll keep posting as EliveUser in the near future ;-)
     
    EliveUser, Dec 29, 2007
    #4
  5. EliveUser

    thunder Guest

    Any other protections at the router? Do you have to add the mac
    address? What iwconfig command are you giving? Have you tried "iwconfig
    wlan0 essid "Meinert" ? Sorry, my experience is limited.
     
    thunder, Dec 29, 2007
    #5
  6. EliveUser

    Unruh Guest

    No it is not. If you look at the output of iwlist s you see that the
    network with essid Meinert has encryption on, and the output of iwconfig
    shows you are trying to connect to Meinert.




    i ^^
    See?
     
    Unruh, Dec 29, 2007
    #6
  7. EliveUser

    Unruh Guest

    And what else did you post that is not true? You want help but then post
    stuff you know is wrong.

    Are you really sure that there is no encryption key? Switch it off and
    leave it off. You are not going to bombarded in the day that you use.

    Fix one problem at a time.

    b)Try with a fixed IP address instead of dhcp. Maybe dhcp is badly set up
    on the router.
     
    Unruh, Dec 29, 2007
    #7
  8. Make sure that in the Kernel-config CONFIG_PACKET is set.

    Greets
    Chris
     
    Christoph Scheurer, Dec 29, 2007
    #8
  9. EliveUser

    EliveUser Guest

    I wasn't aware of that when i first posted it. Why do you assume so?
    Anyway, i went through the whole procedure several times with encryption
    turned off and with the same result.

    Tried that, same result with a static IP address as well. The router
    works fine and assigns IPs to several other gadgets in my network, so i
    would assume the problem must be specific to how the wmp54g communicates
    with the router.
     
    EliveUser, Dec 29, 2007
    #9
  10. EliveUser

    EliveUser Guest

    yup, the pci card knows which essid to connect to. The router broadcasts
    the ssid and it doesn't try to hide the mac address either...
     
    EliveUser, Dec 29, 2007
    #10
  11. EliveUser

    EliveUser Guest

    Phew, afraid i'm not savvy enough to follow you there. How would i do that?
     
    EliveUser, Dec 29, 2007
    #11
  12. EliveUser

    Unruh Guest

    Sorry, I am out of ideas. Clearly your system is communicating with the
    router (iwlist) but the router does not like your system.
    You could try putting your router onto a different freq (1 6 or 11 bands
    are the usual recommendation) to see if it is interference.
    Has your wireless card worked with anything?
     
    Unruh, Dec 29, 2007
    #12
  13. EliveUser

    Unruh Guest

    If you compiled your own kernel this might be a problem If you use a
    distro, do not worry about it.
     
    Unruh, Dec 29, 2007
    #13
  14. EliveUser

    EliveUser Guest

    hmm, yes i think switching freqs might be worth a try, since there seems
    to be someone else working on the same frequency as me in my neighbourhood.
    First thing i need to do though is go to sleep, since its already past
    midnight here in Germany ;-)

    The wireless card is new, i haven't tried it with anything else.
    Obviously i could also consider trying it out under windoze to see if
    its defective.

    I have noticed that similiar (similiar not identical) problems do seem
    to occur to other users of this card ever so often though. My last
    resort will be to remove ndiswrapper and the pre-installed native linux
    rt61 driver by serialmonkey and download and compile the linux firmware
    directly from ralink. Judging from the many postings i have googled so
    far on the subject, this seems to be a messy task i would have been
    happy to avoid.

    Thanks for your help, i'll post the solution here in case i find it.
     
    EliveUser, Dec 29, 2007
    #14
  15. EliveUser

    EliveUser Guest

    thanks. Didn't compile my own kernel....
     
    EliveUser, Dec 29, 2007
    #15
  16. EliveUser

    Unruh Guest

    Once again the scan shows that encryption is on. YOu have been told
    repeatedly to switch it off. You state that you have but everytime you post
    a scan it is on. You either do not know how to switch it off, or are
    purposely jerking us around-- why do you expect help in that case?


    ....
    .....
     
    Unruh, Dec 31, 2007
    #16
  17. EliveUser

    Syren Baran Guest

    Switch your address manually once iwconfig shows the connection, via
    ifconfig wlan0 same.as.router.someothernumber
    Ping the router, if that doesnt work check if your router surpresses
    ping/icmp. If it works, check the dhcp configuration on the router.
     
    Syren Baran, Dec 31, 2007
    #17
  18. EliveUser

    EliveUser Guest

    What are you talking about... "Once again (...)"?

    I haven't posted anything new since our last exchange 2 days ago. I told
    you that i got the same result:

    $ dhclient wlan0
    No DHCPOFFERS received.
    No working leases in persistent database.

    when trying to bring up wlan0 in an unencrypted network. The scan
    delivers no new information, except that it says "Encryption key: off"
    where below you can see "Encryption key: on". That is why i saw no point
    in posting it again. I may not be knowledgeable enough to solve this
    problem, but i certainly do know enough as to not waste other peoples time.

    And as for your last question, i don't expect your help. You are
    obviously a troll, who's main reason for posting here is to be
    disrespectful to others in the shelter of anonymity. Please go elsewhere
    or reconsider your manners.
     
    EliveUser, Jan 1, 2008
    #18
  19. EliveUser

    EliveUser Guest

    Thanks for your help. I can ping the router, ok. But its still
    impossible to connect with the internet. The router also works as a dhcp
    server and assigns ip adresses to other cards in my network - it just
    doesn't like the wmp54g.. :-(
     
    EliveUser, Jan 1, 2008
    #19
  20. EliveUser

    ray Guest

    So - get another card? I've found that using an Atheros based card with
    mad-wifi works very well. I'm currently using a Dlink WNA-2330.
     
    ray, Jan 1, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.