Wireless considerably faster one way than the other

Discussion in 'Wireless Internet' started by Dave Brown, Jun 15, 2006.

  1. Dave  Brown

    Dave Brown Guest

    Acer Travelmate laptop with built-in Intel 2200GB 802.11b/g wireless
    network adaptor, XP Pro.
    Netgear ME102 802.11b Access Point, plugged into network hub.
    2 more desktop machines plugged into the hub, both Win 2k, it's a 100Mb
    network.
    The Access Point is approximately 3 inches away from the laptop.

    I'm experiencing really bad network throughput at the laptop end, but
    have discovered that copying a large file from the laptop to one of the
    desktop machines is fast - the problem seems to be only when
    transmitting data TO the laptop. I get all sorts of network errors,
    including disconnections. Signal strength on the laptop is a full set
    of green bars when I look at the connection status, "excellent" when I
    hover over the tray icon.

    I downloaded QCheck, installed it on a desktop machine and the laptop.
    When I run a throughput test at the laptop, sending from the laptop to
    a desktop machine with 100kb packet size, I get roughly 5 to 6 Mbps,
    which as I understand is as good as you can expect from 802.11b.
    However, when I run the test from a desktop machine to the laptop, I
    get around 30 kbps. Yep, kilobytes per second. And that's when it
    works, most of the time the test fails - it only works reliably when I
    reduce the packet size down to, say 5kb, then it shows a throughput of
    about 1 Mbps.

    Anyone have any idea what could be causing this? I've tried all
    possible channel settings, and combinations of all other settings I can
    see.
     
    Dave Brown, Jun 15, 2006
    #1
    1. Advertisements

  2. Dave  Brown

    John Navas Guest

    That close may result in signal overloading in the radios.
     
    John Navas, Jun 15, 2006
    #2
    1. Advertisements

  3. Dave  Brown

    Dave Brown Guest

    No, the reason it's that close is because I wanted to rule out distance
    as a factor. They were originally about 30 feet apart.
     
    Dave Brown, Jun 16, 2006
    #3
  4. Dave  Brown

    John Navas Guest

    3" is too close.
     
    John Navas, Jun 16, 2006
    #4
  5. Dave  Brown

    Dave Brown Guest

    Thanks John, but I'm getting the same results regardless of the
    distance.

    Regards,
    Dave
     
    Dave Brown, Jun 16, 2006
    #5
  6. Dave  Brown

    John Navas Guest

    1. Restore all settings to default values.
    2. Don't use huge packets, which increases the cost of errors.
    3. Make sure the ME102 has the latest firmware.
    4. Use the latest Intel reference drivers and software for the 2200BG.
    5. Move the wireless units at least a few feet apart.
    6. Try testing with:
    (a) Iperf <http://dast.nlanr.net/Projects/Iperf/>.
    (b) Netio <http://freshmeat.net/projects/netio/>
    7. Check the Intel statistics after transmissions.
     
    John Navas, Jun 16, 2006
    #6
  7. Is the ME102 running the Netgear firmware, or has someone installed
    firmware from a DWL-900AP+ or WAP11?
    Too close. The receivers will overload at that distance. There are
    also some timing problems that appear at such a short distance. I'm
    not sure if there's a real minimum distance, but methinks about 12" or
    more is safe.
    Yep, been there. I've seen this when the 10baseT-HDX (half duplex)
    interface on the access point ends up with a different protocol than
    your network hub or switch. In particular, with a 10/100 hub or one
    of the Netgear FS-xxx series 10/100baseT switches. This does not
    cause disconnects, so that's probably not the problem.

    If you're using a 10/100 hub (not switch), I would certainly want to
    try using a 10baseT only hub, or a 10/100baseT switch, as the buffers
    in the dual speed hubs are always a problem. Going from 10 -> 100 is
    not a problem because the buffer can be emptied faster than the 10
    port can fill it. However, going from 100 to 10 requires that flow
    control and buffering work overtime. That's the way you get
    assymetrical performance.
    Maximum theoretical speed at 10Mbits/sec is 7.1Mbits/sec for UDP and
    5.9Mbits/sec TCP. Most benchmark tests use file transfers which are
    TCP. You're going as fast as 802.11b will go.
    Fine. Take the other potential sources of error out of the picture.
    Plug the desktop machine directly into the ME102 access point and try
    again. You might need a crossover ethernet cable.
     
    Jeff Liebermann, Jun 16, 2006
    #7
  8. Dave  Brown

    Dave Brown Guest

    Wow, thanks John & Jeff, I've obviously got a few things to try out
    there.
    I'll keep you posted, but thanks again in the meantime.

    Regards,

    Dave
     
    Dave Brown, Jun 16, 2006
    #8
  9. Dave  Brown

    DanS Guest

    Really stupid question.....what about a wired connection on this laptop ?
    What speeds do you see from that ?

    (Unless there isn't a wired connection of course.)
     
    DanS, Jun 16, 2006
    #9
  10. Dave  Brown

    Dave Brown Guest

    Really stupid question.....what about a wired connection on this laptop ?
    No, that's a perfectly acceptable question, unfortunately the answer is
    93Mbs in both directions. :(

    Regarding the other issues that Jeff & John brought up:
    Original Netgear firmware. There is an update available, but it doesn't
    mention anything critical as far as I can see. I'm, a bit reluctant to
    change it because a) I've seen a number of postings about these AP's
    being killed by upgrading firmware and b) I've had this AP for about 4
    years, and it used to work find with a different laptop/PCMCIA card.
    Yeah, I've just thought, I might dig out that old card and see if that
    fixes things - update see end of message.
    No change :(
    No change.
    Using Windows networking, how can I change the packet size?
    See answer above.
    Got to try that one yet.
    No Change.
    With desktop as server:
    ------------------------------------------------------------
    Server listening on TCP port 5001
    TCP window size: 8.00 KByte (default)
    ------------------------------------------------------------
    [820] local 192.168.0.1 port 5001 connected with 192.168.0.3 port 1555
    [ ID] Interval Transfer Bandwidth
    [820] 0.0-10.0 sec 3.82 MBytes 3.21 Mbits/sec

    With laptop as server::
    ------------------------------------------------------------
    Client connecting to 192.168.0.3, TCP port 5001
    TCP window size: 8.00 KByte (default)
    ------------------------------------------------------------
    [884] local 192.168.0.1 port 3320 connected with 192.168.0.3 port 5001
    read on server close failed: Software caused connection abort
    [ ID] Interval Transfer Bandwidth
    [884] 0.0-87.2 sec 48.0 KBytes 4.51 Kbits/sec
    I ran this in server mode on the desktop, client on the laptop.
    I tried it first with a wired connection, fine, I see the client both
    sends and receives, giving throughput for both.
    Then I tried in wireless mode. The laptop did a 1k block size
    transmission, 384 kbyte/sec, then simply hung up on reception, it never
    did anything else, even though the server end said it had sent.
    Is this to do with the reference drivers you mentioned?


    Update: I found my old PCMCIA card, and it produces practically
    identical figures on all tests. So that discounts the laptops built-in
    network adaptor.

    I've not really much idea about how wireless networks work, (I'm a
    software guy, always blame the hardware), but presumably each end has a
    transmitter and a receiver. I'm now guessing that the transmitter on
    the AP is bad. Is that feasible?

    Thanks for all your input so far, by the way,

    Regards,

    Dave
     
    Dave Brown, Jun 17, 2006
    #10
  11. Dave  Brown

    John Navas Guest

    Thanks for trying so many things -- that's very helpful, and serves to
    eliminate possible problems.

    Nonetheless, it is still important to upgrade the firmware, which you
    should be able to do safely -- just get the firmware directly from the
    manf website and follow instructions carefully. In general, upgrade
    firmware over a wired (not wireless) connection. Download from
    That can sometimes (not always) be done in the driver for the wireless
    adapter. But since you apparently haven't messed with it, that's
    probably not a problem.
    Might not help, but definitely worth trying. Be sure to uninstall the
    old drivers and software before installing. Download from
    Interesting. Did you abort that manually?
    Also interesting.
    That's in the Intel connection manager that installs at the same time as
    the drivers. The statistics (which show the speed profile for all
    packets as well as errors) should tell us a lot about what's actually
    going on.
    Yep. Really pointing to the ME102. Can you borrow a temporary
    replacement? If not, please do at least update the firmware.
    Yes, although both transmitting and receiving are involved
    (asymmetrically) in any transfer:
    Computer A Computer B
    data block 1 ->
    data block 2 ->
    <- acknowledge data block 1
    data block 3 ->
    <- acknowledge data block 2
    etc.
    You're a pleasure to work with, and very welcome.
     
    John Navas, Jun 17, 2006
    #11
  12. Dave  Brown

    Dave Brown Guest

    Hi John,

    Upgraded firmware. No change...
    No. This is what I've been seeing. If I try to send a large file (and
    by large, I mean >10k!) to the laptop using Explorer, it just hangs and
    hangs, then Windows reports that the network name is no longer
    available. Here, it just says connection abort.
    Note the interval in that printout - 87 seconds, whereas normally it
    runs for 10 seconds.
    Trying a copy from a command prompt, I get "error performing inpage
    operation", or "the semaphore timeout period has expired". Very small
    files do go over, and in fact I can - slowly - use the internet through
    it, presumably because small packets are involved.
    Nope, on my own here.

    Re the Intel drivers, I downloaded them (80 Mb?????!!!!!) and have them
    installed. Hasn't made any difference to the throughput - no better, no
    worse. Signal strength and quality both "excellent". I installed
    everything from the package, and now have wireless management under
    Intel control, rather than Windows. I'm looking at the advanced
    statistics. I tried to copy a 6 Mb file from (success) then to
    (failure) the laptop. Rather than typing it all out, I did some screen
    grabs here:

    http://davebrown.demon.co.uk/stats.gif
    http://davebrown.demon.co.uk/txrx.gif.gif

    Obviously the transmission stats show the full 6Mb, while the reception
    shows it only got 300k and is using the lower rates more, but apart
    from that I can't see anything bad. Any ideas?

    Regards,

    Dave
     
    Dave Brown, Jun 17, 2006
    #12
  13. Dave  Brown

    Dave Brown Guest

    Dave Brown, Jun 17, 2006
    #13
  14. Dave  Brown

    John Navas Guest

    No local dealer that accepts returns? You may need to replace the ME102
    in any event.
    I know, I know. [sigh]
    Lots of errors, which is what's presumably causing the speed fallback.
    I'd think seriously about replacing the ME102, which is pretty ancient
    in any event.
     
    John Navas, Jun 17, 2006
    #14
  15. Dave  Brown

    Dave Brown Guest

    Lots of errors, which is what's presumably causing the speed fallback.
    Ah well, I had this feeling it would come to this. I suppose it gives
    me an excuse to go to 802.11g anyway...

    Thanks again, I really appreciate your help.

    Dave
     
    Dave Brown, Jun 17, 2006
    #15
  16. Dave  Brown

    dold Guest

    What about taking the laptop to a nearby WiFi hotspot?
    Starbucks has a free day pass.
     
    dold, Jun 17, 2006
    #16
  17. Dave  Brown

    Dave Brown Guest

    What about taking the laptop to a nearby WiFi hotspot?
    Nice idea, but I'm nowhere near one. Actually one of my neighbours has
    a wifi connection, I can see it. I just don't know who it is!
     
    Dave Brown, Jun 17, 2006
    #17
  18. Dave  Brown

    John Navas Guest

    Free day pass?! All of them, or just some?
     
    John Navas, Jun 19, 2006
    #18
  19. Dave  Brown

    dold Guest

    dold, Jun 19, 2006
    #19
  20. Dave  Brown

    dold Guest

    The opening page says 2004, but if you "sign up now" at the bottom of the
    page, the next page says "Offer expires January 31, 2007".
     
    dold, Jun 19, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.