Wireless connection says excellent but not working

Discussion in 'Wireless Networks' started by sally, Apr 3, 2009.

  1. sally

    sally Guest

    Hi, I have a Toshiba laptop and have a home network which uses a wireless
    router. My wireless laptop says internet connection excellent; however, when
    I log on to internet explorer the page cannot be displayed, and I can't get
    on the internet. Any help to be appreciated.
     
    sally, Apr 3, 2009
    #1
    1. Advertisements

  2. sally

    David B. Guest

    What changed on your laptop between when it was working and now? Your
    problem could be caused by a bad configuration, wireless driver, malware, or
    any number of other issues.
     
    David B., Apr 3, 2009
    #2
    1. Advertisements

  3. sally

    Chuck [MVP] Guest

    Your wireless laptop says "Signal strength excellent". That doesn't say that
    you have Internet connectivity. Look at some details, please.

    * Is this your WiFi access point?
    * Are there any signal interference sources inside your home?
    * Is your WiFi security setup properly?
    * Is your selected WiFi channel available?
    * Have you run a WiFi environment survey?
    * Have you tried using Ethernet?

    http://networking.nitecruzr.net/2009/04/getting-internet-service-requires-more.html
     
    Chuck [MVP], Apr 3, 2009
    #3
  4. sally

    Jack-MVP Guest

    Jack-MVP, Apr 3, 2009
    #4
  5. sally

    sally Guest

    Well, I did install one of those free SuperAnti Spyware removers on my laptop
    because I did have a virus.
     
    sally, Apr 4, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.