Wireless card 'ifup: operation failed'

Discussion in 'Linux Networking' started by Lord Vain, Apr 13, 2006.

  1. Lord Vain

    Lord Vain Guest

    Debian based Linux:

    I'm trying to get my RT2500 based wifi card working but it the 'ifup ra0'
    command always returns: 'operation failed'

    The /etc/network/interaces looks somewhat like this

    auto ra0
    iface ra0 inet dhcp
    wireless-essid MyESSID
    wireless-key 12345678
    wireless-channel 5

    First problem is that the interface ra0 doesn't come up automatically during
    boot. The script therefore doesn't work and I have to start it by hand:

    ifconfig ra0 up

    Does anyone know in what script I need to add a 'ifconfig ra0 up' command?

    Once it's up I can check it with the 'ifconfig' and 'iwconfig' commands.
    That works fine but the interface isn't configured.

    Now I do a :

    ifup ra0

    but I it returns (after 10 seconds or so):

    operation failed.

    That's it, no error indication. Is there a log file where I can view what
    the problem is?


    *** ***
     
    Lord Vain, Apr 13, 2006
    #1
    1. Advertisements

  2. Does your rt2500 module get loaded? ("make install" should make sure it
    does)

    If you change the script in /etc/modprobe.d/wireless by adding the
    following line:

    options rt2500 debug=5

    and run update-modules, then you will get logging in /var/log/kern.log
    and /var/log/messages

    Robert
     
    Robert Harris, Apr 13, 2006
    #2
    1. Advertisements

  3. Lord Vain

    Lord Vain Guest

    There isn't a /etc/modprobe.d/wireless file on my system so I can't take
    your advice.

    I think I've figured out that the 'Operation failed' message is actually
    coming from the 'pump' DHCP client. Does that ring a bell with anyone?


    *** ***
     
    Lord Vain, Apr 14, 2006
    #3
  4. Lord Vain

    Unruh Guest

    Which "operation failed" You have no idea tht went wrong, but you think
    that you can selectively report from the full thing and that your
    selection will be an accurate indication of the problem.


    On which operating system? And why in the world would you specify the
    channel?

    Probably the module is not loaded.
    Make sure that th emodule is getting loaded.
    lsmod


    ? ifconfig will do absolutely nothing of any worth. Your system has to load
    the module to run your wireless card. That module then selects and
    interface. Not you.

    None. That is not the problem.

    And if you do
    iwlist s
    do you get any reports of anything?

    And your system is what? Almost all distributions use slightly different
    ways of setting up . modprobe.d is in Debian based systems. The Linux
    kernel people use modprobe.conf


    If the previous line says
    getting dhcp address: Operation failed
    then yes, the problem is getting a dhcp address. It may have nothing to do
    with your card at all.


    lsmod
    and look for your module driver for the card
    iwlist s
    and look for reports of wireless access points.
    ifup <name of the interface reported by iwlist to have access points>
    Then look at
    iwconfig
    to see if it is connected to the access point.

    If all of the prvious work then it is dhcp. Perhaps you forgot to set up
    your wireless router to run dhcp.

    (I have found dhclient better than dhcpcd but I have not tried pump.)
     
    Unruh, Apr 14, 2006
    #4
  5. Lord Vain

    Lord Vain Guest

    If I do 'ifconfig' I only get the loopback interface 'lo.' I have to do
    'ifconfig ra0 up' before I see the 'ra0' interface with 'ifconfig'. Also,
    the 'ifup ra0' call will simply fail with 'ignoring unknown interface ra0'
    if I don't do this. The module 'rt2500' is loaded (aliases to 'ra0') is
    loaded, that's for sure.
    I don't see any messages in dmesg pertaining to my 'ra0' interface.

    It's Damn Small Linux, a Debian derivative.
    No, but if I bring up the interface ra0 with 'ifconfig ra0 up' and then do a
    '/sbin/pump' I get the exact same message: 'Operation failed.' with
    identical capitalization and punctuation, so I'm guessing it's actually
    coming from 'pump', but I'm not 100% sure.
    If I set the interface manually with 'iwconfig key' and iwconfig essid' the
    card connects to the AP but I don't get an IP (checking with ifconfig).
    No, the AP is correctly configured, Windows clients connect with DHCP.


    *** ***
     
    Lord Vain, Apr 14, 2006
    #5
  6. Lord Vain

    Unruh Guest

    I do not care what it is aliased to. Unfortunately Linux does not pay any
    attention to those aliases it seems.

    a)
    rmmod rt2500
    modprobe ra2500
    dmesg|tail
    to look for things wich may give you a hint about the card.

    Then do
    iwlist s


    AND IF YOU DO iwlist s DO YOU GET ANY REPORTS OPF ANYTHING?

    Sheesh. Do you really want help? Please try the things that people suggest.


    You really selectively read.

    Why do you thing your interface is called ra0?





    Of course not.

    Again, do
    iwlist s
    first.


    Try using dhclient instead of pump.

    But it may still be that you have not set stuff up properly on the router.
     
    Unruh, Apr 15, 2006
    #6
  7. Lord Vain

    marcrho Guest

    Have you tried to load the RT2570 module? I repeatedly hit my head against
    the wall trying to get a D-Link Wireless USB adapter working in Ubuntu
    with the RT2500 driver and then I came upon this article -->
    http://www.ubuntuforums.org/showthread.php?t=106846

    And here is the home page rt2570 -->
    http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page

    You may not be using Ubuntu but the gist is that you may need to use the
    RT2570 module instead of the RT2500 module. Worked for me (after a full
    day of trying and crying).

    Are you familiar with the modules tools (modprobe, lsmod, depmod, etc.) to
    check for/load the device module?

    MR
     
    marcrho, Apr 22, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.