Wired LAN works, Wireless on same machines does not. (longish post)

Discussion in 'Broadband' started by -halli-, Apr 17, 2004.

  1. -halli-

    -halli- Guest

    I am close to launching the bloody things through the window!

    Here is the spec.

    Origo ADSL router ASR 8400 (4 port wired)
    Desktop PC Windows XP pro SP1 Norton Internet security 2004
    Laptop PC Windows XP pro SP1 Norton personal firewall 2003

    Both connected to the router *wired* with router assigned IP addresses and
    using the ORIGO Ethernet setup program

    IP Desktop 10.0.0.7 Laptop 10.0.0.4 Subnet mask 255.0.0.0 gateway 10.0.0.2
    (these work fine if I input them and set the Router to not assign the IP
    addresses as well.)

    All works fine, file sharing, printer sharing and both connect to the net
    using the router.

    I have disabled simple network sharing, enabled guest with a password but
    the computers will not allow me to access the workgroup. This is a pain, but
    not the point of the post.

    Wireless configuration:

    Same computers, cat5 cable removed from laptop.

    Desktop has a ZyDas ZD1201 wireless USB adapter and is connected to the
    ORIGO router using Cat5
    Laptop has a Level One 11Mbps 32bit Wireless PCMCIA adapter

    I followed the tutorial on
    http://www.microsoft.com/windowsxp/expertzone/columns/bowman/02april08.asp
    and the wireless cards see the SSID and seem to connect. When hovering over
    the connection icon in the start bar I get a message Wireless Network
    Connection (Peer to Peer) Speed:11Mbps Signal Strength: Excellent.

    I ran the internet sharing wizard and rebooted.

    Desktop connected to Router Via cable Works fine on the Internet, No file
    sharing, no printer sharing
    Laptop - Nothing. No file sharing, no printer sharing, Can not Ping the
    other computer, no Internet.

    Bugger.

    I have spent all day on this and I am very fed up.

    Could some kind soul out there please tell me the error of my ways and how
    to fix it?

    I have networked many peer to peer computers using Win 95/98 and cat5/hubs
    etc (suites of 20+computers). I am quite new to Windows XP.

    Cheers

    -halli-
     
    -halli-, Apr 17, 2004
    #1
    1. Advertisements

  2. -halli-

    aj Guest

    Have a check and see if Win XP has added a network bridge by default in the
    network conections screen -
    I had what sounds like an identical issue with XP, in my case deleting the
    bridge cured it.
    It was XP trying to be clever and messing it up when I fitted two network
    device to the same PC (Wireless and ethernet).
    May not be the case for you but it worked for me (like so many things in
    life!!)

    AJ
     
    aj, Apr 17, 2004
    #2
    1. Advertisements

  3. -halli-

    John Kelly Guest

    Could it be a firewall problem?

    When I switched to a router with built in firewall I found that I had to
    uninstall Zone Alarm. Just stopping it running didn't work (presumably it
    was also running a process)
     
    John Kelly, Apr 17, 2004
    #3
  4. simple, the ICS wizard will have set the desktop sharing interface to
    be 192.168.0.1 thereby making it invisible to a laptop assigned
    10.x.y.z addresses

    change that manually and you're away.

    you will also have to tell the laptop to use the desktop as its
    default gateway I think

    Phil
     
    Phil Thompson, Apr 17, 2004
    #4
  5. -halli-

    -halli- Guest


    Thanks for the reply, I have tried with and without bridges without
    success. :-(

    -halli-
     
    -halli-, Apr 17, 2004
    #5
  6. -halli-

    -halli- Guest

    It is not a problem for the wired connection, could it be a problem for only
    the wireless connection? I will try this before smashing the PC into bits
    :)

    Thanks

    -halli-
     
    -halli-, Apr 17, 2004
    #6
  7. -halli-

    -halli- Guest

    Yes, I thought that too. It didn't work :-(
    So is this the IP of the wireless adapter or the ethernet adapter connecting
    the PC to the router?

    Thanks for the reply

    -halli-
     
    -halli-, Apr 17, 2004
    #7
  8. the laptop needs to have the IP address of the desktop running ICS as
    its default gateway. This will be the IP address of the wireless
    adaptor on the desktop as the laptop can't see the ethernet card or
    the router unless the PC routes it from the wireless.

    What IP addresses do the desktop and laptop have now on their various
    adaptors ? Can you ping around the network.

    Phil
     
    Phil Thompson, Apr 18, 2004
    #8
  9. -halli-

    -halli- Guest

    Here is the latest one!

    MainPC

    Windows IP Configuration



    Host Name . . . . . . . . . . . . : 1xp1800

    Primary Dns Suffix . . . . . . . :

    Node Type . . . . . . . . . . . . : Unknown

    IP Routing Enabled. . . . . . . . : No

    WINS Proxy Enabled. . . . . . . . : No



    Ethernet adapter Network Bridge (Network Bridge) 13:



    Connection-specific DNS Suffix . :

    Description . . . . . . . . . . . : MAC Bridge Miniport

    Physical Address. . . . . . . . . : 02-0A-E6-15-32-2D

    Dhcp Enabled. . . . . . . . . . . : Yes

    Autoconfiguration Enabled . . . . : Yes

    IP Address. . . . . . . . . . . . : 10.0.0.10

    Subnet Mask . . . . . . . . . . . : 255.0.0.0

    Default Gateway . . . . . . . . . : 10.0.0.2

    DHCP Server . . . . . . . . . . . : 10.0.0.2

    DNS Servers . . . . . . . . . . . : 10.0.0.2

    Lease Obtained. . . . . . . . . . : 17 April 2004 21:20:05

    Lease Expires . . . . . . . . . . : 18 April 2004 21:20:05

    LaptopPC


    Windows IP Configuration



    Host Name . . . . . . . . . . . . : Laptop1

    Primary Dns Suffix . . . . . . . :

    Node Type . . . . . . . . . . . . : Mixed

    IP Routing Enabled. . . . . . . . : No

    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection 2:



    Connection-specific DNS Suffix . :

    Description . . . . . . . . . . . : Realtech RTL8181 wireless LAN
    (mini-) PCI NIC

    Physical Address. . . . . . . . . : 00-50-fc-d0-73-72

    Dhcp Enabled. . . . . . . . . . . : No

    IP Address. . . . . . . . . . . . : 10.0.0.5

    Subnet Mask . . . . . . . . . . . : 255.0.0.0

    Default Gateway . . . . . . . . . : 10.0.0.10

    No. the desktop attached to the router can ping the router but not the
    laptop, the laptop pings nothing.

    -halli-
     
    -halli-, Apr 18, 2004
    #9
  10. -halli-

    -halli- Guest

    Just tried again. I can see the laptop in the view workgroup (from the
    desktop) but on double clicking it says I do not have permissions and the
    path was not found.

    this is the ping:

    Pinging 10.0.0.5 with 32 bytes of data:

    Destination host unreachable.
    Destination host unreachable.
    Destination host unreachable.
    Destination host unreachable.

    Ping statistics for 10.0.0.5:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    The request times out from the laptop to the desktop and the desktop is not
    visible in view workgroup computers.

    -halli-
     
    -halli-, Apr 18, 2004
    #10
  11. so ICS didn't take.
    should be no if you're fixing it manually. Otherwise might get a
    dfiferent address.
    looks good, apart from risk of router DHCP doling out a different IP.
    what happened to settings of the wireless adapter in the desktop ??
    10.0.0.10 is the address of the wired ethernet adapter on the desktop,
    not the wireless USB. Problem.

    ICS did not get set up and the wireless NIC details are missing from
    the desktop's wireless USB adaptor.

    Also I would turn all that security stuff off completely (uninstall
    it) until you get it fixed. One elss thing to worry about / diagnose.

    You may have bridged the wired ethernet to the wireless USB, if so
    remove the bridging and try the ICS wizard again (followed by
    resetting the IP of the desktop manually into the right range).
    I would expect to see two NICs and not just
    when you have two NICs visible ICS should ask which one is the
    internet and which one is the LAN

    Phil
     
    Phil Thompson, Apr 18, 2004
    #11
  12. -halli-

    -halli- Guest

    It is part of the bridge. Wireless and Ethernet are bridged together. I have
    ran "netsh" from the command prompt to enable both connections in the
    bridge.
    And the wireless as they are bridged.
    Did that. I tried everything on a Win98SE machine and the same laptop and it
    works fine (not tried sharing internet though). I have come to the
    conclusion that it is a driver problem for the USB adapter, though I can not
    find the updated drivers anywhere - It seems that www.zydas.com does not
    exist anymore.
    Yes it did, but the above is the result. The thing is, file sharing does not
    work even if I disable the wired LANs of each machine and set the IPs to
    auto configure (or set them manually). It does work on the Win98SE and XP
    combination so I think it is the driver for the XP machine with the USB
    dongle.

    Thanks for your help, it is much appreciated.

    (If you pop over to microsoft.public.windows.networking.wireless you will
    see the whole sorry story!)

    -halli-
     
    -halli-, Apr 18, 2004
    #12
  13. I believe you should not be bridging the two, so they don't appear as
    one composite entity. Forget about file sharing until you have the IP
    connectivity running

    I have shared with ICS using a laptop plugged into a hotel high speed,
    the two were not bridged and I was therefore able to select which one
    was the internet and which was the LAN.

    If you bridge the two into a single IP address it is not possible for
    ICS to route from one to the other, surely ?

    Give it another try with bridging turned off

    Phil
     
    Phil Thompson, Apr 19, 2004
    #13
  14. perhaps because 98 doesn't do bridging ?

    Phil
     
    Phil Thompson, Apr 19, 2004
    #14
  15. -halli-

    -halli- Guest

    OK, tried everything suggested and still nothing. I am now almost 90% sure
    it is a driver issue with winXP. I have uninstalled all Nicks from both
    machines and reinstalled them from scratch. Disabled the Firewire and wired
    LAN on each machine. Set the static ip of the host to 192.168.0.2 and the
    client to 192.168.0.3 both with a Subnet mask of 255.255.255.0 I have tried
    each adapter on every channel available and even tried using the
    configuration utilities that came with the adapters to see if that makes a
    difference.

    Still no connection to see the other computer in workgroups. Everything
    still works fine with the Client connected to the Win98SE machine.

    My next thought was to uninstall all recent uninstallable windows updates,
    anything is worth a try!

    Thanks for your support

    -halli-
     
    -halli-, Apr 19, 2004
    #15
  16. -halli-

    -halli- Guest

    I didn't try internet sharing on the 98SE machine as it is too far away from
    the router.

    -halli-
     
    -halli-, Apr 19, 2004
    #16
  17. -halli-

    -halli- Guest

    OK, tried everything suggested and still nothing. I am now almost 90% sure
    Yeeeeeeeehaaaaaaaaaaaaaaaaa!!!!!!!!!!!

    It works - it really works!

    I don't know what I did, but it bloody works!

    I uninstalled everything again, reinstalled (this time used a different USB
    port - could that make a difference?) and it bloomin flippin works, even
    internet sharing - without bridges.

    Thank you so much for all of your help and have a Virtual pint on me (the
    next round is yours)

    Cheers

    -halli-
     
    -halli-, Apr 20, 2004
    #17
  18. I have seen various USB devices work in one port of a laptop after
    failing in another. The ports may not be on the same controller, also
    sometimes things don't like sharing a controller with certain other
    things.

    What was the final working config - bridged or separate IPs for the
    thernet and the wireless ?

    Phil
     
    Phil Thompson, Apr 22, 2004
    #18
  19. -halli-

    alan Guest

    Not sure if this will help but I have been having a similar sort of
    problem with an Origo wireless network, I un-ticked the box that said
    let xp manage my wireless connections and hey presto it started
    working....
     
    alan, Apr 23, 2004
    #19
  20. -halli-

    -halli- Guest

    It's the only thing I can think that it was. Nothing was workign and when I
    changed USB port it did! I am having another mare with internet sharing at
    work with the sam laptop and a desktop with WinME (ugh!). Internet
    connection sharing seems more of a nightmare on WinME than on XP! The laptop
    can be seen by the desktop (worryingly without the password required by my
    XP machine at home!) but the laptop does not see the desktop or the
    Internet. I feel a late night at work coming on next week!
    HOST: Ethernet shared getting IP from router, firewire disabled, Wireless
    set to auto IP.
    CLIENT: Ethernet getting IP from router if connected, firewire disabled,
    wireless set to auto IP from HOST, Shared Ethernet Internet connection
    visible in Network Connections.

    Cheers,

    -halli-
     
    -halli-, Apr 23, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.