Windows 2000, Linksys Wireless G 2.4 Ghz WPC54GS v2 2 days trouble installingand working

Discussion in 'Wireless Internet' started by Ritter197, Dec 27, 2006.

  1. Ritter197

    Ritter197 Guest

    I am trying to install for one of my grandchildren a Linksys WPC54 GS v.2
    Wireless card Adapter with Windows 2000 and have nothing but trouble with
    it. I downloaded from the Linksys site the latest driver and software v.
    2.02 and it seems to install normally, but when you insert the card you
    cannot connect to the internet.

    I have my own laptop with a D-link adapter and it connects wirelessly
    without a problem.

    Linksys technical support has also not been helpful, knowledgeable enough to
    successfully assist.

    Maybe someone here has the same configuration and has an answer, I hope.

    Thanks in advance
     
    Ritter197, Dec 27, 2006
    #1
    1. Advertisements

  2. Holdit. Connecting to the internet is the LAST step in the process.
    Let's rewind and start from the beginning. Some rhetorical questions:
    1. Did the software install correctly?
    Right click on My Computah and select Properties.
    Hardware -> Device Manager
    Is the WPC54GS listed?
    If not, uninstall, reboot, and reinstall, this time following the
    instruction where it says to shove in the card AFTER you load the
    software. (This is the most common error).

    2. If the software appears to be installed correctly, does plug-n-pay
    recognize the card? Same test as above.

    3. Is there an icon that vaguely looks like a wireless antenna in the
    system tray (lower right of screen)? If so, right click, and select
    "View available networks". See any SSID's? If yes, it's working. Try
    to connect.

    4. If nothing is visible, are you broadcasting your SSID on your
    unspecified model access point? If not, turn it on and leave it on.

    5. From this point on, you should be able to connect. If not, kindly
    describe your setup. If using WEP, use the Hex key, not the ASCII
    key. If possible switch to WPA for better security and no Hex
    hassles.
     
    Jeff Liebermann, Dec 27, 2006
    #2
    1. Advertisements

  3. Ritter197

    Ritter197 Guest

    To the different points:

    1. The software did download from the Linksys site and is the latest for
    this card. It did install correctly and the card was ONLY inserted after the
    SW was installed.
    2. Device Manager does show the Linksys wireless connector, but with a
    yellow exclamation point because it did not find the drivers.
    3. I have installed and un-installed probably 5 times (the proper way too)
    and it always is still looking for drivers.
    You would think that the Linksys SW would not install and asks you to
    finally insert the card, if it did not install the drivers too.
    4. There is no wireless icon in the system tray.
    5. The router is on all the time and works fine with other cards for my
    laptop.
    6. No WEP or WPA at this time selected, since it does not yet connect.

    BY the way, 2 night ago it did work fine for about 30 minutes. I tried
    different web sites, then made a normal shutdown went to bed. Next morning
    just turned on the laptop and nothing worked anymore for wireless.
     
    Ritter197, Dec 28, 2006
    #3
  4. I got this with some completely different hardware. Turned out that
    the crappy installer routine had fscked up the registry keys for the
    USB devices beyond recovery so that irrespective of which USB port I
    stuck the device into, it could not connect the card to the
    (installed) drivers.

    I had to manually track down and delete the right registry keys in
    HKLM\system\current control set\enum\usb. Danger Will Robinson, this
    is VERY RISKY and might destroy your USB stack requiring a reinstall
    of Windows.
     
    Mark McIntyre, Dec 28, 2006
    #4
  5. I agree. I've seen this once with some Linksys USB device (forgot
    model number). I had to use System Restore to put the registry back
    to the way it was before I started tinkering. As I vaguely recall, it
    would work with the older version of the driver from the CDROM that
    was included with the device, but not with the updated driver from the
    web pile. If I installed the downloaded driver initially, I would get
    a device not found error in the Device Manager. However, if I rolled
    it back to the before installing the driver, installed whatever was on
    the cdrom, and then updated with the downloaded driver, it would work.
    No clue what that was all about. However, that was with a USB device,
    not a PCMCIA. I don't know if it's the same issue. It won't hurt to
    roll back the registry with System Restore, and just try the older
    driver on the cdrom.

    However, this is Windoze 2000, not XP, so there's no System Restore. I
    guess you'll have to hack the registry. Before attacking, I suggest
    you cover your posterior with a registry backup and restore utility.
    Download and install ERUNT.
    <http://www.larshederer.homepage.t-online.de/erunt/>
    If you mess up the registy, it will make it easy to recover.
     
    Jeff Liebermann, Dec 29, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.