Win98 / WinXP networking only one way

Discussion in 'Windows Networking' started by Damin Kercha, Nov 18, 2003.

  1. Damin Kercha

    Damin Kercha Guest

    I have a desktop pc with Win98 and a laptop with WinXP(Home). I have
    the two machines connected with a crossover cable and have set static
    IPs on both. The problem is I can map network drives from the XP to
    the '98 machine and use the printers connected to the '98 box, but
    when I try to access the XP machine from the '98 machine I get an
    error ('network not available'). I can ping the XP box but cannot see
    it in Network Neighborhood. I have verified that the firewall is
    disabled on the XP box and have TCP/IP, File and Print Sharing
    installed on both machines. I have a feelig that this is something
    simple and I am just not seeing it. HELP please!!!!
     
    Damin Kercha, Nov 18, 2003
    #1
    1. Advertisements

  2. 1. A common reason for inability to browse the network is that the
    user isn't logged on. Is there a logon prompt when Windows 98 starts?
    If so, don't cancel it. Complete the logon by entering a user name
    and, optionally, a password. If there's no logon prompt, click Start
    | Shut Down | Close all programs... and log back on. If that makes
    network browsing work properly, the most likely fix is to go to this
    registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
    Network\Real Mode Net

    and delete the value named "AutoLogon", as shown here:

    http://www.wown.com/j_helmig/nologon.htm#AutoLogon

    2. You've already disabled XP's built-in Internet Connection Firewall.
    Good. Now, disable and un-install any other firewall programs
    (ZoneAlarm, Norton Internet Security, etc) while troubleshooting.
    Note that some antivirus programs have a firewall built in. If you've
    previously un-installed a firewall program, go to Start | Run |
    Msconfig | Startup and disable any remnants of it.

    3. Use only one protocol for File and Printer Sharing. If the network
    needs more than one protocol, unbind File and Printer Sharing from all
    but one of them. Details here:

    Windows XP Network Protocols
    http://www.practicallynetworked.com/sharing/xp/network_protocols.htm

    4. Make sure that NetBIOS over TCP/IP is enabled on both computers.
    Details here:

    Enable NetBIOS Over TCP/IP (NetBT)
    http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm
     
    Steve Winograd [MVP], Nov 18, 2003
    #2
    1. Advertisements

  3. Carey Holzman, Nov 19, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.