Wifi horribly slow on MSI RG60G, very fast with an ethernet cable

Discussion in 'Wireless Internet' started by deepdark, Jan 7, 2007.

  1. deepdark

    deepdark Guest

    Can anyone suggest a solution to extreme slowness of internet access
    when using wifi on MSI router RG60G? When the computer is wired to the
    router via ethernet, internet is very fast. The router is connected to
    a cable modem with a dynamic IP address.

    I have tried all channels.

    The computer is just next to the wifi router, so interference should
    not be a problem. Signal strength is "Excellent."

    The router is installed as purchased, with no additional configuration
    (no encryption, no port forwarding, nothing).

    The computer has the built-in Intel PRO/Wireless 3945ABG.

    The computer works BEAUTIFULLY with any other wifi hotspot other than
    my own.

    The latest firmware from MSI's site is the same as the one installed on
    the router.

    If I connect the computer to the router with an ethernet cable, the
    computer gets only a slightly different NAT'ed IP address
    (192.168.1.160 instead of 192.168.1.122 when using wifi). Yet with
    wireless, it is disastrously slow (2-3 kB/s).

    Does anyone have any, even crazy idea what could possibly be wrong? I
    accept anything except answers involving aliens from outer space. Thank
    you.
     
    deepdark, Jan 7, 2007
    #1
    1. Advertisements

  2. hath wroth:
    <http://www.msi.com.tw/program/products/communication/cmu/pro_cmu_detail.php?UID=632>
    Try turning OFF:
    1. 802.11b compatibility mode.
    2. Turbo-G features.
    Ok, it's not interference.
    How fast does the configuration web page come up? Can you switch from
    page to page in the configuration at reasonably fast speeds (or
    similar speeds to what you got with a direct ethernet connection)?
    OK, then it's not the computah. Are you using Windoze Wireless Zero
    Config or Intel Proset on this laptop? If Proset, 9.x was a bit
    weird, but 10.x is just fine.
    That would have been too easy. Have you tried a hard reset to
    defaults and starting over from scratch?
    Ouch. That's 16 to 24Kbits/sec. It should be perhaps 25Mbits/sec at
    a 54mbit/sec association. I'm suprised it works at all. The Intel
    Proset utilities have a diagnostics and logging page. See if you're
    getting any errors.
    Never underestimate the power and influence of aliens from outer
    space. Dunno. You might want to try it in some other room or house
    just to make sure your router is not located in the path of the alien
    wi-fi jammer ray gun. A basement or inside room might be best. If
    you want to waste some time, try loading a fresh firmware image even
    though the version numbers are the same. The installed image might be
    corrupted. Otherwise, it seems broken and should be returned or
    recycled.
     
    Jeff Liebermann, Jan 7, 2007
    #2
    1. Advertisements

  3. deepdark

    deepdark Guest

    Thank you for the message!
    These options are not available on the router. I switched off Turbo on
    the wifi adapter, though.
    When it's wired, it comes up very fast. Wireless, it's erratic and
    sometimes the configuration page doesn't want to come up at all.
    Strangely, some local websites here where I live come up fast when
    using wifi - maybe aliens ARE involved... :(
    Zero Config...
    More than a few times...
    Now that's a promising advice. Thank you. I'll try it.
    Yes, I installed the latest firmware although it's the same as the one
    on the router...

    Thanks again!
     
    deepdark, Jan 8, 2007
    #3
  4. hath wroth:
    The local web sites are coming fast because they're in your browser
    cache. Flush the cache and they'll be as slow as the rest.

    The fact that configuration web pages are slow via wireless and fast
    via ethernet eliminates the router WAN connection as the culprit
    taking the internet out of the picture. It's definately a wireless
    problem. My guess(tm) is the router is sick sick sick.
    I don't think you'll see much there. Look for statistics that show
    MAC layer (not IP layer) packet loss. I forgot if Proset will show
    those. Incidentally, I suggest you use Intel Proset 10.x instead of
    WZC as it's much more informative, feature infested, and rationally
    designed.

    You might want to drag in a friend with a known working laptop and try
    connecting to your router for a sanity check. It won't fix the
    problem, but it will help identify the culprit by eliminating the
    laptop as a probable cause. (Avoid alien laptops as they have
    incompatible protocols).
     
    Jeff Liebermann, Jan 8, 2007
    #4
  5. deepdark

    deepdark Guest

    The local web sites are coming fast because they're in your browser
    Unfortunately, it's not that easy. This is actually the only thing that
    doesn't make any sense, and the only piece of evidence that is stopping
    me from throwing the router out of the window:

    I use WGET to test speed, which has no cache (verified). Wired, "wget
    http://www.apple.com/trailers" returns 100 kb/s, when wireless, it's
    only 3kB/s, sometimes even 7kB/s. Then I download a large test file
    from my ISP - wired, it's 500kB/s, wireless 500kB/s. (I live in
    Europe.)

    I know, it's alien-abduction-in-Bermuda-triangle-style weird stuff.
    I was already told that router is probably "faulty". I know I might be
    a stubborn f*ck, but I somehow can't believe this router is "faulty" if
    everything other than wireless _international_ downloads works
    brilliantly.
    I'll try that as well... Thank you.

    The only reason I prefer Zero Config is the ugliness of Intel's PROSet
    software. I guess I'll have to get used to it if it works better.
    However, Zero Config works great with all other hotspots.
    Thank you for your time, I'll see if I can do that too. I'll let you
    know if I figure it out or break it into small pieces and feed it to
    aliens.
     
    deepdark, Jan 8, 2007
    #5
  6. Hmm.... Black hole MTU negotiation problems? I assumed that your
    "local" meant on your LAN, not nearby web servers.

    If you have a DSL connection, try reducing the router MTU from 1500 to
    1492 and see if it helps. Smaller numbers are also acceptable but
    you'll see a reduction in max speed. I have no idea why it makes a
    difference with wireless but not wired, but let's see what happens
    first.

    Use a program called MTUroute:
    <http://www.elifulkerson.com/projects/mturoute.php>
    to determine if your router is not doing MTU discovery, if your ISP has
    a misconfigured router, or if there is a broken router somewhere along
    the path.
    If it were easy, it would be no fun.
    Unless I read your description incorrectly, it's only slow via wireless
    on *SOME* web sites. Is this correct?
     
    Jeff Liebermann, Jan 8, 2007
    #6
  7. deepdark

    deepdark Guest

    Hmm.... Black hole MTU negotiation problems? I assumed that your
    Yes, I'm sorry, I did not emphasise that clue enough although it's
    probably the most important one.
    It's a cable modem, but the router has a MTU setting, which I played
    extensively with to no avail.
    Thank you, this is a very interesting tool I did not know about.
    Strangely, one three consecutive runs (from wifi connection) it
    reported three wildly different values:

    mturoute.exe www.apple.com
    Path MTU: 1462 bytes.
    Path MTU: 1500 bytes.
    Path MTU: 1192 bytes.
    :) Guess so, it only makes it sweeter when (if) it works out well.
    It is slow "only" with all international (non-Maltese) sites.

    Just when I wanted to try out the MTU tool, I decided to do a Factory
    Reset of the router just to eliminate any other configuration issues
    that might be impacting the problem. In the mean time, I have played
    with wifi adapter settings, of which there are only around 10 (mostly
    related to power management and performance), again to no avail.

    *** Now, the router is reset to factory defaults and the wireless
    connection works brilliantly, international and local. ***

    If it was one of the network adapter settings, I really don't want to
    find out which one. I'll let you know if the problem returned, but so
    far it seems wonderful.

    Thank you for your ideas and kind help, it's very much appreciated! :)
     
    deepdark, Jan 8, 2007
    #7
  8. When the error rate goes up, the routers will negotiate a smaller
    maximum packet size, which has a better probability of arriving
    intact. However, such changes are usually much larger than what
    you're seeing. I've seen routers negotiate MTU's down to about 512
    bytes. However, I've never seen it change in such small incriments as
    what you're getting. Aliens again.
    You're on Malta? Cool. The problem might be explained by congestion
    to whatever backhaul is being used to the continent. However, it
    would not explain why it's fast with ethernet and slow with wireless.
    I'm still mystified.
    Some routers (i.e. Linksys) require that the reset button be held down
    for about 30 seconds or the reset to defaults fails. It's often
    better to do the reset to defaults from the web interface than the
    reset button. I guess your MSI RG60G night need a similar long reset
    time.
    Well, by this time, I suspect you've changed literally everything with
    a minimal hope of putting the settings back to the correct defaults. I
    guess you did the right thing by resetting everything and evicting the
    aliens.
     
    Jeff Liebermann, Jan 9, 2007
    #8
  9. deepdark

    alien Guest

    Well, I know what the problem is but since you've excluded me I'm going to
    play poker with the caveman from the Geiko commercials.

    alien
     
    alien, Jan 10, 2007
    #9
  10. deepdark

    deepdark Guest

    You're on Malta? Cool. The problem might be explained by congestion
    Me too. ;)

    I have now graciously decided to let my neighbor use my wireless
    connection (with password protection).

    He got a wireless PCI card, and it is working at 3 bars (Good)
    reception, sometimes 2 bars.

    However, his connection is constantly breaking. I do a

    ping -t 192.168.1.172

    and it looks like a zebra crossing - 15 successful pings, 10 failed, 32
    successful, 12 failed, and so on. Can anyone point to a potential
    solution?
     
    deepdark, Jan 18, 2007
    #10
  11. hath wroth:
    That's what RF interference looks like. The large variations and
    dropouts are caused by retransmissions, retries, and timeouts. Pings
    should be 1 to about 3 msec latency for such short links and constant
    value.

    It is probably aggrivated by a marginal signal. 2-3 bars is usually
    considered somewhat tolerable and should work, but different cards and
    devices have different ideas of how many bars to present. Also, the
    signal strength may not be symmetrical. Check the access point for
    signal strength or use Netstumbler to sniff the traffic and extract
    the signal strength in both directions.

    Lastly, you might have a problem with "frequency selective fading"
    also known as multipath and reflectons. If your antennas are located
    so that there is a direct path, and a longer reflected path, and they
    cancel, you may have a problem. Try moving the antenna a few cm in
    any direction to see if it helps stabilize the pings.

    Possible sources of interference:
    <http://wireless.wikia.com/wiki/Wi-Fi#Interference>

    The best solutions usually involve using directional antennas to both
    improve the signal strength, and to reduce pickup of the sources of
    interference. If there are any obstructions in the line of sight,
    move the antennas so they are eliminated or avoided.
     
    Jeff Liebermann, Jan 18, 2007
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.