Why proxy server set to 127.0.0.1?

Discussion in 'Broadband' started by Zak, Feb 13, 2005.

  1. Zak

    Zak Guest

    I use XP+SP1. I am in the UK and I am connected to NTL broadband.

    I am almost certain that I used to have no proxy sevrer set in IE6 >
    Tools > Internet Options > Connections > Lan Settings.

    However I now see that the Use Proxy Server box is ticked and the IP
    address entered is the loopback address 127.0.0.1 on port 81.

    Some web sites do not like this and they have problems.

    I also have Zome Alarm 4.5 and also the antivirus Avast (version 4.5
    home edition). Perhaps one of these two applications change the LAN
    Settings?

    I also use Firefox and Opera as browsers. Their own settings seem
    unchanged and do not refer to a proxy server but when I try to go to
    the problem web pages (eg http://www.firstdirect.com/) then they
    return a message protesting about proxy servers.

    How can I get around this?
     
    Zak, Feb 13, 2005
    #1
    1. Advertisements

  2. Zak

    Jan Il Guest

    Hi Zak :)

    If you do not need the proxy, the try the following and see if it helps:

    Disable Proxy Settings
    Tools>Internet Options> Connections tab> LAN Settings button
    Under Proxy server, make sure the box there is unchecked

    Disable Automatic Proxy configuration
    http://charterpipelinentx.net/disableproxy.htm


    Hope this helps

    Jan :)
    Smiles are meant to be shared,
    that's why they're so contagious.

    Replies are posted only to the newsgroup for the benefit or other readers.
    How to make a good newsgroup post:
    http://www.dts-l.org/goodpost.htm
     
    Jan Il, Feb 13, 2005
    #2
    1. Advertisements

  3. Zak

    Charlie Tame Guest

    A popup blocker might do this, check Zone Alarm if it has one, stop blocking
    and see if settings change.

    In that case what would happen is that ZA is taking over reading the site
    and filtering it's content, leaving IE to look at the ZA proxy for the
    filtered output.

    I hasten to add that I don't know this for sure but it's possible.

    There could also be spyware or malware doing this, however try the obvious
    first and look for popup blockers, possible antivirus with similar and then
    check task manager to see what's running in case that helps.

    Charlie
     
    Charlie Tame, Feb 13, 2005
    #3
  4. Zak

    It's Me Guest

    You have installed something that is routing you through your local IP.

    What have you installed recently?
     
    It's Me, Feb 13, 2005
    #4
  5. Zak

    Dr Teeth Guest

    Some email antivirus scanners do it.
    --
    Cheers,

    Guy

    ** Stress - the condition brought about by having to
    ** resist the temptation to beat the living daylights
    ** out of someone who richly deserves it.
     
    Dr Teeth, Feb 13, 2005
    #5
  6. Zak

    steve Guest

    Unfortunately last time I looked windows does not allow you to see what is
    listening on a port (does XPSP2? the most secure ever?)

    Download this
    http://www.sysinternals.com/ntw2k/source/tcpview.shtml

    and see what is listening on TCP port 81.

    If it is something like rundll.exe or the other easily hijacked system
    process you will need to do futher investigation.
    Well it is best to have only proxying of HHTP and not everything, I am
    sure you can do that on windows.
    I run a transparent proxy and never have problems with firstdirect.

    BTW: Avoid using your home banking until you get to the bottom of this.
     
    steve, Feb 13, 2005
    #6
  7. Zak

    steve Guest

    For HTTP?
     
    steve, Feb 13, 2005
    #7
  8. Zak

    Muxton Guest

    Command prompt -> netstat -b

    Tells you which app has opened which port.

    Command prompt -> netstat -a

    Tells you which ports are listening.

    Command prompt -> netstat /? gives you the whole rundown of options.

    Jake
     
    Muxton, Feb 13, 2005
    #8
  9. Zak

    Dave J Guest

    I think you'll find that's netstat -o
    This can be combined with -o, so

    Command prompt -> netstat -a -o

    lists all open ports, and gives the process identity number (PID) of the
    owner of each port.

    Then, to find the name, window title and username of the process, use

    -> tasklist /V /FI "PID eq NNNN"

    where NNNN is the PID number you got from netstat.
     
    Dave J, Feb 13, 2005
    #9
  10. Zak

    Charlie Tame Guest

    Yes I guess they would have to for web based email, but I was not thinking
    of that :)
     
    Charlie Tame, Feb 13, 2005
    #10
  11. (posted from ie6.browser on msnews server (not USENET);
    all crossposting left for possible propagation but I would be just as happy
    to drop the USENET newsgroup if it is not needed.)


    Look again. <eg>

    netstat -ao | find /i "listening"

    Then use tasklist /v /fi "PID eq ..." (or Task Manager's Processes tab)


    ---
     
    Robert Aldwinckle, Feb 15, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.