What chipset does D-Link use?

Discussion in 'Wireless Internet' started by gary, Oct 7, 2003.

  1. gary

    gary Guest

    What chipsets are used in the D-Link DWL-AG65O cardbus adapter and the
    DI-774 router? These support A/B/G nets, and the 774 is "revision A" - it
    has two antennae, not one. D-Link recently announced that it would be using
    the newest Atheros chips in new products, but I don't know if that's what is
    in my AG650 adapter. I want to know because the new Atheros chipset claims
    to support AES encryption, which means that an eventual upgrade to full
    802.11i support is possible without a hardware change.

    WPA with pre-shared keys is supposed to work now, but it isn't working for
    me. I have upgraded the 774 firmware, and installed the 2.35 driver on the
    AG650. I have the Windows WPA patch, and I'm using Windows zero-config
    instead of the Air Xpert utility, as recommended by D-Link support. The last
    I heard from D-Link, I may have to use the AG650 Beta drivers dated June 10,
    instead of the 2.35 driver dated August 22. Since 152-bit WEP didn't start
    working for me until I upgraded to 2.35, I'm reluctant to back down to a
    Beta driver and lose WEP.

    Also, does anybody know if the AG650 will work in Europe? My guess is yes,
    but I know that there have been adapters marketed that do not support
    channels above 11.
     
    gary, Oct 7, 2003
    #1
    1. Advertisements

  2. gary

    CWatters Guest

    Not sure if this helps you but...

    I have a new D-Link DI-624 router (two aerials) and a D-Link DCF 660 card in
    a PocketPC. This combo works fine _except_ I can't get WEP working either.
    As I enable WEP I loose the connection. I''ve tried updating everything and
    even replaced the DCF660W with a new one. I'm using using the supplied
    config utilities.
     
    CWatters, Oct 8, 2003
    #2
    1. Advertisements

  3. gary

    gary Guest

    I've got 152-bit WEP working fine on A, B, and G networks. WPA is the
    problem. Until I upgraded to the 2.35 driver for the AG650, I could only get
    WEP working at 128 bits. Not that it matters, there is essentially no real
    difference in security over the 64-bit version in the standard.

    I assume you've done the obvious:

    * Use 64-bit WEP to start, only 64 bits is required by the standard and for
    WiFi Alliance certification.
    * Be absolutely sure that the keys you enter are identical on the client
    adapter and on the router. 64-bit encryption requires a 5-byte key, which
    will be 5 Ascii characters or 10 hex digits.
    * Disable any fancy stuff - no MAC filtering, leave SSID broadcast enabled.
    * Be absolutely sure that the SSID is configured identically on the router
    and the client. If it works without WEP, then you've got this right.

    If it still doesn't work, then you may need driver and/or firmware upgrades.
    If I were you, I'd phone D-link support before attempting to apply any
    upgrades, especially since one of them appears to be a Beta (see below).

    I just glanced at the D-link support site. There is a firware upgrade,
    revision 1.25, for the DI-624 which includes WPA and final 802.11G standard
    fixes. It is for the "B" version of the router only, however. A and B both
    have two antennae, so you'd have to look at the label on the bottom of the
    router for the "HW:" field - it should be something like "HW:A1" or "HW:B1".
    If you have an A version, then this firmware upgrade is *not* for your box.

    The URL I'm looking at for DI-624 is:

    http://support.dlink.com/Products/view.asp?productid=DI-624

    It looks like the driver supporting the 660 for Pocket PC is Beta, so it's
    not clear that it has been adequately tested. I assume this is the driver
    you're using. It says, "Please use these drivers at your own risk and let us
    know your results". The URL for the page I'm looking at is:

    http://support.dlink.com/faq/view.asp?prod_id=1350
     
    gary, Oct 8, 2003
    #3
  4. gary

    CWatters Guest

    Thanks for the reply, I'll give it another go later today.
     
    CWatters, Oct 9, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.