What am I doing wrong?

Discussion in 'Home Networking' started by Tony Raven, Aug 28, 2005.

  1. Tony Raven

    Tony Raven Guest

    What should be a fairly simple task of home wireless networking has got
    me flummoxed. Bits of it work some of the time but with no consistency
    and one bit does not work at all. The one that does not work is one of
    two identical brand new laptops set up identically yet behaving very
    differently.

    The summary:

    Five computers, four wireless, one wired. All running AVG AV+firewall
    with WLAN IP addressess specifically allowed. All connected through
    Netgear DG834W router/modem

    Computer 1: Desktop running XPProSP1, wired
    Computer 2: Desktop running XPHomeSP2, wireless
    Computer 3: Laptop running XPProSP1, wireless
    Computer 4: New laptop running XPHomeSP2, wireless
    Computer 5: New laptop running XPHomeSP2, wireless

    Generally 1,2,3 & 4 can see each other in the workgroup although when
    you try and access them sometimes they connect, sometimes they say there
    is no permission to connect and sometimes they say the workgroup is not
    available.

    5 is the mystery. In network places it shows the router and nothing
    else. I have not been able to make it see the other workgroup computers
    (checked the name is right). It has been set up identically, as far as I
    can tell, to 4 and both are brand new so no legacy problems hanging
    around to confuse the picture.

    I can ping any one, from any other and all can access the internet
    through the router. As far as I can tell they are set up identically
    apart from computer name but they behave differently and it varies with
    time. Last night I had 1,2,3 & 4 all talking to each other. This
    morning when I switched on 1 was there but denying access to the others
    and now later this morning it is allowing access with nothing being done
    inbetween. Sometimes for example 2 cannot see 4 but 4 can see 2.
    Following comments that seem to be made here I have enable Guest
    accounts on all of them but it made no difference.

    Anyone got any suggestions of what to try or non-XP alternative
    networking software that does not take all the control off you I could try?

    Many thanks
     
    Tony Raven, Aug 28, 2005
    #1
    1. Advertisements

  2. XP Home is always a bit of a bugger to get set up. The general
    checklist for this sort of thing is as follows:

    1: Make sure at least one folder is shared on each machine.

    2: Create an account with the same username and password on every
    machine, and ensure that this account has access rights to the shared
    folder.

    3: Temporarily disable firewalls. It would probably be a good idea to
    pull the plug on your internet connection before doing this; better to
    be safe than sorry.

    Are you assigning addresses manually or via DHCP?
     
    Gareth Robert Halfacree, Aug 28, 2005
    #2
    1. Advertisements

  3. Tony Raven

    Conor Guest

    Firstly, enable Windows Firewall while we do this and disable all 3rd
    party firewalls.
    Secondly, go into into Control Panel, Windows Firewall. Click on
    Exceptions and make sure File and Printer Sharing is ticked.


    On all of them, open up regedit. Navigate to
    HKLM/Software/Microsoft/Windows/CurrentVersion/Explorer/RemoteComputer/
    Namespace

    Delete the folder:

    {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

    This stops XP searching the LAN for Remote Schedule tasks - one of the
    biggest causes of slowdown.

    On each of them again, open up Windows Explorer. Click on Tools, Folder
    Option, View and untick "Automatically search for netowrk folders and
    printers.

    We have now got rid of the two things that slow LAN browsing on XP.



    List the IP addresses for each of them.

    On each one, open a Command prompt and type:

    nbtstat -n

    You're looking for a line that says __MSBROWSE__.000 or similar.

    Make sure that only one computer on the LAN has this line. If more than
    one has, the master browser elect process is failing which produces the
    results you get. If this is the case, disable the Computer Browser
    service on all the computers other than the main one on the LAN.

    IF you still can't see computers in the Network Places then try the
    following:

    Click on Start, Run and type in \\<ip address of the machine you're
    trying to view> , i.e \\192.168.0.4

    After a few seconds, an explorer window should open showing shares.

    Let us know how you get on after that lot.
     
    Conor, Aug 28, 2005
    #3
  4. Tony Raven

    Tony Raven Guest

    Thanks for that. I found one thing that seemed to fix virtually all the
    problems that I have not seen written here (at least not in the recent
    posts I've read) That was I switched NetBios from default (Use NetBios
    settings from the DHCP server) to Enable NetBios over TCP/IP. That
    seems to have got rid of all the flakiness and inconsistency in connnections

    Tony
     
    Tony Raven, Aug 29, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.