Wake On Lan with RedHat 9 and onboard Realtek 8139

Discussion in 'Linux Networking' started by Oscar Overdijk, Jan 11, 2004.

  1. I have a MSI-6368 mobo with RedHat 9 installed en WOL function enabled
    in the BIOS.
    This is a server in my home network and now I want to startup this
    server with Wake On Lan. Linux is installed without X.
    I tryed a lot things but without any luck, the server stays down. When
    I do this with a windows box the WOL works fine.
    What am I missing, can somebody help with this problem?

    Oscar
     
    Oscar Overdijk, Jan 11, 2004
    #1
    1. Advertisements

  2. Oscar Overdijk

    Cameron Kerr Guest

    Missing may be the operative word. For WOL to work, you need to have a
    cable (single pair, usually red and green) connected between the NIC and
    the motherboard (it usually plugs in between the PCI slots.)

    There may be differences in how the packet is expected to be sent,
    depending on whether it (the NIC) is AMD or not, IIRC. But I haven't
    played with WOL much myself.

    Also, some WOL NIC chips (maybe BIOS, I'm not sure) can set a password.

    And of course the machine needs to be ATX and turned on at the power
    supply.
     
    Cameron Kerr, Jan 12, 2004
    #2
    1. Advertisements

  3. Oscar Overdijk typed:
    have you tried 'ether-wake'?
    http://www.scyld.com/expert/wake-on-lan.html
     
    johnny bobby bee, Jan 12, 2004
    #3
  4. The MSI motherboard has the Realtek onboard. I know that if you have
    ethernetcard with WOL you need the cable between the board and the
    card.
    It's not a AMD. For Magic Packet from AMD to wake up lan, if the NIC
    adres is sent 16 times then Wake On Lan will power up the host.
    From the ethtool eth0 I get the information that WOL is supported with
    p for the Magic Packet, but after a halt -p and a manuel startup of
    the host, the ethtool eth0 gives the information that p is not set.
    Strange. Then there is an option for the modules.conf that indicate
    that post-install 8139too ethtool -s eth0 wol umbgp do the trick, but
    no luck for that so for.
     
    Oscar Overdijk, Jan 12, 2004
    #4
  5. No I didn't, I want to wake up the Linux server from a window workstation.
    Ether-wake can restarting machines that have been soft-powered-down
    (ACPI D3-warm state) according to the source.
     
    Oscar Overdijk, Jan 12, 2004
    #5
  6. Oscar Overdijk

    Cameron Kerr Guest

    What happens when you use ethtool by itself to set WOL parameters?
    Here's what mine says. My laptop _can_ do WOL, but its not set to in the
    BIOS, which may explain the message. (its an Intel NIC also)

    root# ethtool -s eth0 wol umbgp
    Cannot get current wake-on-lan settings: Operation not supported
    not setting wol
     
    Cameron Kerr, Jan 12, 2004
    #6
  7. Well now it works but I don't understand it at all. Maybe a little
    bit.
    What happened: I put a 3Com 905C-TX ethernet card in my Linux Server
    with the MSI-6368 motherboard. I dissabled the onboerd Realtek NIC.
    I checked with ethtool eth0 to see the state of 3Com card and there
    was no responce from it. Then I used the Magic Packet and Yes it
    worked, the Linux Server powered on. I don't understand it but it
    works.

    Oscar
     
    Oscar Overdijk, Jan 14, 2004
    #7
  8. Oscar Overdijk

    Kelvin Yip Guest

    In /etc/modules.conf add
    "options Rlt8139 wol=1"

    As I can wake my computer up even power down the machine.
    I don't sure if it is work.
     
    Kelvin Yip, Jan 20, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.