Voange WRT54GP2 router to Fedora Core 5 - eth0 won't get IP address and won't start

Discussion in 'Linux Networking' started by Ohmster, Dec 28, 2006.

  1. Ohmster

    Ohmster Guest

    Issue: Cannot get Fedora Core 5 computer to boot up eth0 and get IP and DNS
    addresses from my Vonage Linksys router, WRT54GP2. Windows XP machines boot
    and get connected with no problem.


    I have a Fedora Core 5 server that I have always used on my broadband
    connection. I am using Comcast high speed cable with their modem, a
    Scientific Atlanta WebSTAR. Previously, I would connect my modem directly
    to my FC5 box on a network card, configured as eth0, and have DHCP enabled
    to get the IP address and the DNS server info. I have a second NIC setup as
    eth1 and this would connect to a hub and into that hub I would connect 2 XP
    Pro machines. I used Firestarter firewall to setup NAT for the home LAN and
    Firestarter would enable DHCP to the hub, where any computer you plugged
    into the hub would be online if you had setup the network on those
    computers as "Automatic". This worked great and I had not problems with
    this setup. Very, very good setup, I could run my apache server for my 3
    FQNS and also run vsftpd for my ftp server. This was so freaking good
    because the Linux machine had the real IP address and thus could be reached
    from the internet and the servers worked really well.

    Now I need to find another telephone company to get my home phone working
    again, I have billing issues with Bellsouth that are not going to be
    resloved any time soon in this lifetime but God knows I really tried to
    work things out with Bellsouth. They are stubborn, inflexible, and just
    darn right mean. I give up on them. Since I always have a good broadband
    connection in my house, I decided to give Vonage a try for the $25 a month,
    all you can eat telephone service. Voange, by the way, is freaking
    fantastic, no BS, low price, and it really is God's gift in my situation.

    To use Vonage, I have to have an adapter connected directly to my cable
    modem where my home phone plugs in and then the Ethernet cable goes on to
    my setup. Now of course this will not work anymore, considering that I need
    a real IP address for the Linux box. The vonage adapter is a Linksys
    Broadband routher, WRT54GP2, which has 1 Ethernet input jack and 3 Ethernet
    output jacks. Here is the device:
    http://tinyurl.com/qt4od

    What I want to do now is have all 3 of my computers plugged into the
    Linksys and allow them to setup themselves with automatic settings for the
    Windows machines and configure my Fedora box to connect with DHCP to get an
    IP address and DNS server addresses. Then I can setup the router to forward
    the server ports or if I can find it, put the Linux box in the DMZ,
    although I cannot really find that setup in the browser admin screen.

    Anyway, the issue is that the Fedora box will not connect to this routher.
    When I boot, eth0 failed to get an IP address and thus in disabled. The
    computer is not online anymore since connecting the Linksys router in
    between the cable modem and the Fedora Box. It just does not work. I can
    even try "service network restart" and "Determining IP information for
    eth0" times out and fails. The Windows XP machines have no problem at all
    with connecting to the Linksys, they boot fine and work great on the
    Internet.

    One thing that I have noticed is that I have always used 192.168.0.xxx for
    my home LAN NAT addresses. The Linux box used 192.168.0.1 as it's local
    address and the other machines on the LAN fall into that range. The Linksys
    router on the other hand, dishes out IP addresses in the 192.168.15.xxx
    range, starting at 192.168.15.100 and is set to go to 192.168.15.50.

    What is the problem here and what do I have to do in order to get my Fedora
    Core 5 server to get an IP address from the linksys? This really bites, I
    desperatly need to get this Linux box back online and am stumped, why won't
    it get an IP address from the router?

    I would really like, in the end, to connect my setup as such:

    Cable to modem
    Modem to Vonage router, Linksys WRT54GP2
    Linksys to Fedora Box on eth0
    Fedora to hub on eth1
    hub to other computers on the LAN

    I would prefer this because I could transfer large files, like a DVD or CD
    image file and with all the computers connected via the 3com hub 8/TP100
    because that sucker was fast. I could transfer a 1Gb file in less than a
    minute, with the network connecting the computers using the LInksys, I
    would have to wait almost an hour to transfer a file.

    Somebody please help, how can I get my Fedora box to boot up and get
    connected to a Linksys router?

    Thank you and Happy New Year.
     
    Ohmster, Dec 28, 2006
    #1
    1. Advertisements

  2. Ohmster

    Ohmster Guest

    For goodness sakes. Found the problem. My network cards reversed. eth0 is
    now eth1 and eth1 is now eth9.

    Solution: Switch the cables. Duh!

    Oh I feel so stupid for overlooking this. :p
     
    Ohmster, Dec 28, 2006
    #2
    1. Advertisements

  3. Ohmster

    Lenard Guest

    Linksys routers sometimes do not play well with Linux and you need to help
    out a bit;

    Try editing the /etc/sysconfig/network-scripts/ifcfg-eth0 file and add the
    line entry; GATEWAY=The Routers IP address here

    Also check the /etc/resolv.conf file and make sure it uses the new
    nameserver address's

    It might be a good idea to use a static IP address on the Linux system for
    the DMZ
     
    Lenard, Dec 28, 2006
    #3
  4. Ohmster

    Alan Adams Guest

    In message <[email protected]>

    Page 41 of the user guide - Applications and Gaming - DMZ
    seems to have what you need.
    I suspect a typo here - 100 to 250 maybe?
    I don't know Fedora. Do you have any of the IP setup fields defined,
    e.g. do you still have a netmask or a gateway defined? That might
    interfere with DHCP.

    However if you want to use the DMZ facility the manual says you need
    to use a static address, so I would do that. Just make sure it is
    outside the DHCP range.

    With DMZ your server has an address which is in your LAN range, and
    the router forwards requests to it. Those requests come in on the
    router's IP address. The issue here is that you need a static address
    on the WAN side of the router - or use dyndns.org. The remote clients
    need a way to find your router.
    Fedora - static on Eth0 and DMZ configured. Run a DHCP server on
    Fedora, supplying addresses on Eth1. Since you are using DMZ, the
    Linksys firewall will not be protecting you very much, so you will
    need the fedora to act as firewall for the rest of your network.

    You'll need to route on Fedora, so you need to use two private network
    ranges. I suggest 192.168.15.x for the linksys-fedora link, and
    10.0.0.x for the LAN
    This puzzles me a bit. Your existing switch seems to be transferring
    at about 150MBit/sec - assuming it is 10/100 that is very good going.
    The Linksys is also 10/100, so the only thing I could see slowing it
    up is the firewall function - and that should be configured so it
    doesn't affect lan-lan traffic.
    Best wishes, and good luck.
     
    Alan Adams, Dec 28, 2006
    #4
  5. Ohmster

    Ohmster Guest

    Hmmm, it seemed to work quite well when I first installed it, then one
    day, it would not work anymore and there was nothing but problems. I
    could not get connected for beans. I gave up for the time being and
    plugged the two doze machines directly into the Linksys. The linux box
    would not pull DNS or an IP, even though the doze boxes had no problems
    at all getting online. Strange.
    Hmmm, it works really well now though since I figured out that by
    switching the Ethernet cables around (eth0 & eth1). Here is the ifcfg-
    eth0 script as it is, works great:

    [[email protected] network-scripts]# cat ifcfg-eth0
    BOOTPROTO=dhcp
    HWADDR=00:E0:7D:9A:0D:0C
    DEVICE=eth0
    MTU=1500
    NETMASK=255.255.255.0
    BROADCAST=192.218.15.150
    IPADDR=""
    NETWORK=""
    ONBOOT=yes
    [[email protected] network-scripts]#
    What nameserver? The ones that come from Comcast via dhcp?
    Oh yeah that would be lovely but Comcast does not offer it on their
    broadband, at least not for what I am paying. 8Mbps costs $55 a month but
    for the first year, you pay only $25 or $27 if you do not buy your own
    modem.

    It works really good now Lenard, I can even use the Linux box as the home
    LAN router which I like better than the Linksys. With the 3com hub, I can
    move a 1Gb file across the LAN in like just a minute or two. When I was
    using the linksys, it would take up to an hour. Thanks for your insight.
    Happy New Year Lenard!
     
    Ohmster, Dec 30, 2006
    #5
  6. Ohmster

    Ohmster Guest

    Oh wow, you are right! I did put my machine in the DMZ but to tell you the
    truth, I really don't see much of a difference now with it. I use port
    forwarding in the linux firewall to make stuff work on the doze machines
    and open the ports on the linux firewall (Firestarter) for what I need,
    e.g.: httpd, vsftpd, pop3, etc.

    What is the DMZ supposed to do, Alan?
    Yep, typo. That should read:
    The Linksys router on the other hand, dishes out IP addresses in the
    192.168.15.xxx range, starting at 192.168.15.100 and is set to go to
    192.168.15.150. The default amount of DHCP addresses is 50, but you can put
    in any number you like.
    Alan, this setup has worked perfectly up to the day when all hell broke
    loose, for no apparent reason, and then nothing would connect or work. No
    internet, no home LAN, and anything else you can think of. The settings did
    not just "go bad". Something else must've happened. I started out by going
    basic and just trying to get the Linux box to pull and IP and DNS from the
    Linksys. The Windows machines had no problem with it, what is Linux looking
    for that it does not see?

    I decided to use Webmin to disable the eth0 and eth1 interfaces. No sense
    in having them both up and confusing things when all I am trying to do now
    is to get the darned thing to work. I ended up shuting off eth0 and did not
    notice any difference. I could still connect to the Linksys config page
    with Firefox. I then disaled eth2 and that was all it took to render Webmin
    useless. I could no longer connect to the router. I turned eth0 back on,
    that is the one that goes to the Linksys and nothing happened. I still
    could not access my adminstration.

    Hmmm, something aweful scwewy awound here. I shutoff eth0 and enabled eth1.
    Now I could connect to the linksys. <applause>

    This means that the network interfaces must have swapped out in the linux
    box. Easy enough to test, just switch the eth0 and eth1 cables. It worked,
    it was just the network got confused. After switching the Ethernet cables,
    we were back in business.
    [snip]

    Forgive me Alan, I have been working very hard and have fallen asleep at
    the keyboard 3 times already. I wakup and see like hundreds of whatever
    character I had my finger on all over the screen.

    I will come back when I am not so tired. Thanks for your insight.

    Happy New Year!
     
    Ohmster, Dec 30, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.