V. slow download speed, upload speed OK

Discussion in 'Broadband' started by Nick, May 18, 2004.

  1. Nick

    Nick Guest

    Hi

    I have just had ADSL installed. I am finding that download speeds are
    very slow (0.5 - 1k/s) much of the time, but sometimes jump up to
    OK-ish levels. All the while, upload speeds are fine.

    The BT engineer who came tested the line and got a download speed I
    would have expected from my connection. He was using his own ADSL
    modem, not the modem/router that I am using - a D-Link (not sure which
    model, but it's a combined modem/wireless router).

    I have tried different computers (with Windows XP, ME and NT4) but all
    have the same problem.

    Anyone got any ideas?

    Thanks :)
     
    Nick, May 18, 2004
    #1
    1. Advertisements

  2. Nick

    Chris Guest


    What are u trying to download???
     
    Chris, May 18, 2004
    #2
    1. Advertisements


  3. Do you have a filter on the line between the wall socket and the
    modem/router???
     
    Gareth not NLL or anybody else., May 18, 2004
    #3
  4. Nick

    Ian Stirling Guest

    Are you using a wireless connection to your router?
     
    Ian Stirling, May 18, 2004
    #4
  5. Nick

    Nick Guest

    What are u trying to download???

    Tried loads of websites, loads of different files - makes no difference
     
    Nick, May 18, 2004
    #5
  6. Nick

    chris Guest

    On 18 May 2004 10:59:07 -0700 and in article
    <>, Nick said...
    : > What are u trying to download???
    :
    : Tried loads of websites, loads of different files - makes no difference
    :
    :
    Tried changing your MTU to 1430 and RWIN to 13900? Use DrTCP to do this
    on Windows.
     
    chris, May 18, 2004
    #6
  7. Nick

    Ian Stirling Guest

    The standard settings should at least get the majoriry of the
    performance of the link.
    Something else is wrong.
     
    Ian Stirling, May 18, 2004
    #7
  8. Nick

    Bink Guest

    No, but it sounds like I'm going through the same thing. It's driving
    me nuts!!

    What tends to happen is if I leave the line diconnected for several
    hours, when I reconnect all is fine, d/l at full rate. After a shoirt
    while though it gets slower and slower and grinds to a halt virtually.
    Upload speed is fine! I've had BB a couple of months (I'm actually
    with Openworld) and it used to be ok.

    Tried both a Voyager USB and a Binatone ethernet router, tried
    different PC's, Win98SE and Win2K, different filters, removed all
    extension wiring etc, no help. Tried all sorts of RWIN and MTU
    settings.

    Sometimes, small downloads are OK (e.g. I can use google reasonably)
    but downloading a file more than a few k is impossible.

    BT tested the line, all OK (as I suspected, the SNR margin is good and
    the modem never loses sync and reports few errors). Sent an engineer
    out, he had no problems, they sent another engineer out and he sat
    here surfing with his Win98 laptop and speedtouch "frog" for nearly an
    hour with no probs. The minute I connect my gear, it all goes wrong
    again.

    Mine's been playing up since about the start of May, and is worse than
    ever at the moment. Did the op ever find the fault? Please help, I'm
    pulling my hair out over this one!!
     
    Bink, Jun 18, 2004
    #8
  9. what are you using now - MTU on the PC and if aplicable the router.
    looks like an MTU problem. Get a command window (cmd in the Run box of
    start) and try "ping www.bbc.co.uk -l 1472 -f' (the character befroe
    the 1472 is a lowercase L)

    if you get the response "Packet needs to be fragmented but DF set."
    try 1430 instead of 1472, if that works you need the MTU at 1458. Same
    if it times out.
    so its either your gear or your ISP. What ISP and account type ?

    Phil
     
    Phil Thompson, Jun 18, 2004
    #9
  10. Nick

    Bink Guest

    Tried one, then the other then both. Every combination I could think
    of!
    Yep, did all that. That didn't fix it.
    It's Openworld standard 512k. An update though: I managed to
    download a firmware upgrade for the ethernet router modem I was using
    and the problem seems to be fixed on that, but the Voyager still has
    the same problem. I'm happy cos I only needed the router to work, but
    it still strikes me as odd that both of these modems suddenly
    displayed the same problem yet worked fine in the past. I'm convinced
    something must have changed with the exchange equipment, an upgrade or
    something, that my modems couldn't cope with in their build state. If
    I had the time to investigate, perhaps I would, but there's more
    important things... :)
     
    Bink, Jul 2, 2004
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.