Using Net Use command...

Discussion in 'Windows Networking' started by Eric, Apr 16, 2007.

  1. Eric

    Eric Guest

    Hello, I have an image cd which is bootablef or my Compaq computer. I get to
    a dos like prompt after the cd boots so I can log into my network with my
    user credentials, which works fine.

    Once I'm in I should be able to use net use command. Evertytime I use "net
    use x: \\dakota\...\..." whihc the (..) represent actual diectories - I get
    an error saying, "syntax is incorrect, please use net help or net use /?".

    What am I doing wrong, or is it a DNS issue or could it be permissions with
    my account?
     
    Eric, Apr 16, 2007
    #1
    1. Advertisements

  2. Eric

    grep Guest

    You can only map a drive to a share, not to a folder off the share.

    So let's say your share is SHARE1 and your folder is A. You could do:
    net use x: \\dakota\SHARE1, but you can't use:
    net use x: \\dakota\SHARE1\A

    The way to get to folder A is to go to the x: drive, and then CD to A.
    Alternately, you could create a new share on folder A (I'll call it
    SHARE2) and then map your drive to it as:
    net use y: \\dakota\SHARE2

    Note that SHARE2 (aka y:) *points* to the same place as x:\A

    grep
     
    grep, Apr 16, 2007
    #2
    1. Advertisements

  3. Eric

    Eric Guest

    I appreciate the answer, now I only have one more question. Now my boot disc
    installs some networking components that allow me to connect to my network,
    but I'm not booted into windows accessing command prompt. I'm in a DOS like
    windows, so I can connect to the share on the network then access my Ghost
    image to pull down to the computer.

    Is the process going to be the same?
     
    Eric, Apr 16, 2007
    #3
  4. Eric

    grep Guest

    I'm not sure about how Ghost will handle it, but I think you should be
    able to point to the folder for the file, without a problem. If you
    can't then just go back to your server and create a new share on the
    folder that actually contains the file. Then there should be no problem
    at all. It should work exactly the same.

    grep
     
    grep, Apr 16, 2007
    #4
  5. Eric

    Eric Guest

    Last question I promise...When I do a "net logon" command is says I'm
    currently logged as as my username. So I'm on my network, but is there
    another way to just browse to a directory? The computer is Dakota, the share
    is dept, and in there is a folder called 1stlevel. So I use net use x:
    \\Dakota\dept\1stlevel and get the invalid syntax error.

    But "cd" does network in the DOS "like" windoew I'm in. Is there some other
    way to try and get to that directory? Also, if I'm on a nother computer that
    works and I'm actually booted into windows and use command prompt, the net
    use command works fine.
     
    Eric, Apr 16, 2007
    #5
  6. Eric

    grep Guest

    Eric,

    Again, you can't use net user with a folder. You can only map a drive to
    a share, not a folder. So you can't do net use x:
    \\dakota\dept\1stlevel, but you could do net use x: \\dakota\dept.

    If you're sure you can't actually do (from the x: drive) cd 1stlevel, to
    reach your data, then you'd probably be best off creating a share on
    dakota called 1stlevel, for example, that is *on* the dept\1stlevel
    folder. Then, instead of mapping to dept, you'd map like this:
    net use x: \\dakota\1stlevel, and that would put you right where you want.

    grep
     
    grep, Apr 16, 2007
    #6
  7. Eric

    Eric Guest

    Ok, so I think I got it, but my next question would be, if I do just "net use
    x: \\dakota\dept" and still get a "syntax error is incorrect" message. might
    that have to do with my permissions on the share itself? I ask because I'm
    pretty sure I tried "net use x: \\dakota\dept" already.
     
    Eric, Apr 16, 2007
    #7
  8. Eric

    grep Guest

    You could get a permissions error, sure. But you wouldn't get a syntax
    error. A syntax error means there's something wrong with the command
    itself, not the result of the command.

    grep
     
    grep, Apr 17, 2007
    #8
  9. Eric

    Eric Guest

    Thanks for all the help, it still doesn't work as of now, I still get either
    a syntax error or when I use "net use x: \\dakota\dept", I get an error
    saying "error code 58: the network responded incorrectly". So something else
    is wrong and I figure I will have to go some other route.

    Thanks!
     
    Eric, Apr 17, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.