USB MA111 Knoppix 3.9 WLAN0 no such device

Discussion in 'Linux Networking' started by Linux Dilettante, Jul 15, 2005.

  1. First off, I did post this in the LinuxQuestions forum as well but
    since that is not on Google groups, I hope this is not a multi post

    All,
    I have been running around the past 3-4 days between the Knoppix forum
    and the Ndiswrapper forum without much luck.

    I have an MA111 USB "card" connected to my PC on which I am running
    Knoppix3.9 from a Live CD.
    I have followed the steps seen in this and other forums

    a) I didn't download or install ndiswrapper since my Linux download was
    quite recent
    b) I downloaded the relevant Win XP driver files from the
    ndiswrapper.sourceforge.net/mediawiki-1.4.6 List
    site.
    I copied the MA111nd5.sys and netma111.inf files to my harddisk

    c) I ran ndiswrapper -i /mnt/hda5/netma111.inf
    I got a message "installing netma111" and it seemed to finish
    successfully

    d) I ran ndiswrapper -l
    I got
    installed ndis drivers
    netma111 driver present (but no reference to "hardware present")

    e) I typed in
    modprobe ndiswrapper
    I got no error messages or anything

    f) I typed in lsmod
    and got among other things

    usbcore 104196 8 ndiswrapper,usbhid and some other stuff

    h)when I type in
    iwconfig I get
    l0 no wireless extensions
    My USB adapter's light is glowing brightly

    AFAIK there is no NIC card installed in the PC.

    i) If I type in
    ifconfig wlan0 up
    Error while getting interface flags: no such device

    I hope all this convinces would-be solution providers that I have
    worked hard at this thing!

    Thanks
     
    Linux Dilettante, Jul 15, 2005
    #1
    1. Advertisements

  2. Please- someone should be able to direct me here.

    At least tell me I am stupid for not having tried the obvious whatever
    that is!
    I have been struggling for 5 days now.

    I am not going to do the usual throwing up my arms thing that I have
    seen people do in some linux forums because it was not as
    straightforward as XP because I am sure with the right directions I can
    get this to work.

    Pleaase?
     
    Linux Dilettante, Jul 16, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.