Unable to set media type and duplex with 3c59x.o driver and a 3c595 card

Discussion in 'Linux Networking' started by J, Aug 17, 2003.

  1. J

    J Guest

    I've been unable to get my 3c595 card to use 100baseTx-FD. I have attempted
    to force this with the mii-tool using

    mii-tool -F 100baseTx-FD eth0

    or by loading the module and specifying that speed. I loaded the module
    with the following

    insmod 3c59x debug=6 options=4,4,4 full_duplex=1,1,1

    Here is some relevant output from my system that may help to determine what
    the exact problem is.

    lspci shows
    host root # lspci |grep Ethernet
    04:02.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev
    08)
    04:09.0 Ethernet controller: 3Com Corporation 3c595 100BaseTX [Vortex]

    host root # ifconfig
    eth0 Link encap:Ethernet HWaddr FF:FF:FF:FF:FF:FF
    inet addr:10.0.0.1 Bcast:10.0.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:694 errors:86 dropped:86 overruns:0 frame:129
    TX packets:93 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:184429 (180.1 Kb) TX bytes:5580 (5.4 Kb)
    Interrupt:17 Base address:0x5840

    eth1 Link encap:Ethernet HWaddr FF:FF:FF:FF:FF:FF
    inet addr:x.x.x.x Bcast:255.255.255.255 Mask:255.255.252.0
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:60045 errors:0 dropped:0 overruns:0 frame:130
    TX packets:16560 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:34952221 (33.3 Mb) TX bytes:1414901 (1.3 Mb)
    Interrupt:18 Base address:0x3000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:10956 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10956 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1066793 (1.0 Mb) TX bytes:1066793 (1.0 Mb)

    host root # mii-tool
    eth0: 10 Mbit, half duplex, link ok
    eth1: 100 Mbit, full duplex, link ok

    I changed the HWaddr and IP since they are not important to this discussion.

    I also see the following output in /var/log/messages

    Aug 17 01:37:46 host Receiving packet size 60 status 003c.
    Aug 17 01:37:46 host eth0: exiting interrupt, status 8000.
    Aug 17 01:37:46 host eth0: interrupt, status 8011, latency 2 ticks.
    Aug 17 01:37:46 host eth0: In interrupt loop, status 8011.
    Aug 17 01:37:46 host vortex_rx(): status 8011, rx_status 4040.
    Aug 17 01:37:46 host Rx error: status 8c.

    root # cat /proc/net/dev
    Inter-| Receive | Transmit
    face |bytes packets errs drop fifo frame compressed multicast|bytes
    packets errs drop fifo colls carrier compressed
    lo: 1067342 10960 0 0 0 0 0 0 1067342
    10960 0 0 0 0 0 0
    eth1:35583568 61213 0 0 0 130 0 0 1440637
    16912 0 0 0 0 0 0
    eth0: 196293 846 105 105 0 160 0 0 6732
    107 0 0 0 0 0 0

    I haven't been able to find any way of getting this card to work. I've made
    sure that the cables are seated correctly and I'm using a 3com 10/100
    Switch with autonegotiation enabled. I've even forced the speed/duplexity
    on the switch with no luck.

    I'm hoping someone may have a better answer to this problem.

    John
     
    J, Aug 17, 2003
    #1
    1. Advertisements

  2. J

    /dev/rob0 Guest

    Try the -v for more information.
    I assume you have already Googled for this. ISTM that autonegotiation
    fails, so the driver falls back to the safest default.
    Have you done something wacky with your kernel configuration? Try using
    your distro's kernel and modules. If you ARE using a distro kernel and
    Google turned up empty, this would be an issue to take to the driver's
    maintainer, or a more specialised forum if it exists.
     
    /dev/rob0, Aug 17, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.