Trouble accessing Samba shares wirelessly

Discussion in 'Wireless' started by Gnate, Aug 12, 2012.

  1. Gnate

    Gnate

    Joined:
    Aug 12, 2012
    Messages:
    1
    Likes Received:
    0
    Hello,
    This is my first post here, I've been trying to find a solution to this issue for weeks to no avail. I apologize if this has been brought up before but I wasn't able to find it here. I recently bought a new wireless router (ASUS RT-N12 b1) after our old one started malfunctioning. Since then, I've been having a lot of issues connecting to my NAS device via Samba, which I never had issues with before I got the new router. Here's my network structure:

    Cisco Cable Modem -> Asus Wireless Router -> Buffalo Linkstation (wired), PS3 (wired), Windows 7 Laptop (wireless), OSx Laptop (wireless).

    The PS3 uses DLNA for its sharing protocol, and despite being extremely finicky, can read my NAS shared file structure. However, both laptops have had the shares mapped as networked drives via SMB. The shares work just fine when my laptop is connected to the router via ethernet cable, just not wirelessly. This leads me to believe that the mapping config is still correct; all devices use the same workgroup and credentials. Also, I can map the NAS shares over a wireless connection if I enter its local IP address, rather than directory path (ie: 196.168.1.28 vs //NASDEVICE/media/ ).

    I've played with the router firmware but can't seem to find anything helpful. I'm nearly sure it's a router issue, but not sure why it could resolve the shares when physically connected and not over wifi. Any help or insight would be very much appreciated.
     
    Gnate, Aug 12, 2012
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.