Third computer won't connect to D-Link DI-624

Discussion in 'Network Routers' started by Sly, Dec 31, 2008.

  1. Sly

    Sly Guest

    Hi,

    ISP -> Broadband modem -> D-Link DI-624
    Computer 1 (C1) - WinXP Pro Wired
    Computer 2 (C2) - WinXP Pro Wireless
    Computer 3 (C3) - WinXP Pro (ASUS P5K Premium MB) Wired or wireless

    Never had any connectivity problem with C1 and C2.
    C3, my new computer, could never connect to the Internet. It is certainly
    "connected" to the D-Link in static mode because I can browse C1 and C2
    from C3. Here is what I have tried so far:

    If I force a static IP (this works well for C1 and C2, my D-Link is then
    providing a static address and I set the TCP/IP accordingly):

    C3 IP = 192.168.0.103 (any given static address will give same results)
    Connection status = Connected
    Ping 192.168.0.1 = fails
    Ping any outside physical (XXX.XXX.XXX.XXX) address = fails
    Ping and browse C1 and C2 = successful

    If I try to get a dynamic IP (this works well for C1 and C2):

    C3 will try to acquire IP for several minutes and then...
    C3 IP = 169.254.XXX.XXX (one of those useless internal IPs)
    Connection status = "Limited or no connectivity"
    Ping 192.168.0.1 = fails
    Ping any outside physical (XXX.XXX.XXX.XXX) address = fails
    Ping and browse C1 and C2 = fails

    I tried switching cables from one computer to another. I tried using other
    LAN ports on the D-Link. I tried shutting down C1 and using its IP address
    and name on C3 (remembering to change MAC on static DHCP of D-Link). I
    tried hooking C3 directly to the broadband modem. I tried the three
    different adaptors (1 wireless and 2 regular LAN) on the MB of C3 and they
    all give the same results as above. I also restored C3 (with XP Pro) to a
    state where absolutely nothing is installed but WinXP Pro. I then
    reinstalled each adapter one by one with testing connectivity between each
    install. All results as above.

    The WinXP Pro install of C3 should be quite optimal since I installed it
    myself. I have done so for many years at work and I have never hit that
    sort of a problem.

    I am beginning to run out of options here.
    Is there a good network diagnostic tool that I could download? MS network
    diagnostic is not helping much.
    Is there a clean and simple way to force XP Pro to reinitialize its network
    components (as it does when you first install it)? I could just reinstall
    XP Pro, but I am getting a little tired of all this work with no good
    results to show for.

    Anyone feels inspired?

    Thanks... And Happy New Year to All!

    Sly
     
    Sly, Dec 31, 2008
    #1
    1. Advertisements

  2. Try one of those boot to Linux CD's and see if the internet works from it.
    If it does then something must be confused in the XP's settings. I

    f the internet still refuses to function using one of those boot CD's I
    would be inclined to try another network card in the box. It is possible
    for a partial failure of the ethernet jack on a motherboard or card to cause
    problems similar to yours.
     
    GlowingBlueMist, Jan 1, 2009
    #2
    1. Advertisements

  3. Sly

    Sly Guest

    Thanks for the reply GlowingBlueMist (and on a Dec 31st!!)

    Actually, I just reinstalled the operating system fresh going with Vista
    Ultimate this time instead of XP Pro just to see if MS did not play a
    trick on me when I asked to exercise my "downgrade right" from Vista to
    XP Pro. I usually buy Vista and then I downgrade to XP Pro and MS really
    doesn't seem to like that...

    In any case, same results with Vista. Just tried one of the LAN adaptors
    so far, but I am pretty sure all adaptors will fail the same as they did
    with XP Pro.

    Trying a bootable OS is a very good idea. I have some bootable CD's at
    work, but I doubt my wife will let me out of the house in the next 2 or 3
    days... :)

    Concerning a hardware failure, don't forget that the MB of that computer
    has 3 different on board adaptors (2 LAN and 1 WIFI), so, it would be
    unlikely that they all partially failed in the very same way... Well, one
    never knows, I guess. I suppose trying a PCI Ethernet card would not be a
    bad idea. I will see if I can find one somewhere (in the house, of
    course...).


    If you can think of anything else...


    Thanks again.

    Sly
     
    Sly, Jan 1, 2009
    #3
  4. Sly

    Smiles Guest

    is your router locked at 2 dhcp address
    can you manually set an IP address
    is your gateway correct
    can you see the router from c3
    post the output from "ipconfig /all" of c3

    just a start
    Smiles
     
    Smiles, Jan 1, 2009
    #4
  5. Good idea Smiles on the DHCP possibly being locked at too low a number. Sly
    can test that by unplugging the Ethernet cable to on one of the working
    machines and then power cycling the router. If the new machine can then get
    a DHCP address the problem is most likely in the router's setup.

    Does that router have a built in firewall that might be blocking based on
    the MAC address values, as in allowing only the two machines it was told to
    accept some time in the past?

    I agree with Sly that with multiple Ethernet ports on his motherboard it's
    most likely not a hardware problem with the PC but stranger things have
    happened.
     
    GlowingBlueMist, Jan 1, 2009
    #5
  6. Sly

    Eric Guest

    sounds to me like a typo in the gateway address in C3
    Eric
     
    Eric, Jan 1, 2009
    #6
  7. Sly

    Sly Guest

    Well...

    I don't know if I should be happy or ashamed...

    Of course, it was something stupidly simple.

    A few hours ago, I removed a SMC Ethernet adapter from a 10 year old
    computer to test it on C3. Of course, I lost about 2 hours trying to set
    this up for Vista. No use, it won't install... Then, I just shut down C2
    and took out the D-Link wireless card to fit it in C3. Bingo! First go at
    it -> Internet connection on C3?!?!?

    So, I open the Web Access D-Link router tool and I go in each page one by
    one as I did about 1000 times already. Nothing... Then, I look at the
    filtering page and it does look weird. There is a radio button that can
    either be set to IP or MAC filtering. It is on IP filtering and there is
    no filtering going on. I have seen this a 1000 times in the last few
    weeks. What if... No... It can't be... I just click on the MAC filtering
    radio button and, of course, C1 and C2 MAC are there! I had entered these
    more than a year ago and have forgotten about it.

    Yesterday, at around 3am, I was reading a thread where a guy lost a week
    looking for a solution to a similar problem. His problem was that he was
    filtering MAC addresses. I then went on the D-Link router to check
    "again" and I saw that radio button set to IP filtering and obviously no
    filtering going on. Of course, I did not think of clicking on MAC
    filtering to see what was on that page.

    You see, for me, a radio button implies an exclusive selection of many
    choices. It does not imply that you can set the two parameters
    concurrently. I think my Visual Basic background just killed me on that
    one.

    GlowingBlueMist, your latest post was right on (just read it to minutes
    ago)... But as I said, I did check for that a 1000 times in the past. I
    just got mislead by the Web Access D-Link tool. Not the first time
    though. There a good chance I would not I've seen it after reading your
    post. I just had to see it at that particular time to realize my blunder.

    Anyway, thanks to the ones who took the trouble of replying and sorry for
    the trouble.

    Happy New Year to All

    Sly
     
    Sly, Jan 1, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.