ssh to ssh

Discussion in 'Linux Networking' started by Michael Lodman, Aug 5, 2004.

  1. I have the following scenerio:

    Remote PC with Xmanager

    small linux gateway, with sshd and ssh but no X software

    local host with sshd and X software

    I am trying to do the following from the remote PC:

    ssh -X (gateway addr. x.x.x.x "ssh -X (local host add 192.168.25.40) xterm"

    and it is failing. Please help if possible.

    Looking at the verbose output I see:

    OpenSSH_3.8.1p1, OpenSSL 0.9.7c 30 Sep 2003
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to x.x.x.x [x.x.x.x] port 80.
    debug1: Connection established.
    debug1: identity file /home/jlodman/.ssh/identity type -1
    debug1: identity file /home/jlodman/.ssh/id_rsa type -1
    debug1: identity file /home/jlodman/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version OpenSSH_
    3.7.1p2
    debug1: match: OpenSSH_3.7.1p2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-
    hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-
    cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-c
    ,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-
    cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-c
    ,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160
    @openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160
    @openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit: first_kex_follows 0
    debug2: kex_parse_kexinit: reserved 0
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-
    hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-
    cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-c
    ,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-
    cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-c
    ,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160
    @openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160
    @openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit: none,zlib
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit: first_kex_follows 0
    debug2: kex_parse_kexinit: reserved 0
    debug2: mac_init: found hmac-md5
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug2: mac_init: found hmac-md5
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug2: dh_gen_key: priv key bits set: 122/256
    debug2: bits set: 519/1024
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug3: check_host_in_hostfile: filename /home/jlodman/.ssh/known_hosts
    debug3: check_host_in_hostfile: match line 1
    debug1: Host '63.200.219.149' is known and matches the RSA host key.
    debug1: Found key in /home/jlodman/.ssh/known_hosts:1
    debug2: bits set: 504/1024
    debug1: ssh_rsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: /home/jlodman/.ssh/identity (0)
    debug2: key: /home/jlodman/.ssh/id_rsa (0)
    debug2: key: /home/jlodman/.ssh/id_dsa (0)
    debug1: Authentications that can continue: publickey,password,keyboard-
    interactive
    debug3: start over, passed a different list publickey,password,keyboard-
    interactive
    debug3: preferred publickey,keyboard-interactive,password
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Trying private key: /home/jlodman/.ssh/identity
    debug3: no such identity: /home/jlodman/.ssh/identity
    debug1: Trying private key: /home/jlodman/.ssh/id_rsa
    debug3: no such identity: /home/jlodman/.ssh/id_rsa
    debug1: Trying private key: /home/jlodman/.ssh/id_dsa
    debug3: no such identity: /home/jlodman/.ssh/id_dsa
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup keyboard-interactive
    debug3: remaining preferred: password
    debug3: authmethod_is_enabled keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug2: userauth_kbdint
    debug2: we sent a keyboard-interactive packet, wait for reply
    debug1: Authentications that can continue: publickey,password,keyboard-
    interactive
    debug3: userauth_kbdint: disable: no info_req_seen
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup password
    debug3: remaining preferred:
    debug3: authmethod_is_enabled password
    debug1: Next authentication method: password
    debug3: packet_send2: adding 48 (len 61 padlen 19 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: Authentication succeeded (password).
    debug2: fd 6 setting O_NONBLOCK
    debug2: fd 7 is O_NONBLOCK
    debug1: channel 0: new [client-session]
    debug3: ssh_session2_open: channel_new: 0
    debug2: channel 0: send open
    debug1: Entering interactive session.
    debug2: callback start
    debug2: ssh_session2_setup: id 0
    debug2: x11_get_proto: /usr/openwin/bin/xauth -f /tmp/ssh-
    xeMPv15491/xauthfile generate unix:19.0 MIT-MAGIC-COOK
    IE-1 untrusted timeout 1200 2>/dev/null
    debug2: x11_get_proto: /usr/openwin/bin/xauth list unix:19.0 . 2>/dev/null
    debug1: Requesting X11 forwarding with authentication spoofing.
    debug2: channel 0: request x11-req
    debug1: Sending command: /bin/ssh -X 192.168.25.40
    debug2: channel 0: request exec
    debug2: fd 4 setting TCP_NODELAY
    debug2: callback done
    debug2: channel 0: open confirm rwindow 0 rmax 32768
    debug1: Remote: No xauth program; cannot forward with spoofing.
    debug2: channel 0: rcvd adjust 131072
    debug2: channel 0: rcvd ext data 72
    Pseudo-terminal will not be allocated because stdin is not a terminal.
    debug2: channel 0: written 72 to efd 7
    debug2: channel 0: rcvd ext data 31
    Host key verification failed.
    debug2: channel 0: written 31 to efd 7
    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug2: channel 0: rcvd eof
    debug2: channel 0: output open -> drain
    debug2: channel 0: obuf empty
    debug2: channel 0: close_write
    debug2: channel 0: output drain -> closed
    debug2: channel 0: rcvd close
    debug2: channel 0: close_read
    debug2: channel 0: input open -> closed
    debug3: channel 0: will not send data after close
    debug2: channel 0: almost dead
    debug2: channel 0: gc: notify user
    debug2: channel 0: gc: user detached
    debug2: channel 0: send close
    debug2: channel 0: is dead
    debug2: channel 0: garbage collecting
    debug1: channel 0: free: client-session, nchannels 1
    debug3: channel 0: status: The following connections are open:
    #0 client-session (t4 r0 i3/0 o3/0 fd -1/-1)

    debug3: channel 0: close_fds r -1 w -1 e 7
    debug1: fd 1 clearing O_NONBLOCK
    debug2: fd 2 is not O_NONBLOCK
    debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 6.9 seconds
    debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
    debug1: Exit status 255
     
    Michael Lodman, Aug 5, 2004
    #1
    1. Advertisements

  2. -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1
    NotDashEscaped: You need GnuPG to verify this message

    [ Followup-To the only ng that is valid for me ]

    Install the Xfree package containing 'xauth' (XFree86-xauth* or
    alike) and retry.

    --
    Michael Heiming (GPG-Key ID: 0xEDD27B94)
    mail: echo | perl -pe 'y/a-z/n-za-m/'
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)

    iD8DBQFBEn9vAkPEju3Se5QRAuE2AJ9p/z0X3djrhSVWO7pUNqXubO4XMQCcDK5f
    vGkLUge+DJP/PKXT0ZL+PMU=
    =hEsG
    -----END PGP SIGNATURE-----
     
    Michael Heiming, Aug 5, 2004
    #2
    1. Advertisements

  3. You may want to setup port forwarding or something, to avoid SSH'ing an SSH.
     
    Patrick McDonnell, Aug 6, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.