Slow loading web pages

Discussion in 'Linux Networking' started by blues2use, Oct 29, 2011.

  1. blues2use

    blues2use Guest

    I have recently started using high-speed Comcast cable modem @ 15MBPS. I
    am having a problem with web pages loading slowly in Mint. I am running a
    dual boot Mint/Win7 desktop pc hardwired to the router. The pages load
    nearly instantaneously in Win7 (Firefox or Chrome) but lag considerably
    in Mint. I have noticed that when I navigate to a web page I see the
    "Looking up whateversite.com" in the lower left corner and "sending
    request" followed by "waiting for whateversite.com" in Firefox and Chrome
    until the page actually loads. I have checked the DNS settings in Win7
    and Mint and they are the same. Thunderbird and Pan speeds are unaffected.

    At this point, I'm looking for suggestions to check for what might be
    causing this lag or how to correct it. BTW, this desktop pc is connected
    via ethernet cable to my router. The wireless laptops being served by the
    router (running dual boot XP/Mint) load pages extremely quickly as well
    in either operating system. Therefore, it seems that there is something
    wrong in my network settings on this particular Win7/Mint desktop pc
    configuration.

    Ethernet info - Ethernet controller: Broadcom Corporation NetXtreme
    BCM5755 Gigabit Ethernet PCI Express (rev 02)

    Router - Linksys WRT54G

    Suggestions for what to check will be most appreciated.

    Thanks in advance..
     
    blues2use, Oct 29, 2011
    #1
    1. Advertisements

  2. blues2use

    J G Miller Guest

    Use nslookup and/or dig to see how long name lookups take.

    From what I recall, there used to be an issue with Firefox
    and IPv6.

    From what I vaguely recall, if IPv6 was enabled on the system,
    lookups were made using IPv6 first, then when that eventually
    timed out, the lookup was then correctly made using IPv4.

    Check the Firefox configuration for

    network.dns.disableIPv6

    and see if setting it to boolean true makes any difference.
     
    J G Miller, Oct 29, 2011
    #2
    1. Advertisements

  3. Hello,

    blues2use a écrit :
    What about (long enough) file download using HTTP or FTP ?
    A packet capture of the traffic generated when requesting a page might help.
     
    Pascal Hambourg, Oct 29, 2011
    #3
  4. J G Miller a écrit :
    What you describe is not an issue with firefox nor IPv6 but with broken
    DNS servers or relays.
     
    Pascal Hambourg, Oct 29, 2011
    #4
  5. blues2use

    J G Miller Guest

    le samedi, 29 octobre, 2011 á 18:10:32h +0200, Pascal Hambourg a écrit:
    So what should one do if those broken DNS servers or relays are outside
    of one's administrative control and the people responsible for them
    refuse to fix them?
     
    J G Miller, Oct 29, 2011
    #5
  6. blues2use

    Bit Twister Guest

    Change DNS server values, or run your own caching server. :)
     
    Bit Twister, Oct 29, 2011
    #6
  7. blues2use

    blues2use Guest

    My cable modem uses fixed DNS via Comcast. Regardless of what I use in my
    router, it has to pass through those DNS servers. I'm thinking I should
    call Comcast to find out what the DNS delay problems are.

    This problem started just about a week ago but it hasn't gotten any
    worse; just never got any better.

    Thanks for the suggestion.
     
    blues2use, Oct 29, 2011
    #7
  8. blues2use a écrit :
    Why ? Does Comcast prohibit communication with any other DNS ?
    IMO you should first check whether your issue is actually a DNS problem,
    with proper DNS tools as already suggested. A web browser alone is not
    enough to investigate network problems.
     
    Pascal Hambourg, Oct 29, 2011
    #8
  9. blues2use

    blues2use Guest

    Currently running caching DNS server with about the same results in lag
    speed...just spent another hour in tech chat with Comcast...it appears to
    be a physical problem possibly in my outside connections at the
    box...we'll find out Monday afternoon...

    Thanks
     
    blues2use, Oct 30, 2011
    #9
  10. blues2use

    blues2use Guest

    Further investigations show: my Mint dual boot Win7 loads web pages
    extremely quickly in Firefox and Chrome as would be expected with a 15mbps
    connection. I am still experiencing a lag from 6 to as much as 15 seconds
    before a web page fully displays in Firefox and Chrome in my Mint
    installation; as previously mentioned, I am running a locally caching DNS
    without any improvement in the lag. Also, I'm not so sure that there is,
    in fact, a physical connection problem but that there is a system setting
    or settings problem in Mint. i just don't know what to check to see where
    the bottleneck may be so that I can make the necessary corrections.

    Thanks
     
    blues2use, Oct 30, 2011
    #10
  11. blues2use

    Bit Twister Guest

    You can change DNS servers to rule out a dns server. Easy to do,

    $ cat /etc/resolv.conf
    nameserver 127.0.0.1


    Using the OpenDns server

    $ cat /etc/resolv.conf
    nameserver 208.67.222.222
    nameserver 127.0.0.1

    Run your test.

    Order of DNS resolution might be improved via nsswitch.conf

    My change
    $ dif /etc/nsswitch.conf /etc/nsswitch.conf_vorig | grep hosts
    < hosts: files dns
    To improve Firefox speed, my $HOME/.mozilla/firefox/*.default/user.js has

    user_pref("browser.download.manager.scanWhenDone", false);
    user_pref("browser.safebrowsing.enabled", false);
    user_pref("browser.safebrowsing.malware.enabled", false);
    user_pref("network.dns.disableIPv6", true);
    user_pref("network.dns.disablePrefetch", true);
    user_pref("network.prefetch-next", false);
     
    Bit Twister, Oct 30, 2011
    #11
  12. blues2use

    Jorgen Grahn Guest

    No, but remember that he said some browsers (in Linux) showed the
    delay, and others didn't. (It seems to me he forgets that half of the
    time, too.)

    I too suspect some IPv6-related problem, but I can't remember which
    ones exist or how you prove that's what you see. Possibly it's
    triggered by an exact combination of bugs/settings in the browser,
    bugs/settings in the resolver, the DNS and your IPv6 setup.

    /Jorgen
     
    Jorgen Grahn, Oct 30, 2011
    #12
  13. blues2use

    blues2use Guest

    I have reverted to Mint 10 from 11 and my slow loading issue is fixed. I
    have no idea why 11 would have worked fine for a while and then started
    the web page lagging issue.

    Anyway, thanks to all for the suggestions. I appreciate your help...
     
    blues2use, Oct 30, 2011
    #13
  14. blues2use

    J G Miller Guest

    No the issue is not fixed. You have merely hidden the issue,
    rather like sweeping dirt under the carpet.
     
    J G Miller, Oct 30, 2011
    #14
  15. blues2use

    bluse2use Guest

    That may well be true but I had nothing else to check to try and
    alleviate the lagging problem. It would seem that working under Mint 10
    does not necessarily mean working under Mint 11. At this point, using 10
    without the lag is more important for me than troubleshooting an ongoing
    condition in 11.

    Thanks
     
    bluse2use, Oct 30, 2011
    #15
  16. blues2use

    David Brown Guest

    Did you keep the same Firefox and Chrome profiles? It is true that it
    is hard to get real malware on Linux, but it is just as easy to get
    tracking cookies and other such junk, which can sometimes greatly slow
    down web browsing.
    This is another carpet-sweeping suggestion, but have you tried using
    Adblock and Flashblock on your browsers? Most sites are much faster
    without adverts and flashing distractions.
     
    David Brown, Oct 31, 2011
    #16
  17. blues2use

    Jorgen Grahn Guest

    A tcpdump from the time the problem happened (with a freshly rebooted
    system, i.e. no cached info in the resolver) would probably have
    revealed the cause.

    /Jorgen
     
    Jorgen Grahn, Oct 31, 2011
    #17
  18. blues2use

    bluse2use Guest

    Didn't keep the profiles on Firefox or Chrome...basically reverted to 10
    and restored certain files from backup and went from there...I've tried
    Adblock and Flashblock but that wasn't the problem. The page call would
    just sit there in FF or Chrome until maybe 15-20 seconds later the entire
    page would load all at once. Additionally, from there, each web page did
    the same thing only not as slowly but still with noticeable lag.

    Thanks
     
    bluse2use, Oct 31, 2011
    #18
  19. blues2use

    bluse2use Guest

    Ok, thanks...I'll remember that if the situation occurs again. Likely I
    will upgrade to 11 again just to see if the problem reoccurs. It only
    takes me about an hour to completely install a working system so it's not
    a big deal. It's just the idea that it was a network setting or other
    error that I couldn't find. Even the local DNS caching really didn't
    help...
     
    bluse2use, Oct 31, 2011
    #19
  20. blues2use

    Jorgen Grahn Guest

    Then I suggest tcpdumping /before/ the upgrade too, to get something to
    compare with. Make sure you capture the entire name server queries and
    responses as well as the actual www chatter.

    /Jorgen
     
    Jorgen Grahn, Oct 31, 2011
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.