Slow browsing with cable modem

Discussion in 'Linux Networking' started by Stephen Zilliox, Apr 21, 2004.

  1. Hi
    Sorry i did miss the whole thread, but as far as i understand the problem,
    you use a high-speed internet connection but you can not access
    all webpages at reasonalbe speed......and you cannot browse _some_ pages
    at all.

    Well,i had a quite similar problem this weekend. I put a new install
    of a stable Debian distro on an old server and tried to
    download some tools via Konquerer (and Mozilla).

    Most webpages and FTPs didn't response.
    When i lowered the MTU of my LAN interface, all worked fine.
    Well, i have a linux gateway in my lan, but it doesn't alter
    the IP-packets from client machines (such as the above mentioned server)
    when masquerading them.

    The default MTU of eth-interfaces is 1500 afaik.
    Try values of 1492 of even lower (1472 for example).
    _Some_ routes on the internet seem to require this.

    Ok, for your ISP/LAN-Interface please try (when it is up already):

    ifconfig <Device_Name> mtu 1472 up


    Then try again.

    HTH

    Ralf
     
    Ralf Herrmann, May 5, 2004
    #41
    1. Advertisements

  2. Just to let you know the problem is resolved!!!! After all this time and
    effort I wish to thank everyone who gave me a hand especially Ralf and P.
    Gentry---if nothing else I learned quite a bit about linux and networking.
    I borrowed a router from a friend and set it up under WinXP and when I
    rebooted to linux everything was blazing fast. I could access all sites
    equally well, and news and mail works also. Looks like this was all I
    needed. Wanted to tell the group in case this happens to someone else they
    can take a shorter route to solving the problem than I did. :) Yes, I'm
    smiling now. Thanks again.

    Steve Z.
     
    Stephen Zilliox, May 8, 2004
    #42
    1. Advertisements

  3. Stephen Zilliox

    P Gentry Guest

    Glad you hung in there and that everything is working great :)

    And thanks for posting a resolution so that others that search -- the
    ones that do -- will have a solution. ^'s off to you.

    Have fun surfing with Linux,
    prg
    email above disabled
     
    P Gentry, May 9, 2004
    #43
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.