Simple LAN Routing Problem

Discussion in 'Windows Networking' started by =?Utf-8?B?bWlucm9u?=, Jan 18, 2005.

  1. LAN1 is using 192.168.1.x snm 255.255.255.0. This is the training room.
    Private network LAN is 10.0.11.x snm 255.255.255.0. This is a segment on the
    corp LAN using a default gateway of 10.0.11.254.

    I am trying to use RRAS to route from private 192 to private 10 so folks in
    the training lab can access the internet through corp 10. network.

    ServerMain is using 2 nics. TrainingroomNIC 192.168.1.10, 255.255.255.0 DG
    192.168.1.10 DNS 192.168.1.10.
    ExternalCorpNIC 10.0.11.1, snm 255.255.255.0, DG 10.0.11.254.
    ServerMain is hosting AD and DNS.

    Clients in training room are XP pro with SP2 and Win 2003 Server.

    The training clients can ping 192.168.1.10 on ServerMain but not the
    10.0.11.1 on ServerMain. RRAS is running and the routing table looks fine.
    ServerMain can ping 10 or 192 segments no problem. I tried to set up with
    just RAS, then using NAT but just can't seem to resolve the routing problem.
    That is the first issue that I can't get past. Then I want the clients to be
    able to access the Internet using the 10.0.1.254 gateway on the corp network.

    Any ideas. I have configured this many times, deleted and reconfigured RRAS
    and even NAT several times and changed DG. I also have tried both with and
    without RIP v2. Any ideas would be appreciated.
     
    =?Utf-8?B?bWlucm9u?=, Jan 18, 2005
    #1
    1. Advertisements

  2. You should be able to do this with RRAS, but since we're not sure of the
    current configuration - Try:

    1. On the server, Disable RRAS and any routing protocols.

    2. On the server, right click My Network Places and select Properties.
    Click Advanaced/Advanced Settings. Make sure the Local Area connection for
    the 192.168.1.10 NIC is at the top of the binding order.

    3. On the server, run regedit and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    Double click on IPEnableRouter and set its value to 1.

    4. Delete the default gateway on the 192.168.1.10 NIC.

    5. Configure clients with a default gateway of 192.168.1.10.

    6. The router/gateway at 10.0.11.254 needs a route to the 192.168.1.x
    network. How you configure this depends on the nature of the device. On a
    multihomed computer, you could use:

    route add 192.168.1.0 mask 255.255.255.0 10.0.11.1

    If you are unable to configue this, or if your Internet router does not
    support NAT for remote subnets, then you will have to implement NAT on
    ServerMain.

    Doug Sherman
    MCSE Win2k/NT4.0, MCSA, MCP+I, MVP
     
    Doug Sherman [MVP], Jan 18, 2005
    #2
    1. Advertisements

  3. problem.

    Routing only,...no NAT!

    299810 - HOW TO: Configure Windows 2000 to Be a Router
    http://support.microsoft.com/default.aspx?scid=kb;en-us;299810

    Your "ServerMain" will have to use as its Default Gateway whatever device is
    being use on the 10.* network normally.

    The Internet Sharing Device (whatever that is in your case) will also need a
    Static Route that tells it what gateway device to use for the192.* network.
    If you don't do this they will be able to use the 10.* network just fine but
    won't be able to use the internet because the Internet Sharing Device will
    have no idea how to "get back" to them.
     
    Phillip Windell, Jan 18, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.