set maximum ip-packet-size ?

Discussion in 'Linux Networking' started by peter pilsl, Jun 1, 2004.

  1. peter pilsl

    peter pilsl Guest

    My provider currently has big router-problems. Today again all packages
    was the same problem last week. I'm sure they blame cisco again ;)

    So I really cant work, cause it seems that most of my ip-packages are
    bigger than that. I can ssh-connect a remote host, I can echo the
    hostname, but a 'ls -l' is too much already and the connection freezes.

    Is there any way to tell my host that it should somehow only creater
    small packages and tell its ip-partners to do the same? Would be useful
    in my situation.

    thnx,
    peter
     
    peter pilsl, Jun 1, 2004
    #1
    1. Advertisements

  2. Hi Peter,
    Assuming you are using some *nix OS......
    when you type 'ifconfig' you get a list of all network devices
    set up on your box. One of them is used to speek to the internet.

    If it is an ethernet interface (like eth0, connected to a router or gateway),
    the default MTU (maximum transfer unit) will most likely have the default
    setting of 1500. You can use the ifconfig command to alter this setting
    (for any network interface).

    Make sure to have root privileges and then type

    ifconfig eth0 mtu 1472 up

    Replace eth0 with the appropriate device.
    The number 1472 is the new desired MTU. You can play with it......

    Ok, this will be lost, when you reboot. But it greatly depends on your
    distro how to make these settinge permanent. You might want to look
    at the network configuration files or the startup scripts themselves
    to do this.....

    HTH

    Ralf
     
    Ralf Herrmann, Jun 2, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.