seems arp problem with bonding 802.3ad on centos 5

Discussion in 'Linux Networking' started by Philippe.Weill, Jan 29, 2008.

  1. I have One switch ( cisco 3750 ) and four servers with 2 intel e1000 card

    I want to do bonding 802.3ad ( mode 4 bonding linux )

    everything seems to be properly configured on server and switch
    see configuration at the end

    I can access with ssh from any external machine to all servers

    but connection from one server to another work strangely
    seems arp problem beetween server on bond device and not with the gateway on
    the cisco

    working 10 seconds every 30 seconds

    if somebody as an idea

    PING dynserv2.ipslnet (172.20.176.92) 56(84) bytes of data.
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=1 ttl=64 time=1.16 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=2 ttl=64 time=0.134 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=3 ttl=64 time=0.092 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=4 ttl=64 time=0.156 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=5 ttl=64 time=0.092 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=6 ttl=64 time=0.156 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=7 ttl=64 time=0.094 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=8 ttl=64 time=0.157 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=9 ttl=64 time=0.095 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=35 ttl=64 time=990 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=36 ttl=64 time=0.136 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=37 ttl=64 time=0.078 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=38 ttl=64 time=0.141 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=39 ttl=64 time=0.078 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=40 ttl=64 time=0.141 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=41 ttl=64 time=0.078 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=42 ttl=64 time=0.140 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=43 ttl=64 time=0.202 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=68 ttl=64 time=1990 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=69 ttl=64 time=990 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=70 ttl=64 time=0.122 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=71 ttl=64 time=0.064 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=72 ttl=64 time=0.126 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=73 ttl=64 time=0.065 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=74 ttl=64 time=0.127 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=75 ttl=64 time=0.066 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=76 ttl=64 time=0.129 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=77 ttl=64 time=0.191 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=102 ttl=64 time=1990 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=103 ttl=64 time=990 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=104 ttl=64 time=0.109 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=105 ttl=64 time=0.174 ms
    64 bytes from dynserv2.ipslnet (172.20.176.92): icmp_seq=106 ttl=64 time=0.111 ms

    --------------------------------
    config
    --------------------------------

    etherchannel is configured on switch
    Version 12.2(25)SEB2

    interface Port-channel1
    description dynserv0 bonding
    switchport access vlan 353
    !
    interface Port-channel2
    description dynserv1 bonding
    switchport access vlan 353
    !
    interface Port-channel3
    description dynserv2 bonding
    switchport access vlan 353
    !
    interface Port-channel4
    description dynserv3 bonding
    switchport access vlan 353
    !
    interface GigabitEthernet1/0/1
    description dynserv0 bond
    switchport access vlan 353
    channel-group 1 mode active
    !
    interface GigabitEthernet1/0/2
    description dynserv0 bond
    switchport access vlan 353
    channel-group 1 mode active
    !
    interface GigabitEthernet1/0/3
    description dynserv1 bond
    switchport access vlan 353
    channel-group 2 mode active
    !
    interface GigabitEthernet1/0/4
    description dynserv1 bond
    switchport access vlan 353
    channel-group 2 mode active
    !
    interface GigabitEthernet1/0/5
    description dynserv2 bond
    switchport access vlan 353
    channel-group 3 mode active
    !
    interface GigabitEthernet1/0/6
    description dynserv2 bond
    switchport access vlan 353
    channel-group 3 mode active
    !
    interface GigabitEthernet1/0/7
    description dynserv3 bond
    switchport access vlan 353
    channel-group 4 mode active
    !
    interface GigabitEthernet1/0/8
    description dynserv3 bond
    switchport access vlan 353
    channel-group 4 mode active

    for all linux server only ip addesse is changed

    [[email protected] ~]# grep bond /etc/modprobe.conf
    options bonding mode=4 miimon=100
    alias bond0 bonding

    [[email protected] ~]# more /etc/sysconfig/network-scripts/ifcfg-eth0
    DEVICE=eth0
    MASTER=bond0
    BOOTPROTO=none
    SLAVE=yes
    ONBOOT=yes

    [[email protected] ~]# more /etc/sysconfig/network-scripts/ifcfg-eth1
    DEVICE=eth1
    MASTER=bond0
    BOOTPROTO=none
    SLAVE=yes
    ONBOOT=yes

    [[email protected] ~]# more /etc/sysconfig/network-scripts/ifcfg-bond0
    DEVICE=bond0
    TYPE=Bonding
    BOOTPROTO=none
    IPADDR=172.20.176.93
    NETMASK=255.255.255.0
    BROADCAST=172.20.176.255
    GATEWAY=172.20.176.254
    ONBOOT=yes
     
    Philippe.Weill, Jan 29, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.