rtnetlink: network unreachable for Routing for multiple uplinks using ip route add

Discussion in 'Linux Networking' started by joerg sauer, Apr 18, 2005.

  1. joerg sauer

    joerg sauer Guest

    Dear all,
    after playing around and having the same problems on all linux
    versions I have at hand and not finding a solution in the net I ask
    for your help.

    Problem: Want to set up a router with multiple uplinks to the
    internet.
    Checked documentation at several places, but all examples given will
    not work!
    Always get rtnetlink: network is unreachable.

    Have tried this with IPCop 1.4.5, SUSE Prof. 9.1 same effect.

    OK now the details:

    For ISP 1 (all IP addresses not the real ones!)
    eth0: 10.138.233.227
    NETMASK: 255.255.255.240
    GW: 10.138.233.226

    For ISP2
    eth1 10.51.238.226
    NETMASK: 255.255.255.240
    GW: 10.51.238.226

    /etc/rt_tables: (added at end)
    200 T1
    201 T2

    Routing table empty but loopback device when I start:
    ip route add 10.138.233.224/28 dev eth0 src 10.138.233.227 table T1
    ip route add default via 10.138.233.226 table T1
    Error Message: rtnetlink: network is unreachable

    ip route add 10.51.238.224/28 dev eth1 src 10.51.238.226 table T2
    ip route add default via 10.51.238.225 table T2
    Error Message: rtnetlink: network is unreachable


    If I use the commands without the table T1/T2 I am able to set the
    route. But later it doesn't work.
    I took the commands from
    Linux Advanced Routing & Traffic Control HOWTO
    Chapter 4.2
    And crosschecked with
    Redundant Internet Connections Using Linux from
    http://www.samag.com/documents/s=1824/sam0201h/0201h.htm

    Same effect.
    Kernel on Suse9.1: 2.6.4-52
    Kernel on IPCop: 2.4.29

    Kernel configured with:
    CONFIG_IP_ADVANCED_ROUTER=y
    CONFIG_IP_MULTIPLE_TABLES=y
    CONFIG_IP_ROUTE_MULTIPATH=y

    ip version:
    Suse: iproute2-ss020116
    ipcop: iproute2-ss010824

    Any clues?

    Thanks in advance
    Joerg
     
    joerg sauer, Apr 18, 2005
    #1
    1. Advertisements

  2. It is strange.

    Maybe first you should try:

    ip addr add 10.138.233.227/28 dev eth0 brd +

    etc.

    Jarek P.
     
    Jarek Poplawski, Apr 18, 2005
    #2
    1. Advertisements

  3. Can you briefly explain what it does? Or do we have to read the man? :D
     
    Coenraad Loubser, Apr 18, 2005
    #3
  4. joerg sauer

    joerg sauer Guest

    Hi, and thanks for your reply, but
    Actually I tried allmost everything allready.
    I first thought about some wrong configuration therefore I removed
    every bit of it and started to configure the system by issueing
    commands from the console like
    ip addr add 10.138.233.227/28 brd 10.138.233.239 dev eth1
    and so on. But always I ended up with the error message when I was
    using ip route add with the 'table ' part.

    Somebody who has any clues?

    Besides I searched google before and found some articles discussing
    maybe the same issue but unfortunately in polish language, which I do
    not understand :-(

    So if somebody polish speaking guy can help out, would be great
    (pl.comp.os.linux.networking)

    Thanks
    Joerg
     
    joerg sauer, Apr 19, 2005
    #4
  5. Routing table is seldom "empty but loopback device", and if your
    network device isn't configured there are messages like this.
    But it could be something else too.

    Jarek P.
     
    Jarek Poplawski, Apr 19, 2005
    #5
  6. If you could show what is your ifconfig and route -n?
    Could you add links or paste some text?

    Jarek P.
     
    Jarek Poplawski, Apr 19, 2005
    #6
  7. I hope it was eth0?

    Jarek P.
     
    Jarek Poplawski, Apr 19, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.