Remote Desktop: The client could not connect to the remote compute

Discussion in 'Windows Networking' started by crazyglue, Jan 6, 2006.

  1. crazyglue

    crazyglue Guest

    I have 2 servers on the same network both running Windows Server 2003
    Standard. I can connect via Remote Desktop Connection from an XP
    Professional workstation to one but not the other. The one that isn't
    working gives me the following message:
    "Remote Desktop Disconnected. The client could not connect to the remote
    computer. Remote connections might not be enabled or the computer might be
    too busy to accept new connections. It is also possible that network
    problems are preventing your connection. Please try connecting again later.
    If the problem continues to occur, contact your administrator."
    I enabled Remote Desktop the same way on both machines -- the machine that
    is NOT working is also running Windows Firewall (the machine that IS working
    is NOT running Windows Firewall). Thinking this might be the difference, I
    disabled the firewall, however the same problem occurs.

    I am the only admin of these servers, so noone else would be connected to
    either of them. Also, I've tried this numerous times on different days and
    times, and I always get the same error message.

    Does anyone have any ideas on what might be causing this problem?
     
    crazyglue, Jan 6, 2006
    #1
    1. Advertisements

  2. Assuming you have enable RDC on the server, can you RDC to itself?

    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
    I have 2 servers on the same network both running Windows Server 2003
    Standard. I can connect via Remote Desktop Connection from an XP
    Professional workstation to one but not the other. The one that isn't
    working gives me the following message:
    "Remote Desktop Disconnected. The client could not connect to the remote
    computer. Remote connections might not be enabled or the computer might be
    too busy to accept new connections. It is also possible that network
    problems are preventing your connection. Please try connecting again later.
    If the problem continues to occur, contact your administrator."
    I enabled Remote Desktop the same way on both machines -- the machine that
    is NOT working is also running Windows Firewall (the machine that IS working
    is NOT running Windows Firewall). Thinking this might be the difference, I
    disabled the firewall, however the same problem occurs.

    I am the only admin of these servers, so noone else would be connected to
    either of them. Also, I've tried this numerous times on different days and
    times, and I always get the same error message.

    Does anyone have any ideas on what might be causing this problem?
     
    Robert L [MS-MVP], Jan 6, 2006
    #2
    1. Advertisements

  3. crazyglue

    perfectlemur Guest

    I am having a similar issue. But my servers had RDP working for months
    before hand. Now 3 of the 10 servers won't allow RDP connections after
    installing Microsoft's December patches. I don't know if the same thing
    could be affecting you.
     
    perfectlemur, Jan 6, 2006
    #3
  4. crazyglue

    crazyglue Guest

    Interesting thought. No, it can't. I get the same error message.
     
    crazyglue, Jan 6, 2006
    #4
  5. crazyglue

    mikeindo Guest

    uh-oh... same problem here. only one of two w2k3 servers won't allow remote
    desktop connections. port 3389 just not listening. might try re-assigning
    RDP port in Reg to see. cant telnet to 3389 either. RDP-TCP not disabled in
    TSCC.msc either. services seem fine. fortunately, i can use Dameware Mini
    Remote Control to get desktop, but of course only cuz uses different port!
     
    mikeindo, Jan 9, 2006
    #5
  6. Is the server that is not connecting a new machine? I had the sam
    trouble and it wasn't until I went to my power settings and set my "Tur
    Hard Disk off to NEVER." before I could connect. The default was set t
    1 hour. You may have been trying after the hard disk shut down b
    itself
     
    Joseph fantozzi, Feb 23, 2009
    #6
  7. crazyglue

    Alister Guest

    On Feb 23, 9:02 pm, Joseph fantozzi <Joseph.fantozzi.
    > wrote:

    This is a known issue following some security patches from December.
    On initial reboot after applying the patches, terminal services is
    disabled, and if you go into Administrative Tools/Services the option
    to change the startup type is greyed out. I run 30 2003 servers at a
    datacentre and found the only option was to logon to another machine
    which hadn't been rebooted and issue a remote shutdown -r to the
    affected server. The second reboot cures the problem.
    AFAIK Microsoft have done nothing about this issue, but it is
    mentioned numerous times in various forums if you do a google.

    Alister
     
    Alister, Feb 24, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.