Redhat 9: Can ping, Can lookup names, Can ftp, Can Not browse http...

Discussion in 'Linux Networking' started by 2boxers_at_comcast_dot_net, Nov 19, 2003.

  1. Just as the subject says.

    I am using PPP on redhat 9.

    I am able to ping hosts on the internet by name or by ip address.
    I am able to perform name lookups.
    I am able to ftp.

    I am Unable to open webpages with lynx and with mozilla.
    When I try, the lookup is successful, i get the notification: Http
    request sent: waiting for response.. but it just hangs there

    The system is behaving as if port 80 packets are being filtered, but I
    have no indication that they are.

    iptables -L shows no rules

    I know this ISP isnt blocking. I am able to browse with this account
    from other hosts.

    any ideas anybody?
    -c
     
    2boxers_at_comcast_dot_net, Nov 19, 2003
    #1
    1. Advertisements

  2. What if you use telnet to open a connection on port 80 of some web
    server? Something like

    telnet www.dilbert.com 80

    and then request the / page? GET / HTTP/1.0 (two enter here)

    Davide
     
    Davide Bianchi, Nov 19, 2003
    #2
    1. Advertisements

  3. 2boxers_at_comcast_dot_net

    2boxers Guest

    This seems to work. I get html data.

    What would cause telnet to work and not lynx or mozilla?

    Also, if I set up an iptables nat on this interface, i get the same
    issue at the workstation.

    At the workstation, I can lookup names, ping names or addresses, ftp,
    etc, but I cannot browse. The web browser just hangs.

    Just to reiterate:

    On the linux box, with or without any iptables modules loaded, when
    using PPP i seem to be able to do anything but browse http.

    If i route to a local gateway on the network that is connected to the
    Internet, I am able to browse from this box.

    This is undoubtedly PPP related. As to why I can telnet some pages
    through PPP0, but cannot pull them down with lynx or mozilla, I have
    no idea.

    any more ideas?

    Charles
     
    2boxers, Nov 19, 2003
    #3
  4. Then there is nothing wrong with your network configuration, nor
    with your firewall.
    Are you using a proxy? Maybe the proxy is misconfigured

    Davide
     
    Davide Bianchi, Nov 19, 2003
    #4
  5. 2boxers_at_comcast_dot_net

    2boxers Guest

    I am definitely not using a proxy from mozilla and it works through
    the lan, just not through the ppp interface.

    I did not intentionally set up a proxy for lynx either. If I recall,
    this is done in lynx.cfg or by setting an environment variable-
    neither of which I have done since I installed 3 days ago.

    This is my 2nd redhat 9 install, but like my 50th linux install.

    In redhat 9, is there a system wide http proxy somewhere that could
    only effect ppp interfaces?

    Other than iptables, what else in the 2.4.22 kernel can filter packets
    for ppp interfaces or otherwise? I guess this question does not make
    sense as the telnet seemed to work, but aside fromt proxy, what else
    could be the cause?

    Remember what I said? http doesn't work when the ppp box is acting as
    an iptables nat either. A proxy should not affect these packets, but
    regardless I dont think any proxies are in use.

    Thanks for sticking with me on this.
    Charles
     
    2boxers, Nov 19, 2003
    #5
  6. 2boxers_at_comcast_dot_net

    2boxers Guest

    Problem solved!

    I recompiled the kernel, disabling three options:

    I disabled socket filtering, PPP multilink support, and PPP over
    Ethernet.

    Disabling socket filtering also disables PPP filtering. Not that I
    even had PPP filtering enabled in the prior kernel, nor was I passing
    any filtering options to PPPd.

    As far as I can tell, I wasnt using any of those features, but there
    was certainly something happening specific to http only, and only for
    the PPP interface, so they seems like logical choices to disable.

    I wish I knew exactly what the issue was for knowledge sake, but for
    now, I'll accept the working configuration.

    Now I can browse from the box and from workstations through the
    iptables nat.

    Thanks again for the help.

    Charles
     
    2boxers, Nov 19, 2003
    #6
  7. 2boxers_at_comcast_dot_net

    2boxers Guest

    Correction... The above is not what fixed this issue. It only seemed
    like that was it since using the new kernel and modules caused the
    comtrol rocket port driver from comtrol not to load since new modules
    and deps were created.

    Using the comtrol rocketport driver from comtrol was the cause. This
    driver compiled and worked seamingly flawlessly otherwise, but only by
    using the module included with the kernel, the problem went away.

    The still baffles me, but I have confirmed this to be the cause.

    Using the driver I downloaded from comtrol worked for everything else.
    Serial communications appeared to be fine with other services, but not
    with http with lynx or mozilla. Perhaps some sort of character
    mapping issue?

    By simply unloading the comtrol rocketport driver and loading the
    module rocket.o from the linux kernel char drivers, the problem is
    truly resolved.

    Has anybody else experienced this or anything similar?

    Im still baffled why this driver could be causing it, but I am now
    confident that I have nailed down the issue.

    Charles
     
    2boxers, Nov 19, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.