Redhat 9.0 PPTPD Problem

Discussion in 'Linux Networking' started by Michael Walzl, Nov 27, 2003.

  1. Hallo everybody,

    I have a problem with PopTop on my Redhat 9.0 machine.

    I installed the needed packages
    pptpd-1.1.3-3
    ppp_mppe-2.4.1-7
    kernel-mppe-2.4.20-8.i686.rpm

    Than I configured the configuration files
    /etc/pptpd.conf
    option /etc/ppp/options.pptpd
    localip 192.168.34.1 # ip-adress of the linux machine
    remoteip 192.168.34.234-238

    /etc/ppp/options.pptpd
    name sel
    lock
    auth
    proxyarp
    -chap
    -chapms
    +chapms-v2
    ipcp-accept-local
    ipcp-accept-remote
    lcp-echo-failure 3
    lcp-echo-interval 5
    deflate 0
    debug
    logfd 2
    logfile /var/log/pptp.log
    mppe-40
    mppe-128
    mppe-stateless
    mtu 1490
    mru 1490
    ms-dns 192.168.34.16

    /etc/ppp/chap-secrets
    # Secrets for authentication using CHAP
    # client server secret IP addresses
    sel\\test test secret *

    than I opened the ports on the iptables firewall:
    Port 1723 and the protocol 47.

    But I get always the following error when I try to connect me from
    my Windows XP machine.

    Nov 27 17:01:52 WebCache pptpd[5954]: CTRL: Client 80.180.26.236
    control connection started
    Nov 27 17:01:52 WebCache pptpd[5954]: CTRL: Starting call (launching
    pppd, opening GRE)
    Nov 27 17:01:52 WebCache pptpd[5954]: GRE:
    read(fd=5,buffer=804d5a0,len=8196) from PTY failed: status = -1 error
    = Input/output error
    Nov 27 17:01:52 WebCache pptpd[5954]: CTRL: PTY read or GRE write
    failed (pty,gre)=(5,6)
    Nov 27 17:01:52 WebCache pptpd[5954]: CTRL: Client 80.180.26.236
    control connection finished

    Please can anyone help me.
    I tried several configuration but with no success.

    thanx in advance
    Michael Walzl
     
    Michael Walzl, Nov 27, 2003
    #1
    1. Advertisements

  2. Hello,

    I noticed that the problem occurs when the
    auth and the +chapms-v2 in the /etc/option.pptpd
    file are set. When I comment this line out,
    than I can connect to the server get an IP-Adress
    but I am not authenticated in the network.
    What could be a possible solution to solve this
    problem? Is there a missing package?

    thanx
    Michael Walzl
     
    Michael Walzl, Nov 28, 2003
    #2
    1. Advertisements

  3. Michael Walzl

    Brian Andrus Guest

    I installed pptpd-1.1.3-4, kernel-mppe-2.4.20-24.9 (had to make the
    rpm from the scripts) and then elected to use ppp-2.4.2-0.1b3 (since
    ppp >2.4.2 has the mppe stuff built in).

    My options.pptpd:
    lock
    debug
    name pptpd
    proxyarp
    bsdcomp 0
    refuse-pap
    refuse-chap
    refuse-mschap
    require-mschap-v2
    require-mppe
    ms-dns 10.1.1.20
    ---------------------

    It does work, at least on one of my test machines. I can vpn in and it
    is fine. For me, some machines fail. Go figure.

    Brian Andrus
     
    Brian Andrus, Dec 18, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.