Reconfiguring the Technicolor TG582n FTTC router from Plusnet

Discussion in 'Broadband' started by David, Jul 19, 2014.

  1. ok, It's a nice evening today :)

    Log in as admin, main screen, under home network click on wireless.
    Top Right, click configure. Down near the bottom, the drop-down marked
    "security mode" change to "New devices are allowed (via registration)"

    Andy
     
    Vir Campestris, Jul 21, 2014
    #21
    1. Advertisements

  2. David

    David Guest

    "Vir Campestris" wrote in message

    ok, It's a nice evening today :)

    Log in as admin, main screen, under home network click on wireless.
    Top Right, click configure. Down near the bottom, the drop-down marked
    "security mode" change to "New devices are allowed (via registration)"

    Andy

    ===========================================================
    Hi Andy

    I can see the router recording the MAC codes/addresses (and IP addresses)
    for the wifi devices in "Home > Home Network > Devices" but as soon as I
    change the Security setting in "Home > Home Network > Interfaces > WLAN" to
    "New devices are allowed (via registration)" the wifi devices disconnect.
    (FYI they also disconnect with "New stations are not allowed").

    Due to the age of a number of my devices, I have to use WEP and it think it
    is this that is causing the problems. Also a number of the devices have two
    MAC addresses, one for data and the other for control/configuration. The
    router only automatically records the data MAC address - what I really need
    is a way of manually entering the MAC addresses into a table.

    My current thinking is to resort back to using a separate Wireless Access
    Point.

    Thanks for your help anyway.

    David
     
    David, Jul 22, 2014
    #22
    1. Advertisements

  3. David

    Adrian C Guest


    http://npr.me.uk/telnet.html

    search that for "Wireless MAC access control"
     
    Adrian C, Jul 22, 2014
    #23
  4. David

    David Guest

    "Adrian C" wrote in message

    http://npr.me.uk/telnet.html

    search that for "Wireless MAC access control"

    --
    Adrian C


    ===============================================================

    Many thanks.

    I've just tried telnetting the router - I can log on and view the current
    settings etc.

    Later when I have some time I'll try loading in some MAC codes and see what
    happens.

    I'll report back with my findings.

    David
     
    David, Jul 22, 2014
    #24
  5. David

    Adrian C Guest

    Before you play, go here

    Home > Technicolor Gateway > Configuration > Backup & Restore

    and backup the current configuration.

    Once inside telnet, try the 'menu' command to browse about and make the
    changes.
     
    Adrian C, Jul 22, 2014
    #25
  6. David

    David Guest

    "Adrian C" wrote in message
    Before you play, go here

    Home > Technicolor Gateway > Configuration > Backup & Restore

    and backup the current configuration.

    Once inside telnet, try the 'menu' command to browse about and make the
    changes.

    --
    Adrian C

    =============================================================

    Hi Adrian

    I think I may have it working.

    I didn't use the menu system - but at the prompt just entered the command
    line

    "wireless macacl add ssid_id=0 radio_id=0 hwaddr=00:xx:xx:xx:xx:xx
    permission=allow"

    followed by "saveall"

    and using the normal web style interface in

    Home > Home Network > Interfaces > WLAN:

    I set the security to "New stations not allowed"

    I need to give it a soak but hopefully the problem is solved.

    Now why could they include that as part of the web interface - it reminds me
    too much of DOS!

    Thanks once again

    David
     
    David, Jul 22, 2014
    #26
  7. David

    David Guest

    "David" wrote in message
    "Adrian C" wrote in message
    Before you play, go here

    Home > Technicolor Gateway > Configuration > Backup & Restore

    and backup the current configuration.

    Once inside telnet, try the 'menu' command to browse about and make the
    changes.

    --
    Adrian C

    =============================================================

    Hi Adrian

    I think I may have it working.

    I didn't use the menu system - but at the prompt just entered the command
    line

    "wireless macacl add ssid_id=0 radio_id=0 hwaddr=00:xx:xx:xx:xx:xx
    permission=allow"

    followed by "saveall"

    and using the normal web style interface in

    Home > Home Network > Interfaces > WLAN:

    I set the security to "New stations not allowed"

    I need to give it a soak but hopefully the problem is solved.

    Now why could they include that as part of the web interface - it reminds me
    too much of DOS!

    Thanks once again

    David

    =================================================================

    Success!

    I've had all the wifi devices running over night and everything is fine.

    Thanks again for the telnet link

    David
     
    David, Jul 23, 2014
    #27
  8. My original Speedtouch ST510 used 10.0.0.138 and used a 10.0.0.x dhcp
    pool so I guess it is hangover from that.

    I now have a TG582n and have configured it to still do this (ADSL)

    I mostly use static addresses.
     
    Michael Chare, Jul 24, 2014
    #28
  9. The Technicolor is *very* programmable, but you have to do it via the telnet
    command line if it's not available as a GUI option.

    http://npr.me.uk/telnet.html

    Theo
     
    Theo Markettos, Jul 24, 2014
    #29
  10. "Theo Markettos" wrote
    Thanks for that but one question

    If you sign on to the GUI it would seem neat to be able to sign out

    Can this be done ?
     
    Michael R N Dolbear, Jul 26, 2014
    #30
  11. Probably a firmware thing. You can definitely do it with other
    Technicolor models that share a very similar interface -
    http://users.plus.net/QL:E694AECF
     
    Plusnet Support Team, Jul 29, 2014
    #31
  12. "Plusnet Support Team" wrote

    Technicolor models that share a very similar interface -
    http://users.plus.net/QL:E694AECF

    Thanks

    I see (as supplied by Plusnet)

    Technicolor Gateway
    Information
    Product Name: TG582n
    Software Release: 8.4.4.J
     
    Michael R N Dolbear, Jul 29, 2014
    #32
  13. If your model has no USB port then I think there might be a firmware
    update available:

    http://products.plus-payh.co.uk/firmware/

    No idea whether or not it will instate a logout hyperlink though.
     
    Plusnet Support Team, Jul 30, 2014
    #33
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.