read/write lag on shared folders when using D-Link equipment

Discussion in 'Windows Networking' started by Lila, Nov 20, 2003.

  1. Lila

    Lila Guest

    I have a two computer home network. It is in a 3 story house. I put
    the D-Link DI-614+ router on the middle floor next to the cable

    One of the computers (which is using a D-Link wireless PCI card
    DWL-520+) is on the top floor. It has a bigger hard drive so it is
    hosting the files I want to share. It is a new Dell Optiplex.

    The second computer is older. It's a no-name brand adopted from
    someone else. It also has a D-Link wireless PCI card DWL-520+. I got
    them to see each other and the internet. Surfing the internet is nice
    and fast on both machines. They can both access their own email
    accounts as well with no problem.

    The problem is when I try to access the files that are shared. It is
    WAY slow. I mean, when I double click on the shared folder it takes
    at least a minute (sometimes more) to show up.

    I have tried using a UNC (//computer/share) as well as mapping a drive
    letter to that share, both with the same slow result.

    They are using TCP/IP with internal IP addresses.

    During the time I am waiting for the shared folder window to show up I
    have opened the D-Link window to see the transmision rate. (oh yeah,
    the wireless connection is strong) Funny thing is, it is not showing
    any information sent or recieved. I will get an occasional blip, but
    basically nothing until the window actually shows up!

    I'm not sure where to even start looking! What should I look for?

    Thanks in advance!
    Lila, Nov 20, 2003
    1. Advertisements

  2. Lila

    daytripper Guest

    You don't mention what OS you're using. On the assumption it's some flavor of

    - make sure both systems TCPIP settings point to the actual gateway address.
    - make sure they're both in the same Workgroup
    - make sure their TCPIP settings have enabled Use Netbios On TCPIP.
    - create an LMHOSTS file with both node names/ip addresses and make sure the
    system TCPIP settings enable "Use LMHOSTS file".
    - make sure you have matching accounts - both username and password - on both
    - once you've done all the above, power one system down, restart the other,
    then once you've logged in, power up the other system.

    That ought to do it...

    daytripper, Nov 20, 2003
    1. Advertisements

  3. Lila

    Lila Guest

    Oops, I forgot to say I was using WinXP Professional.

    1 The gateway is blank. Do I use the TCP/IP address of he router?
    2 workgroup is the same
    3 the Netbios address says "Default: Use NetBIOS setting from the DHCP
    server. If static IP address is used or the DHCP server does not
    provide NetBIOS setting, enable NetBIOS over TCP/IP"
    4 LMHOSTS is enabled, but how do you edit the file? I searched for
    LMHOST and found a file in ":\windows\system32\drivers\etc"
    5 usernames were different. I'll change to be the same and see if it
    helps. It's not as spelled out as it is in Windows 2000. I mean the
    user interface is completely different so I'm assuming everyone on the
    list is a local user (since there is no domain).



    Would it be better to "Enable NetBIOS over TCP/IP"
    Lila, Nov 20, 2003
  4. Lila

    daytripper Guest

    Yes - the LAN address.
    Good and good.
    Use any text editor that'll let you open it (I use UltraEdit for pretty much
    everything but Wordpad should work). Just make sure when you're done that the
    file is just LMHOSTS without any extension.
    Everyone can be a local user, you just need a matching, valid account on the
    other node to gain access to the first...

    daytripper, Nov 20, 2003
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.