r8169 + network slow and unstable.

Discussion in 'Linux Networking' started by Fokke Sukke, Dec 2, 2003.

  1. Fokke Sukke

    Fokke Sukke Guest

    I have two sweex gigabit network cards. They are based on the rtl8169s
    realtek network ic.
    One of the cards is in my athlon (via chipset) pc (windows xp) and the other
    is in my pentium pro 200 (asus)
    pc (linux 2.6.0-test11). I am testing the stuff with a 3com switching hub
    and a sweex switch.

    The problem is that the network speed is very slow, about 1,3MB/s. Further
    more the connection is
    very unstable. Most of the times it suddenly stalls and stops working
    completely. Only some ping
    icmp packets from my linux (ppro 200) pc to the windows pc can revive the
    connection.

    Some other strange thing is that ftp transfers to the ppro pc goes fast, but
    ftp transfers from the ppro pc goes slow and stalls; this is certainly the
    case when i transfer large files. My switch and hub are both indicating good
    network conditions -> no collisions and both 100MB full duplex.

    I tried linux on both pc -> no luck.
    I tried replacing my hub with a switch -> no luck
    I tried kernel 2.4.22 and 2.6.0-test10 and 2.6.0-test11 -> no luck

    Maybe someone can help me out here.

    Thanks!
     
    Fokke Sukke, Dec 2, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.