Problems with Netgear WGR614 & Dlink dsl-300T

Discussion in 'Broadband' started by Pascal Herczog, Dec 9, 2004.

  1. I am stumped on this one, so I really hope someone can help me!

    My PC (XP) can connect to the internet fine if connected directly to the
    d-link modem. So, the modem is configured ok, and my PC gets its IP address
    from the ISP passed through (e.g. static 83.99.11.11), and has its gateway
    pointing to the modem at 192.168.1.1 (which is an address set in the modem),
    along with the ISP DNS address at 212....

    BUT, when I connect my PC to my Netgear WGR614, and it to the modem, I can't
    access the internet. The configurations appear to have been set up ok, but I
    just can't see past the router.

    So, my PC gets its IP address from the router, as 192.168.0.2, whilst the
    router is visible at 192.168.0.1.

    If I log into my router using IE, then I can view its connection status.
    This shows that the router has been given the static address (83.99.11.11)
    by the modem, and also shows it knows what the DNS server address is. I can
    therefore access the router login page via both the 192.168.0.1 and the
    83.99.11.11 address.

    However, I cannot ping the DNS server or any other web IP address, and I
    also cannot see 192.168.1.1.

    I've tried connecting my portable to the router at the same time, and it
    also cannot see the internet. It was not running any firewall at the time
    (win2k). My PC uses ZoneAlarm, but the problem remains if I disable it.

    My PC can see other devices attached to the router, which are at 192.168.0.3
    etc. The Netgear router is the original version (v1), though I have upgraded
    the firmware to version 1126.

    Any help would be very much appreciated!!!

    Pascal.
     
    Pascal Herczog, Dec 9, 2004
    #1
    1. Advertisements

  2. Pascal Herczog

    cw Guest

    NAT turned off or firewall issues (if the Netgear has a built in
    firewall..)?
     
    cw, Dec 9, 2004
    #2
    1. Advertisements

  3. Hmm - don't think that I could find a NAT entry on the routers web config
    pages.

    I think the Netgear has some sort of firewall, is it called SPI (stateful
    packet inspection)?

    Not sure if this is meant to interfere with my own generated traffic. But I
    cannot 'see' what goes on between the router and the modem, as I can't see
    the modem nor its config pages.

    Forgot to mention, I have the modem connected to the WAN port of the router
    and the routers WAN led is on suggesting all is well. It even flickers
    sometimes when I try ping or other commands

    Hope you've got some more suggestions!
    Thanks,
    Pascal
     
    Pascal Herczog, Dec 9, 2004
    #3
  4. Hi Colin, the 300T auto locates the DHCP of the unit it first attached to -
    in your case the PC - disconnect it form your PC - reset the 300T - set your
    router to get the DHCP automatically (don't set it for PPPoA re E etc.)
    connect the router WAN port to the 300T and your PC to a LAN port power up
    the modem - you should then be able to access the modem (300T) thro' your
    router to setup. see link below

    http://www.adslguide.org.uk/hardware/reviews/2004/q4/dlink-dsl300t.asp

    Bill M.
     
    Bill Middleton, Dec 10, 2004
    #4
  5. Additional info:
    Using the D-Link DSL-300T with a router

    Configuring the DSL-300T to use with an Ethernet router such as the Linksys
    WRT-54G is very simple. Simply connect the Ethernet port of the modem to the
    Internet port of the router, and ensure that the router is configured to get
    its Internet IP address via DHCP.

    Initially when you first connect the modem to the router, it will hand the
    router an IP address in the range 192.168.1.x. This means you need to ensure
    your router does not become confused by using the 192.168.1.x range for its
    LAN interface. If it does you should change the LAN IP range of the router
    for example to 192.168.0.x.

    The actual configuration of the DSL-300T, can take place from a computer
    connected to the router, simply by opening the web page http://192.168.1.1/
    and setting the modem up as shown above. Then once the modem is configured
    and has authenticated with the ISP the Internet IP address on the router
    should become the one your ISP has assigned you. Some routers may need you
    to manually trigger the renewal of the IP address on the Internet interface,
    either via their web configuration or switching the unit off and on again.



    Bill M

     
    Bill Middleton, Dec 10, 2004
    #5
  6. This is your problem - your router and PC are sharing the same IP
    address, the router cannot handle this :) How did your PC get the IP
    address which the ISP has assigned to you?

    Manually set the IP address of your PC to 192.168.1.10 (has to be
    192.168.1.xx, except 1), subnet mask of 255.255.255.0, and default
    gateway of 192.168.1.1. Set DNS to whatever is given to you by your
    ISP. This should now work, although I would strongly recommend this:
    turn on the DHCP server in the router and set your PC to automatically
    obtain all the network configuration.

    Hope this helps!
     
    Richard Sobey, Dec 10, 2004
    #6
  7. _IF_ my PC is connected directly to the modem, the modem does pass the
    assigned ISP IP address through to my PC. (i.e. a ipconfig /all shows that
    the IP address is 83.99.x)

    But, when I connect my modem to the router WAN port, and my PC to the router
    LAN port, then my PC gets its IP address from the router DHCP, so it is
    192.168.0.2).

    Whenever I try to access an internet site, I note that both the routers WAN
    light (green, showing connected) and the modem's ethernet port flash a few
    times, simultaneously. But I have no idea what is happening on that link,
    because all my accesses time out.

    I've tried to manually assign IP addresses, to no avail. It seems the DHCP
    assignments are working correctly.

    I would really appreciate any further thoughts on this!

    Thanks
    Pascal
     
    Pascal Herczog, Dec 11, 2004
    #7
  8. A further clue in this puzzle, is that when I have the modem connected to my
    router, and my PC to the router, with the modem connected to the internet I
    cannot 'see' the modem, as described. BUT, when I unplug the telephone cable
    from the modem, such that the modem reverts back to passing on its own DHCP
    address to the router, ie. the router sees the WAN interface on 192.168.1.2,
    THEN the modem is visible on 192.168.1.1, from my PC on the router LAN port
    at 192.168.0.2

    So, I know that the router can talk to the modem, it just doesn't seem to
    know what to do when its being given the ISP WAN IP address, instead of the
    modems DHCP address.

    Does this help?

    Thanks,
    Pascal
     
    Pascal Herczog, Dec 11, 2004
    #8
  9. This is, I think, exactly how I did it so far. The router can see its been
    given the internet IP address on its WAN interface, and it is set not to
    require a login. Perhaps someone could explain if this is important, as I
    don;t fully understand this aspect in the context of the modem already
    having logged in with the ISP (i.e it wouldnt have got the ISP IP address,
    otherwise).

    But, I cannot access the modem, nor the internet.

    Thanks,
    Pascal.
     
    Pascal Herczog, Dec 11, 2004
    #9
  10. Pascal, did you setup your 300T thro' you PC initially? is your router
    internet connection "WAN" set to "Dynamic IP Address" ? - as stated the 300T
    automatically sets up to the first unit its connected too - and if this was
    your PC it wont then work with your router - so you then need to reset the
    300T and reconnect thro' the router - whose IP Address is set not to
    conflict i.e 192.168.0.X - 255.255.255.0 if this does not work - then you
    may want to try setting the 300T to "Bridging Mode" and setup your Internet
    thro' your router.

    Bill M.
     
    Bill Middleton, Dec 12, 2004
    #10
  11. I've now finally come across a solution that works:

    Setting the router to have a fixed WAN address of 192.168.1.2, netmask of
    255.255.255.0 and gateway of 192.168.1.1, as well as filling in the DNS
    address, has made it work!

    SO, being of the inquisitive type, I now wonder whether this will behave any
    differently from the ideal scenario, which is presumably when the router has
    its WAN address set to the public address, not hardcoded to the modem's
    address. For example, does this affect the routers SPI, or does it
    complicate port forwarding etc? (I am presently a newbie on broadband, so am
    not using anything complicated yet!)

    Pascal.
     
    Pascal Herczog, Dec 12, 2004
    #11
  12. Yes, I tried to keep it simple first, just connecting the PC to the modem,
    which worked.

    I have reset the modem, but I've tried so many things that I now can't
    remember whether I then connected it directly to the router. I think I did,
    but the fact that the router could see the WAN IP address being passed
    through the modem to the router, made me think that at least somehow the
    modem was talking to the router.

    I'm not sure how to set the modem to bridging mode, there doesn't seem to be
    such a menu. I have seen descriptions of telnetting in when directly
    connected, but that sounds a bit on the edge to me.

    I have now got it working, see my previous post, though I'd be very
    interested in your follow up response from that. For example, without the
    router getting a dynamic IP config, can I be sure that the DNS server will
    always stay the same?

    Thanks for your help!

    Pascal.
     
    Pascal Herczog, Dec 12, 2004
    #12
  13. Hi Pascal, The "Bridging Mode" allows you to setup the modem as a plain old
    ADSL modem and all the your ISP settings are done thro' your router - to do
    this - login to your modem - select "Setup" - the select "WAN Setup
    Connection" then next to "Type:" select "Bridge" from the Pull-Down menu -
    save and reboot - I have read in many forums that with certain non-d-link
    routers this method seems to work best.
    Bill M.
     
    Bill Middleton, Dec 12, 2004
    #13
  14. Pascal: this was cut from a reply from D-Link USA Support I found in some
    forum,

    D-Link USA said.......
    The DSL-300T is not a D-Link US product. You are using a device (DSL-300T)
    that is a modem and a Router with another device (DI-714P+) that is also a
    Router. You cannot use NAT on both these devices at the same time. You
    either need to make the DSL-300T a bridge or use the DI-714P+ as a switch
    only. You can use the DI-714P+ as a switch by disabling DHCP on the unit and
    not using the WAN port, just connect the DSL-300T to one of the LAN ports on
    the 714P+.

    I think the latest f/ware switches NAT off as default-but hey 'in for a
    penny, in for a pound' I will try this!

    OK, we got it going so here goes....
    I connected PC to Modem only & set to it 'Bridge' mode & switched DHCP OFF,
    I then hooked up the Router to the modem & went to the WAN tab on the router
    setup.
    I chose 'PPPoE' & 'Static PPPoE' then set Username & password to my Wanadoo
    account, & changed the Primary DNS to Wanadoo's 195.92.195.94, IP address
    192.168.1.100, then saved settings.
    (DHCP is enabled on Router start 192.168.0.100 & end 192.168.0.199).
    I went to the 'Status' tab & hit 'Connect' BUT it took 3mins or so to
    'sync', it then returned
    on the 'status' tab LAN IP 192.168.0.1/Subnet Mask 255.255.255.0/DHCP
    Enabled.
    On the WAN section PPPoE Connected/IP 81.XX.XX.XXX etc/Subnet Mask
    255.255.255.255/Gateway 81.XX.XX.XXX (same as IP)/DNS
    195.92.195.94(Wanadoo's)-hooray! btw, I havn't had the guts to update the
    Firmware now it's working!
    Did the firmware last nite & no issues. Left it in bridge, then powered off
    for 2 weeks whilst on vacation. Returned & switched on, all is well-'solid
    as a rock'!

    Bill M
     
    Bill Middleton, Dec 12, 2004
    #14
  15. Pascal, if I read the thread correctly you have set your modem to IP
    address 192.168.1.1 and the router to 192.168.1.2?
    Are you able to download large files (>2 Mbytes) without interruption?
     
    evangelical_bob, Dec 14, 2004
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.