Problems reconfiguring a Linksys/Cisco EA2700 with a different localIP address

Discussion in 'Home Networking' started by Henry Law, Jan 28, 2013.

  1. Henry Law

    Henry Law Guest

    I have a new EA2700 which I'm about to introduce into my local network.
    I have always changed the default 192.168.1.1/24 network to one of the
    other RFC1918 blocks so I set out to do that again.

    The configuration screen allows me to change the IP address of the
    router to (say) 10.1.1.1 but the DHCP address range is hard coded in its
    first three octets, that is to say 192.168.1.---

    Damn poor programming, I'd say. If I change the internal IP address to
    a different subnet the page should automatically offer a valid DHCP
    range. But of course domestic WiFi routers are designed for people who
    haven't a clue, so when someone turns up who does he can't expect it to
    work ...

    Can anyone suggest how to get round this? I can't leave the DHCP range
    as it is in a different subnet (it won't let me), so the only way to
    save the new local IP address is to disable DHCP. Tiresome, as I'll
    then have to give my client machine a fixed IP address in order to get
    in and (hopefully) find that the DHCP range that it will accept is in
    the new local network subnet. Untidy, but in the end do-able.
     
    Henry Law, Jan 28, 2013
    #1
    1. Advertisements

  2. Henry Law

    Dave Saville Guest

    That's because you are not doing it the way Cisco want you to. You
    obviously aren't supposed to do that. Have they forced upgraded it for
    you yet? Have a Google.
     
    Dave Saville, Jan 28, 2013
    #2
    1. Advertisements

  3. Henry Law

    Chris Davies Guest

    If you actually change the IP address, doesn't the DHCP address range
    follow?

    Chris
     
    Chris Davies, Jan 29, 2013
    #3
  4. Henry Law

    Henry Law Guest

    Not until you reboot. And the config utility won't allow you to have
    DHCP addresses which aren't in the router's own network (obviously) and
    complains if you just leave it, so you have to disable DHCP, reboot,
    reconfigure your client for static IP, connect up, change the DHCP range
    and re-enable, power cycle the router to enable the changes, and then
    put your client back to automatic. Damn pain.
     
    Henry Law, Jan 29, 2013
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.