problems for automounting in squeeze

Discussion in 'Linux Networking' started by Michael Barth, Aug 20, 2011.

  1. In my network I've two maschines with lenny installed. The automounter
    is working in both directions. Now I added a new maschine (amd64) and I
    installed squeeze. On that maschine automounting does not work. A
    manual mount is no problem. Can anybody help?

    More details:
    server:/etc/exports
    /data 192.168.1.0/24(rw,sync,no_root_squash,no_subtree_check)


    client lenny:/etc/auto.master
    /mnt /etc/auto.lenny --timeout=60

    client lenny:/etc/auto.lenny
    * -fstype=nfs,hard,intr,nodev server:/&

    automount -V
    Linux automount version 4.1.4_beta2


    client squeeze:/etc/auto.master
    /mnt /etc/auto.nfs --timeout=60

    client squeeze:/etc/auto.nfs
    * -fstype=nfs,hard,intr,nodev server:/&
    * -fstype=nfs,hard,intr,nodev lenny:/&


    automount -V
    Linux automount version 5.0.4

    Directories:
    config dir: /etc/default
    maps dir: /etc
    modules dir: /usr/lib/autofs

    Compile options:
    ENABLE_FORCED_SHUTDOWN ENABLE_IGNORE_BUSY_MOUNTS WITH_HESIOD
    WITH_LDAP WITH_SASL LIBXML2_WORKAROUND






    The following command on lenny is succesful
    ls -a /mnt/data
    . ..

    But the same command on squeeze leads to an error:
    ls -a /mnt/data
    ls: cannot access /mnt/data: No such file or directory

    A manual mount on squeeze is succesful:
    mount -tnfs server:/data /mnt
    ls -a /mnt
    . ..
    umount /mnt

    Any suggestions where to solve the problem.

    Thanks
    Michael
     
    Michael Barth, Aug 20, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.