Problem with Realtek 8139(It sends ARP but the reply is lost)

Discussion in 'Linux Networking' started by akshatc, Jun 5, 2006.

  1. akshatc

    akshatc Guest

    I have a desktop machine with a Realtek 8139 ethernet card. I also have
    a laptop and a router.

    Now when I connect my desktop to my router directly everything works
    fine. But I want to share my internet connection and hence installed a
    switch. This is where the problem started. My laptop is working fine on
    the network and can ping my router. But the desktop just is not being
    seen.

    So I setup ethereal trace on both my laptop as well as the desktop. Now
    when I ping the laptop from the desktop I can see the ARP messages on
    the laptop to which it sends a normal reply. But the trace on the
    desktop only shows outgoing ARPs and no replies.

    To ensure that this was not only a Linux issue, I tried the same
    experiment with windows XP on the desktop with the same result. So it
    is definitely not a driver problem.

    To ensure that there is no problem with the switch I connected the two
    systems through a cross cable. Again I pinged from the desktop to the
    laptop. The result was the same. The ARP replies were being sent
    correctly but was not seen on the desktop.

    What could be the problem?
     
    akshatc, Jun 5, 2006
    #1
    1. Advertisements

  2. It looks as if your laptop doesn't know the route to your desktop (i.e.
    local). That is normally set up by your DHCP server which is normally on
    the router. Ethereal should show the MAC destination in the laptop
    responses.

    Robert
     
    Robert Harris, Jun 5, 2006
    #2
    1. Advertisements

  3. akshatc

    akshatc Guest

    i dont see how that is the case. Since in ethereal i can see that the
    message is going out correctly with the right MAC address.

    Also the desktop is unable to see the router either.
     
    akshatc, Jun 5, 2006
    #3
  4. What is your network topology (IP addresses, physical connections) and
    what do you get when you type:

    route -n

    on your desktop?

    Robert
     
    Robert Harris, Jun 5, 2006
    #4
  5. akshatc

    akshatc Guest

    Hi,

    First I would like to thank you for taking time out to help. I have
    been wrecking my brain over it for the past 4 days without any luck.

    Here is my n/w topology

    192.168.1.101 192.168.1.1
    192.168.1.100
    255.255.255.0
    255.255.255.0
    Laptop Router
    Desktop
    | |
    |
    | |
    |
    ---------------------------------Switch----------------------------------------------

    the route set at my desktop is -
    Destination Gateway Genmask Flags Metric Ref Use
    Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0
    eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
    eth0
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0
    eth0


    my laptop also has the very same route setting but its network works
    just fine.

    Thanks,
    Akshat
     
    akshatc, Jun 5, 2006
    #5
  6. You need to take the line starting 169.254.0.0 out of your routing table
    (which says that all IP addresses of the form 169.254.x.x are local,
    which they are not).

    Robert
     
    Robert Harris, Jun 5, 2006
    #6
  7. akshatc

    Spoon Guest

    Here is some background on 169.254/16

    Request for Comments: 3927
    Dynamic Configuration of IPv4 Link-Local Addresses
    http://www.rfc-editor.org/rfc/rfc3927.txt

    To participate in wide-area IP networking, a host needs to be
    configured with IP addresses for its interfaces, either manually by
    the user or automatically from a source on the network such as a
    Dynamic Host Configuration Protocol (DHCP) server. Unfortunately,
    such address configuration information may not always be available.
    It is therefore beneficial for a host to be able to depend on a
    useful subset of IP networking functions even when no address
    configuration is available. This document describes how a host may
    automatically configure an interface with an IPv4 address within the
    169.254/16 prefix that is valid for communication with other devices
    connected to the same physical (or logical) link.
     
    Spoon, Jun 6, 2006
    #7
  8. akshatc

    akshatc Guest

    Hi,

    Thanks, for the replies. I have solved my issue. I just changed the PCI
    slot of my ethernet card and all is fine.

    Cheers,
     
    akshatc, Jun 6, 2006
    #8
  9. akshatc

    David M Guest

    Set the Realtek card to half-duplex, 10Mbps. I had a problem once
    with a similar cards' auto-negotiate not working correctly.
    Hard-setting the configuration fixed the problem.
     
    David M, Jun 7, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.