Problem with NFS export of FAT32 partition

Discussion in 'Linux Networking' started by Allen, Mar 22, 2009.

  1. Allen

    Allen Guest

    I'm trying to set up one-way file sharing of a FAT32 partition between
    my two PC's using NFS. I can mount the FAT32 partition on my NFS client
    PC but I can't view the mounted files. I've tried the troubleshooting
    steps listed in the NFS HOWTO.

    According to the NFS FAQ, there is only limited support for export of
    FAT32. However, the level of support described in the FAQ is adequate
    for my needs. I only want to make a copy of my FAT32 partition.

    Here is my setup:

    NFS Server:

    1. Running Fedora 9
    2. Static IP: 192.168.1.150
    3. /etc/exports:
    /mnt 192.168.1.0/255.255.255.0(rw)
    /mnt/windows 192.168.1.0/255.255.255.0(rw)
    /mnt/large_downloads 192.168.1.0/255.255.255.0(rw)
    4. /mnt has two files systems mounted on it: /windows (FAT32) and
    /large_downloads (ext3)
    5. /etc/fstab entries for the two subdirectories of /mnt:
    UUID=768B-E069 /mnt/windows vfat uid=1000,gid=1000,umask=0000 0 0
    UUID=4f26a47f-28c3-4e5e-b6d0-6817891af123 /mnt/large_downloads ext3
    defaults 1 2
    (I changed the uid, gid from 500 to 1000 to match my client)
    6. My user account has UID=500,GID=500


    NFS Client:

    1. Running Ubuntu 8.04
    2. Dynamic IP (set by DHCP)
    3. I manually issue: sudo mount -t nfs 192.168.1.150:/mnt/windows /mnt/nfs
    4. My user account has UID=1000,GID=1000


    I can mount and access /mnt/large_downloads (which is ext3) OK on the
    NFS client. I can mount /mnt/windows (which is FAT32) on the NFS client.
    Both "df" and "/proc/mounts" show that /mnt/windows is mounted. I try to
    access /mnt/windows on the client via GNOME -> Places -> Computer ->
    Filesystem -> /Mnt -> NFS. I get a busy mouse pointer, and nothing is
    displayed. The file manager on my NFS server hangs. When I try to reboot
    my NFS server, the shutdown hangs.

    My NFS server is capable of running NFS Version 2,3, and 4. According to
    /proc/mounts, apparently my client is running NFS Version 3.

    I've also tried exporting and mounting the FAT32 partition as readonly
    instead of rw. (I changed the specification in /etc/exports to ro and I
    specified -r in the mount command).

    I don't want to try using samba. I no longer run Windows. If I can't
    access my FAT32 partition via NFS, I will migrate the partition to ext3
    and access the ext3 partition via NFS. I'd rather not do the migration.
    The FAT32 partition contains tens of thousands of files (11 GB of data).

    Any suggestions on how I can get the NFS access of my FAT32 partition to
    function?
     
    Allen, Mar 22, 2009
    #1
    1. Advertisements

  2. You've answered your own question, reformatting the partition as EXT3 is
    the right solution. The only place you should use FAT32 is on FLASH cards
    that you share with devices like cameras and phones, it has no place on
    the hard drive of a Linux system. Even if you were still using Windows
    for something there is no reason to have a FAT partition, if you are
    sharing data between Linux and Windows you should be using a Windows VM,
    not native Windows, and sharing data via SAMBA.
     
    General Schvantzkoph, Mar 22, 2009
    #2
    1. Advertisements

  3. Allen

    David Brown Guest

    If you want to make a copy of a bunch of files, try rsync.

    If you want to share a directory, try samba. Just because you are
    sharing between two *nix machines, does not mean you have to use NFS -
    many people prefer samba even in a windowless setup (IMHO, it's easier
    to get control of permissions and ownership with samba than NFS).
     
    David Brown, Mar 22, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.