Problem Networking via TCP/IP

Discussion in 'Windows Networking' started by Ira Blumenthal, Oct 7, 2004.

  1. I am attempting to network 3 computers in my home, a Gateway desktop, a
    Toshiba laptop and a Dell WebPC; all run Win 98SE. I am using a US Robotics
    8054 802.11g Wireless Router. In addition to wireless capability the 8054
    has a 4-port Ethernet switch. The Gateway desktop and the Toshiba laptop are
    to be hard wired to the 8054's switch ports. The Dell WebPC will connect
    wirelessly via a US Robotics 5420 802.11g Wireless USB Adapter. The 5420
    must network via TCP/IP - it cannot use NetBEUI. In fact, if NetBEUI is
    loaded on the computer the 5420 is attached to it will fail to boot.

    Therefore, I need to get the other two computers hard wired to the 8054
    switch networked via TCP/IP. I have been unable to do this. The two
    computers can network if NetBEUI is installed but not over TCP/IP. They
    cannot Ping each other although they can Ping themselves and the 8054. It is
    also possible to access the Internet from each computer through a DSL modem
    attached to the 8054. This would seem to indicate that the hardware is
    working OK. Nevertheless, I have replaced the 8054 with a hub and the
    Gateway's PCI card and the Toshiba's plug-in PC card with alternate hardware
    to no avail. The computers cannot Ping each other over TCP/IP, but they can
    connect to the Internet and can network over NetBEUI with any of the
    hardware.

    I have searched the Web and have found a couple of articles about networking
    over TCP/IP. I have tried all their suggestions to no avail. Does anybody
    have any suggestions for me?

    Ira B.
     
    Ira Blumenthal, Oct 7, 2004
    #1
    1. Advertisements

  2. Ira Blumenthal

    Don Guest

    On all 3 PCs, open a MS-DOS prompt window and do an
    IPCONFIG command. You might see 3 Ethernet adapters (if
    all three PCs are attached to the network), two of them
    will have zeros in the values, but the one for the PC
    entering the command will have values. You'll see IP
    address (the IP# for the PC), subnet mask (the numbers for
    your LAN network), and default gateway (the IP for the
    router). All 3 PCs should have the same value in Subnet
    mask (usually 255.255.255.0) and the same value for
    default gateway (the IP of the router). They should each
    have a different IP. Right click Network Neighborhood and
    choose properties. Make sure Client for Microsoft network
    is installed and is the default network logon. Go to the
    Network identification tab and make sure each PC has a
    different 8-character (or less) name with no spaces, and
    that they all have the same workgroup. Make sure file and
    print sharing is enabled and make it share level (not user
    level). Go into "TCP/IP ---> ethernet adapter" (whatever
    the ethernet adapter is) and look at the tabs for each of
    the values. In DNS, enter the IP of the router, enter the
    PC network ID into HOST and add the router's IP to the
    list of DNS entries. If the value criteria mentioned
    above are wrong (like subnet mask are not all 3 the same,
    or IPs are not all different, or default gateway is not
    pointing to your router), change from automatically
    getting settings to manually setting them. Add the router
    to the list of default gateways (it should be the only one
    in there then). DHCP should be disabled then because
    you've done it manually. How do you configure your
    router? Is it via your browser? However it's done, do it
    and make sure all the values are like you've set them up
    on the PCs. Finally, reboot the router and the PCs.
    Anything I missed or didn't explain correctly? Let us
    know how it all works out, OK?
     
    Don, Oct 8, 2004
    #2
    1. Advertisements

  3. Carey Holzman, Oct 8, 2004
    #3
  4. Thanks to Don for his response and suggestions. I now know what my problem
    was and it had nothing to do with configuring TCP/IP. The problem was the
    firewall software I was using, the no-charge version of Zone Labs Zone
    Alarm. The no-charge version of Zone Alarm blocks all TCP/IP access to the
    computer it is installed on preventing all network access using TCP/IP. Thus
    when I removed the TCP/IP protocol from my LAN adapters and bound them to
    NetBEUI, I was able to share files across the network. However, when TCP/IP
    was bound to the adapters, even though NetBEUI was still bound to them, the
    firewall prevented access. Since TCP/IP is needed for DSL Internet access
    this was no good at all.

    It is really annoying that Zone Labs does not tell you that the no-charge
    version of Zone Alarm is no good for a networked PC. You have to dig into
    the support info on their web site to find it. The charge version, Zone
    Alarm Pro, can be used for network access. However, they use the same
    interface for the no-charge version so it appears at first that, it too, can
    be used on a networked PC - very confusing.

    Now I am looking for some inexpensive or no-charge firewall software that
    will run on a networked PC. Does anyone have any recommendations?

    Ira
     
    Ira Blumenthal, Oct 8, 2004
    #4
  5. Ira Blumenthal

    BobC Guest

    Sygate personal firewall
    http://smb.sygate.com/products/spf_standard.htm
     
    BobC, Oct 8, 2004
    #5
  6. Ira Blumenthal

    TW Guest

    I have been using the free Zone Alarm for years on my LAN. Excellent
    product.
    Zone Alarm does block incoming TCP/IP packets, unless you configure it
    properly.
    Click the firewall tab on the left, then click on ADD in the lower right.
    Click on subnet then add your subnet info e.g. 192.168.0.0 subnet mask
    255.255.255.0
    This will open the firewall to the subnet used by most entry level routers,
    while still blocking anything from outside your routers
     
    TW, Oct 9, 2004
    #6
  7. I am certain TW is correct for the version of Zone Alarm he is using.
    However, the version that I have (just recently downloaded) does not have an
    ADD on the firewall tab. BobC's suggestion was a big help. I downloaded and
    installed Sygate Personal Firewall. Tools|Options|Network Neighborhood tab
    permits you to select check boxes to Allow to browse Network Neighborhood
    file and printer(s) and to allow others to share my files and printer(s).
    When these check boxes are selected full network access is available
     
    Ira Blumenthal, Oct 11, 2004
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.