PEAK Wireless Broadband Router (Model# 6147ABPK) alternative firmware update source

Discussion in 'Network Routers' started by Johnny B Good, May 11, 2009.

  1. Copied and paste of an item I posted (slightly off topic) to
    uk.comp.homebuilt (I wasn't subscribed to this ng then). This was the
    first ng I came across in the usenet ng listings that I thought this
    type of posting would be more appropriate to.

    I've just proved that this is just a rebadged ZyXEL P-330W model[1].

    This is a useful bit of info for those who happen to be wondering why
    PEAK haven't bothered to get off their backsides to offer any firmware
    upgrades beyond their one and only v4.2.3.0.12 offering (_very_) dated 9
    Nov 2007 (actually shown on their website <peakhardware.com> as being
    dated 16 Nov 2007) to address the problem of frequent loss of connection
    (anywhere from a day to a week in frequency) to the WAN (cable modem)
    port.

    When I first installed this router, such events appeared fairly rarely
    (anywhere from twice a week to once a month) so, for a cheap SoHo
    product, seemed an acceptable trade off. I could always soft reset it by
    running the setup wizard, leaving the entries untouched as I clicked the
    4 or 5 "Next" buttons to get to the restart button (I couldn't find a
    dedicated restart option anywhere within the router's web management
    pages).

    However, these last few months have seen the frequency at which I have
    to soft restart it increase to several times a week so I finally decided
    to look on PEAK's web site for a firmware update only to be disappointed
    to find only the original update I'd already applied over a year ago.

    Since I hadn't immediately spotted the model number so carefully hidden
    away in the bottom right corner of the back of the box it came in, I
    trawled the user manual for a clue and found a reference to "P-330W"
    which a google search of took me to ZyXEL's website and some useful JPGs
    of the actual router which showed the back panel connector layout and
    the front panel LED indicator layout.

    The pictures of the router shown in the PEAK manual are a fiction, but
    the one on the box is the real McCoy. A comparison of the actual PEAK
    router's back panel layout and side panel LED layout matched the ZyXEL
    ones to a close enough precision to convince me that, despite a slightly
    different plastic skin, the boards in question were, as far as
    connector/led layout were concerned, identical. [2]

    I downloaded all THREE firmware updates (two of which, postdated the
    PEAK one), along with some pdfs (install and user guides and release
    notes) and ran the firmware update using the latest one from ZyXEL.
    After a nerve racking couple of minutes, I had a working router up and
    running.

    Of course, I had to type in a slightly different IP address to log into
    the ZyXEL version of the web interface since the default IP address was
    on a different subnet. Once I'd gotten admin access, I was able to
    change the router's address and scope to match the default used by the
    PEAK firmware version (I've a NAS box and a print server on static IPs -
    it just seemed less hassle to reprogram the router ;-).

    Since this firmware update is only a couple of hours old[3], it's too soon
    to say whether it has actually addressed the loss of WAN connection
    issue (or, indeed, whether it has improved the wireless connectivity
    issue complained of by my son, or introduced new issues altogether).
    However, be that as it may, I thought I'd impart the good news for those
    who might be experiencing the 'lost WAN connection issue' with their
    Peak Wireless Broadband Router (Model# 6147ABPK / #154242NRPK) and are
    as dismayed as I was at the lack of any recent firmware updates that
    would hopefully have addressed this.

    [1] The fact that I found a reference to a ZyXEL wireless router model
    number in a Taiwanese manufacturer's user manual rather suggests that
    it's this way round. I suspect they've simply taken the text straight
    from the ZyXEL manual and edited slightly to suit the minor differences
    in the webmin setup menus, forgetting (rather fortuitiously) to excise
    that "P-330W" reference. ;-)

    [2] I've since been advised that XyXEL act as an OEM to a lot of
    Taiwanese/Chinese rebadgers such as PEAK and if I'd cared to open the
    PEAK router to inspect its innards, I'd have seen the P-330W model
    number printed on the PCB.

    [3] At this time, the router has now clocked some 22 hours and 42
    minutes of uptime and still going strong. However, it's still far too
    soon to tell whether the dropped wan connection issue has finally been
    resolved. A quick check with my Acer notebook suggests the wireless
    connectivity is still working fine (but I normally disable the wireless
    and connect via the ethernet port so that's no indicator of the problem
    my son was seeing).

    HTH & HAND!
     
    Johnny B Good, May 11, 2009
    #1
    1. Advertisements

  2. Update:

    The message <>
    from Johnny B Good <> contains these words:

    ====major snip====
    Despite the lack of a response (which would seem to be typical in this
    NG), I thought any lurkers (and the usenet archive) would benefit from
    an update.

    The router (and, more importantly, the wan link) uptime is now showing
    "7day:9h:11m:40s". Not having to restart the router in over a week is
    quite an event compared to its pre ZyXEL firmware update behaviour.

    Since my son hasn't complained about the wireless connection for all of
    this week and the wan connection has remained up, it does look as though
    the ZyXEL firmware update was the right thing to do.

    HTH & HAND
     
    Johnny B Good, May 18, 2009
    #2
    1. Advertisements

  3. Johnny B Good

    Rambo Guest

    False assumption .... personnaly i have a linksys adsl2-modem-router
    WAG200G-FR ... without any problem .. no need to update my firmware.
    So tell me how can i answer/reply/react to your post ? :)
    I think that your problem is too specific that nobody have an experience
    to tell you - or to speak about ...
     
    Rambo, May 18, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.