OpenLDAP 1.2.13 and BerkeleyDB 2.7.7

Discussion in 'Linux Networking' started by tylernt, Sep 22, 2003.

  1. tylernt

    tylernt Guest

    I was trying to get OpenLDAP 1.2.13 installed for historical reasons.
    The docs say OpenLDAP wants BerkeleyDB 2.7.5, which cannot be
    downloaded from Sleepycat anymore. I compiled 2.7.7 but still had
    nothing but problems compiling OpenLDAP until I found this old post in
    the Google archive:

    http://groups.google.com/groups?hl=...ve&q=dn2id+openldap+error+compile&sa=N&tab=wg

    All I had to do was copy db_185.h from /usr/local/BerkeleyDB to
    /usr/include and suddenly OpenLDAP would compile successfully on
    Slackware Linux 8.0...

    So...

    THANK YOU Mr. Thompson!! :)

    (And and I hope this post helps someone else too!)
     
    tylernt, Sep 22, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.