Obtain IP vs Use the following IP

Discussion in 'Wireless Networks' started by Jeff, Jul 17, 2006.

  1. Jeff

    Jeff Guest

    In my Windows XP, WPA-PSK protected home wireless LAN (via router > cable
    LAN) one laptop was having problems regaining internet access after
    hibernating. I solved the problem by switching it's wireless TCP/IP setting
    from
    "Obtain an IP address automatically"
    to
    "Use the following IP address"
    and
    "Use the following DNS server address"

    Question:
    While the internet connection is now working fine, I suspect the laptop will
    not see hotel access points? If so, is there a way to have both setups
    simultaneously on this laptop? I mean have the laptop "Obtain IP address
    automatically" and if unable to "find any network"?

    Thanks.

    Jeff
     
    Jeff, Jul 17, 2006
    #1
    1. Advertisements

  2. Hi Jeff,

    Switch your laptop back to "obtain an IP address" and check the status of
    your IP address by typing ipconfig at a command prompt. To see more
    details, type ipconfig /all.

    Now allow the laptop to hibernate and demonstrate the problem. Check the IP
    address again using ipconfig. If you lost the IP address during
    hibernation, it will be 0.0.0.0. You can prevent this by using the
    "alternate configuration" tab. Enter the static IP address and DNS settings
    you used before in the alternate configuration tab. When the computer loses
    it's dynamic address (the one it obtains automatically), it will fail-over
    to this alternate address. You should still be able to access hotel access
    points, because it won't use the alternate configuration unless it can't
    find one automatically.

    I hope this helps!

    --
    Greg Lindsay [MSFT]


    Disclaimer: This posting is provided "AS IS" with no warranties, and confers
    no rights.
     
    Greg Lindsay [MSFT], Jul 19, 2006
    #2
    1. Advertisements

  3. Jeff

    Jeff Guest

    Thank you very much. Very clear and helpful. I will try it.

    Jeff
     
    Jeff, Jul 19, 2006
    #3
  4. I just thought of another option that might help you.

    Check the detailed properties of your wireless adapter by using the
    configure button. On the advanced tab, there should be a list of
    properties, one of which is power save mode. Disable this and it may
    prevent your network card from losing the IP address. Hibernation sometimes
    shuts down the power to network cards, and when that happens they often
    don't maintain a dynamic IP address.

    --
    Greg Lindsay [MSFT]


    Disclaimer: This posting is provided "AS IS" with no warranties, and confers
    no rights.
     
    Greg Lindsay [MSFT], Jul 19, 2006
    #4
  5. Jeff

    Jeff Guest

    Dear Greg

    You are very kind. Thanks for taking the time to help me.

    On the advanced tab for the wireless adapter there is indeed a "Power Save
    Mode" and it currently is set to "CAM" The other options to select from for
    the Power save mode are: "Fast_PSP" and "Max_PSP" . Not sure which to
    choose. (see below under BUT).

    Interesting, on this screen there are also options to set
    1. Network type - (set to infrastructure, which I hope means access point or
    router)
    2. Network address whcih I notice is blank!! ("Not present" selected).
    Should that be so?

    The other settings are of course Channel (1) and SSID (which is not the
    default one).

    BUT, looking at the other tabs there is a tab called "Power management" and
    it gives the option to "Allow the computer to turn off this device to save
    power" and it was selected! Sp I unselected it. That may well be it.

    One more question if I may. On the TCP/IP "alternate configuration tab", I
    entered the data as you suggested, including the DNS. It however also asked
    for WINS which I left blank. Where do I get the numbers for WINS?

    Ipconfig /all shows me that:

    for Windows IP configuration:
    - Primary DNS suffix is empty
    - Node type is unknown
    - IP routing Enabled is set to No
    - WINS proxy enabled is set to No

    for the wireless adapter
    - DHCP is enabled
    no mention of WINS

    Are these correct?

    Thanks.

     
    Jeff, Jul 19, 2006
    #5
  6. Jeff,

    You found the correct place to disable power management of the adapter.
    Some adapters have this on a power management tab, while others list it as a
    property. Good work - I hope this prevents your problem entirely.

    Your alternate configuration is correct. The output of ipconfig that you
    have below indicates that you aren't using WINS, so you don't need to
    configure anything there. Good luck!

    --
    Greg Lindsay [MSFT]


    Disclaimer: This posting is provided "AS IS" with no warranties, and confers
    no rights.

     
    Greg Lindsay [MSFT], Jul 20, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.