Not RTL8139 problem, but for any NIC

Discussion in 'Linux Networking' started by Delip Singh, Jun 27, 2003.

  1. Delip Singh

    Delip Singh Guest

    I explored the porblem lil more and here are findings -

    1. The problem is not with RTK 8139 driver. I tried puting DLink and
    Intel cards also, but nothing works. The 8139too.o supplied with
    RedHat 8.0 is just fine.

    2. I tried to capture the trace over wire and got some surprising
    stuff. When i do ifup eth0, I can see dhcp request going out
    (broadcast 255.255.255.255) and my dhcp server running on 192.168.1.1
    sends back the dhcp reply with client address as 192.168.1.174. But
    the response never reaches ifup, so it keep trying and finally gave up
    displaying "FAILED" message.

    3. If I disbale eth0 and try to ping 192.168.1.1 via eth1, I always
    get "Destination Unreachable". The routing table is fine and it has
    entry for default route. The surprising part is that this time I don't
    see any packets on wire.

    So am not able to understand where the problem is. Is it realted with
    IRQs? I even added the "options eth0 io=0x1800 irq=5" in
    /etc/modules.conf There are the values i got from "lspci -v"

    The IRQ 5 is shared between my two NICs and a sound card on board. I
    even tried t by disabling the sound card from BIOS, but no luck.

    Is there someone to help me out. I can provide as much info you want.
    I already wasted 3 days debugging it.

    DS
     
    Delip Singh, Jun 27, 2003
    #1
    1. Advertisements

  2. Delip Singh

    Whoever Guest

    IPTABLES problem? What is the result of:
    iptables --list -n
    What is the result of:
    route -n
    I strongly suggest that you take the second NIC out, since it is probably
    only confusing the issue.
     
    Whoever, Jun 28, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.