NFS problems with Linux mounting a file

Discussion in 'Linux Networking' started by Meik Langwald, Jul 8, 2004.

  1. Hi,
    Nope, nothing. :-(

    regards
    Meik
     
    Meik Langwald, Jul 11, 2004
    #21
    1. Advertisements

  2. :)

    That's what I think, too. But I didn't use Linux NFS for some time,
    because we had problems with Linux and NFS some time ago. Mixing NFS
    with different filesystems, 2GB limits and such stuff have been big
    problems.

    My current problem is a rather small one compared to those, but
    nevertheless it's a problem with Linux and NFS again.
    The Linux box is not a dedicated NFS server, we need it only for
    desaster recovery (hopefully never). So switching to Solaris x86 won't
    be a simple solution, err.. workaround. :)

    regards
    Meik
     
    Meik Langwald, Jul 11, 2004
    #22
    1. Advertisements

  3. Hi,

    (follow up only to coln)

    IMHO 2.4 had the first really usable NFS implementation for Linux. ;-)

    I posted a description how to reproduce my problem. It should be fairly
    simple if you have at least one Linux and one Solaris box. And it would
    be good to hear somebody else was able to reproduce it.

    It would be interesting to hear some opinions, if this can be considered
    a bug (and addressing it to a vendor like Suse or Redhat to fix it) or
    if it's more like a missing feature, which will be added hopefully in a
    future kernel release.

    regards
    Meik
     
    Meik Langwald, Jul 11, 2004
    #23
  4. Hi,

    I didn't knew that Solaris (or NFS generally) can do this, but it's used
    when installing Solaris boxes with Jumpstart and Flash archives (archive
    files can be mounted by NFS). And we want to drop this flash archive
    file on a Linux box. But if the Jumpstart process cannot access it
    there, we're probably in trouble. :-/

    regards
    Meik
     
    Meik Langwald, Jul 12, 2004
    #24
  5. Don't know, how can I verify that?

    regards
    Meik
     
    Meik Langwald, Jul 12, 2004
    #25
  6. Casper, what does "ir" stand for?

    Dragan

    --
    Dragan Cvetkovic,

    To be or not to be is true. G. Boole No it isn't. L. E. J. Brouwer

    !!! Sender/From address is bogus. Use reply-to one !!!
     
    Dragan Cvetkovic, Jul 12, 2004
    #26
  7. Oh, that's some left-over from when I first joined Sun; it was short
    for something like "information resources", the then current name for
    the internal IT infrastructure organization (I worked in the
    security group).

    Casper
     
    Casper H.S. Dik, Jul 12, 2004
    #27
  8. Thanks. I guess "information resources" contains as much information as
    e.g. "a member of technical team" seen quite often here...

    Dragan

    --
    Dragan Cvetkovic,

    To be or not to be is true. G. Boole No it isn't. L. E. J. Brouwer

    !!! Sender/From address is bogus. Use reply-to one !!!
     
    Dragan Cvetkovic, Jul 12, 2004
    #28
  9. Any ideas how to get around this? I need this feature, otherwise the
    ISTR it is to do with the version of the C libraries on the machine.

    SuSE 9 and up will def. deal with files > 2GB without issue.

    The problem is with the local file IO and not NFS - to verify, try creating
    a > 2GB file on your problem client.

    Cheers

    Alex
     
    Alex Harrington, Jul 12, 2004
    #29
  10. Hi Alex,

    (F'up to coln, because this is getting more and more only Linux specific)

    Yes, I suspected that, too. Problems with a 2GB limit seems to have gone
    since kernel 2.4. I tried to create 3gb big files by NFS on Linux boxes,
    that worked without any problem. I can also access 3GB files by NFS, if
    I mount a directory.

    I didn't try to mount a file by NFS from Linux to Solaris with Suse 9.1,
    but I tried it with Suse SLES8 (Kernel 2.4 and glibc 2.2) and Debian
    sarge (Kernel 2.6 and glibc 2.3), the latter should be fairly similar to
    Suse 9.1. I got exactly everytime the same error message.

    regards
    Meik
     
    Meik Langwald, Jul 12, 2004
    #30
  11. Hi Michael,

    Mounting a 2mb+ file from Linux to Solaris works, nfsstat shows on both
    sides only v3 communication.

    Mounting a 2gb+ file from Linux to Solaris does not work, nfsstat shows
    on both sides no nfs communication, neither v3 nor v2.

    I traced the communication during the mount operation with ethereal.
    It's just six packets, three requests from the Solaris box and the three
    corresponding responses from the linux box (get port for mount service
    from portmap, null mount, mount with filename). The last response just
    contains the error code 13 (ERR_ACCESS).

    If I retry this with a smaller file, the response to the mount request
    has the return code 0 (Status OK) and a file handle attached.

    All mount calls are version 3. Both files have the same user and access
    rights.

    So, I investigated everything a little bit deeper, but without a
    solution. Is the next step analysing Linux kernel source, or some other
    ideas?

    regards
    Meik
     
    Meik Langwald, Jul 12, 2004
    #31
  12. Yes, but flash is not limited to the core Solaris product. In this case
    the flash archive contains a weekly snapshot of the /, /var and /opt
    (partitially) filesystems. There is some 3rd party software installed,
    but /var makes a good deal of the whole archive, too.

    Even if we could establish a 2gb limit on the flash archives, the whole
    thing looks like a generic problem to me. Even if it's
    Yes, I can do that. But the jumpstart framework mounts the file directly
    and not the directory with the file. I'd prefer a fix on the (IMHO
    broken) linux side over a hack in some jumpstart scripts (if this mount
    is not done in an compiled executable).
    It's a little surprising for me, but right now it looks like nobody ran
    into this before.

    Maybe because the flash utilities in Solaris 8 (don't know about 9) had
    problems with archives growing bigger than 4gb uncompressed until quite
    recently. So "best practice" was to use very small flash archives and
    stay below the 2gb file limit.

    regards
    Meik
     
    Meik Langwald, Jul 12, 2004
    #32
  13. Perhaps Linux mountd doesn't deal with large files properly?

    Casper
     
    Casper H.S. Dik, Jul 13, 2004
    #33
  14. Meik Langwald

    Dave Uhring Guest

    So create a flash archive of the OS and another for the apps and data.
    Linux ext3fs can easily deal with the 3GB file so the problem lies, as
    Casper suggested, with Linux mountd or perhaps the kernel itself. I only
    have one Linux box working here so I can't test mounting a 3GB file Linux
    to Linux to see if even that works. Have you tried that?
    You know it would not cost very much to just build a Solaris x86 machine
    or purchase a used Ultra to set up your install server. Good Ultra-1
    workstations, also usable as servers, can be found on ebay for less than
    $50 USD, although you might need to install a larger HDD and more memory.

    But I see you are in Germany. Why not check http://ebay.de and see if
    something meeting your needs is available? Used Ultras are available
    there but they are somewhat more expensive than in the US. Still EUR 100
    is not unreasonable for a reliable jumpstart server.
     
    Dave Uhring, Jul 13, 2004
    #34
  15. You could try using tftp:// or http:// to access the flash image,
    rather than nfs://

    - Jeremy
     
    Jeremy Harris, Jul 15, 2004
    #35
  16. Hi Dave,

    Yes, that seems to be one of the better "workarounds".
    No, from what I tried out, Linux is unable to mount files at all. Maybe
    it's because of the implementation of the loop option of mount, maybe
    only nobody stumbled over this feature in Solaris and found it usefull
    enough to implement in Linux. With Linux you can only mount directories.
    I know, but another (even it it's used) box is not yet an option.

    regards
    Meik
     
    Meik Langwald, Jul 15, 2004
    #36
  17. Hi Casper,
    That's exactly what I suspect. I digged around in sunsolve and found a
    patch 111197-02, which fixes a similar problem for Solaris. (The patch
    is included in Solaris 8 update 2/02, which is used here.)

    regards
    Meik
     
    Meik Langwald, Jul 15, 2004
    #37
  18. Meik Langwald

    Dave Uhring Guest

    If my other suggestion, to set up another Solaris SPARC/x86 boot server,
    doesn't work out you are just going to have to work around the limitations
    of Linux.
    I don't know what downtime of your server would cost, apparently more than
    you wish to expend, but the cost of setting up another Solaris machine is
    really only a few hundred Euros for the hardware and OS and only several
    hours of labor.

    Additionally, if you set up another Ultra server you would also have
    hardware redundancy.
     
    Dave Uhring, Jul 15, 2004
    #38
  19. Hi Dave,

    Yes, but it's not on me to take that decision. Using a dedicated box
    with Solaris x86 would be another possible solution for the goal of the
    whole project (get the Solaris box fast up and running after a crash).
    But this decision was out of my scope.

    And I'm still hoping that there will be a fix for the mountd problem.
    All the suggestions (use another box, use another protocol, split
    archive, etc) are just workarounds.

    regards
    Meik
     
    Meik Langwald, Jul 15, 2004
    #39
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.