Network device is gone -no such device

Discussion in 'Linux Networking' started by Bryce, Apr 20, 2004.

  1. Bryce

    Bryce Guest

    During the last few months my Suse 9.0 (Kernel 2.4.21-144-default)
    worked perfect. I have an Elitegroup K7S5A board. I enabled the SIS
    internal NIC and added an Intel e100 card. Both worked fine for about
    3 months. eth0 was for the internal network (fixed IP) and eth1 for a
    DHCP one.

    All at a sudden my eth1 (e100) went away after reboot. lsmod shows
    that e100 is still there. I cannot remove it. I did not change
    anything at that time.
    Then in Suse I removed the eth1 (e100) NIC, reboot and added it again.
    Voila, the eth1 was up again with an address of DHCP. So I rebooted
    again(ok, ok...) then the eth1 disapeared again. A boot with the
    Knoppix CD showed a similar effect. But strange enough, even if I get
    temporarily an IP address from the DHCP server on eth1, I could not
    ping a known internet address.
    Any ideas? (Don't forget, it worked just fine for about 3 months...)

    Bryce
     
    Bryce, Apr 20, 2004
    #1
    1. Advertisements

  2. On 20 Apr 2004 13:28:21 -0700
    It happened to me once that I had to throw away 3 NIC after a
    thunderstorm. Check the card on another box and see what happens.

    Greets
    Chris
     
    Christoph Scheurer, Apr 21, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.